Jump to content
racemaniac

Bepaalde links in e-mails naar klanten werkt niet

Recommended Posts

PS 1.6.014

In  alle e-mails die naar klanten verzonden worden werkt de url die men kan aanklikken voor bijvoorbeeld account-overzicht en de shopurl   niet

 

Ik heb de originele contact_form.htm via ftp ge-upload, echter  zodra je de verzonden (ontvangen)  mail bekijkt en in de footer de link wilt aanklikken staat er als URL  alleen {shop_url}  en dus niet de daadwerkelijke url van de shop. Als je de url aanwijst zie je dus als tekst verschijnen {shop_url} 

Blijkbaar wordt de variabele niet juist vanuit de database ingelezen

Dit is dus ook het geval indien met het mail-form voor het wijzigen / opvragen van het wachtwoord  ontvangt.

Bij het contact formulier/mail  is dit het geval in de gebruikers/klanten mail  als de mail die ontvangen wordt naar het beheer

 

contact_from.html :
 

<td class="footer" style="border-top:4px solid #333333;padding:7px 0">
<span><a href="{shop_url}" style="color:#337ff1">{shop_name}</a> powered by <a href="http://www.prestashop.com/" style="color:#337ff1">PrestaShop™</a>
 
Voor de goede orde, ik heb dus alleen de Nederlandse taal geactiveerd
de originele engelse contact_html heb ik naar naar de mails/nl gekopieerd
 

Share this post


Link to post
Share on other sites

Even voor de duidelijkheid, je footer zegt ps 1.5.6.2 en je post zegt 1.6.0.14 - welke gaat het om?

Share this post


Link to post
Share on other sites

post-346276-0-56669500-1432417254_thumb.jpg

 

post-346276-0-58021000-1432417458_thumb.jpg

 

Deze screenprints geeft te zien dat de aanroep binnen de email template  contact en contact_form  wat verminkt worden

in plaats van de { en }   worden de hexcode %7B  en %7D  gebruikt.

Indien ik dit aanpas en opsla blijkt dat de aanpassing dus niet doorgevoerd wordt

 

Share this post


Link to post
Share on other sites

hier hetzelfde probleem, doordat ik aanpassingen aanbracht in LOCALISATIE--VERTALINGEN--VERTALINGEN AANPASSEN

zijn de links toe toegevoegd zijn in mijn email naar de klant niet juist  , inderdaad, de tekens { en } zijn vervangen.Als ik ze aanpas en opsla lukt het niet

 

Een voorbeeld:  normaal moet het zijn:   {my_account}  maar bij mijn broncode staat er  :   7bmy_account_url%7d

 

 

ik moet zeggen, ben verre van een html kenner....

mocht er iemand kunnen helpen, u zou mij heel gelukkig maken....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More