Jump to content

Recommended Posts

Hoi nogmaals.

 

De configuratie zegt het volgende:

 

Verplichte parameters Repareer aub de volgende fout(en)

Optionele parameters Oké

 

Dan onderin staat:

 

Overzicht van aangepaste bestanden
Veranderde/missende bestanden zijn gevonden
Bijgewerkte bestanden (268)

 

Ik heb debugmode en aan staan dat errors weergegeven moeten worden. Maar ik zie verder geen fouten. Hoe kan ik dat zien? :)

 

Share this post


Link to post
Share on other sites

Laat maar. De fouten staan dus alleen op de pagina waar een product in staat:

 

 

Notice: Use of undefined constant _PS_PRICE_COMPUTE_PRECISION_ - assumed '_PS_PRICE_COMPUTE_PRECISION_' in /mnt/webr/e0/82/54616482/htdocs/modules/socialsharing/socialsharing.php on line 169

Warning: round() expects parameter 2 to be long, string given in /mnt/webr/e0/82/54616482/htdocs/classes/Tools.php on line 1592

Notice: Use of undefined constant _PS_PRICE_COMPUTE_PRECISION_ - assumed '_PS_PRICE_COMPUTE_PRECISION_' in /mnt/webr/e0/82/54616482/htdocs/modules/socialsharing/socialsharing.php on line 170

Warning: round() expects parameter 2 to be long, string given in /mnt/webr/e0/82/54616482/htdocs/classes/Tools.php on line 1592

Heeft dus iets met social sharing te maken maar wat ik ermee moet doen?

Share this post


Link to post
Share on other sites

Hij geeft nu nog maar 1 fout aan:

 

 

Warning: round() expects parameter 2 to be long, string given in /mnt/webr/e0/82/54616482/htdocs/classes/Tools.php on line 1592

Warning: round() expects parameter 2 to be long, string given in /mnt/webr/e0/82/54616482/htdocs/classes/Tools.php on line 1592

Twee keer zelfde melding achter elkaar.

 

Iemand een oplossing?

Share this post


Link to post
Share on other sites

Deze fout betekent dat er een bedrag afgerond wordt, maar dit bedrag is geen number, maar tekst. Gebruik je een eigen template die iets berekent ofzo?

Share this post


Link to post
Share on other sites

Ik gebruik een template die ik gekocht heb. Sagitta. Of die iets berekend? Ik heb geen idee eerlijk gezegd. Kan ik dat zien?

Share this post


Link to post
Share on other sites

Niet direct, dat kan op meerdere plekken gebeuren. Ik wil eventueel wel even voor je kijken (maar dan heb ik FTP gegevens nodig en een admin login+beheerurl).

 

Deze mag je me sturen via Messenger hier op het forum.

  • Like 1

Share this post


Link to post
Share on other sites

Idem :) Ik hoop er vanavond aan toe te komen anders morgen wel.

 

Let me know!

  • Like 1

Share this post


Link to post
Share on other sites

Hoi Peter,

 

Thanks - ik heb even gekeken en het blijkt hem te liggen aan een van je modules.

 

Ik heb de foutmelding getraced naar het moment voordat de pagina op het scherm verschijnt.

De content uit module positie "displayHeader" gaat iets niet goed.

 

Mijn verwachting is (na snel even gekeken te hebben) dat je POS Slideshow of je Revolution slider oid het probleem zijn. 

 

Je zou dit het beste zelf kunnen uitproberen > Back office > modules > posities en dan even zoeken naar "displayHeader", daar gaat iets niet goed dus probeer (niet-prestashop-eigen) modules aan en uit te zetten op die positie.

 

Good luck ;)

Share this post


Link to post
Share on other sites

Yep, reden dat ik niet ben gaan zoeken is omdat ik de modules niet ken, en daardoor kan het zijn dat ik je installatie / template om zeep help e.d.

 

Het slimste zou zijn  om gewoon een database backup te maken, modules een voor een uit de displayheader positie te halen, en als je de boosdoener hebt gevonden je backup terug zetten - dan kun je vervolgens 1 module uitzetten en klaar :)

Share this post


Link to post
Share on other sites

Puur voor zekerheid maar echt alleen backup van de database? Als ik die dan weer terugzet staan alle modules er weer in en aan? Geen backup van de server?

Share this post


Link to post
Share on other sites

Een backup van de database zou goed moeten zijn (mits je modules gaat verwijderen via prestashop, in plaats van uitzetten). Als je modules verwijdert dan worden de files ook gewist. Wil je 100% safe zijn doe dan beide (raad ik overigens altijd aan).

 

Suc6!

Share this post


Link to post
Share on other sites

Tuurlijk is er nu precies een storing bij mijn hoster zodat ik niet op de database kan komen. Hopelijk vana nog opgelost...

Share this post


Link to post
Share on other sites

1e module die ik uitschakel was meteen raak. Het gaat om Sociale Delen. Wat kan nu dan de reden zijn dat die een foutmelding maakt?

Share this post


Link to post
Share on other sites

Verplichte parameters Repareer aub de volgende fout(en)

 

Staat er nog wel. Kan dat te maken hebben met het feit dat ik errors nog laat zien?

 

Ik zie verder nergens nog fouten...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More