Jump to content

Problem with layered navigation and product options


sh3ppard
 Share

Recommended Posts

Hello. I'm gonna sell games so I've set in product options the game platform (I have ps3,ps4,pc and so on).

When I go to games and click on the PS4 option in platform it redirects me, but does not filter and just shows all the products in the category, but if i click in the square next to the name of the platform it filters normaly. I have this bug only with this option. Other platforms work great, other options like genre work great. Just the PS4 platform option has this problem, when i set direct link from the top menu to filter PS4 it just shows all.

I tried renaming the option and the state but stil no luck. Noticed that the others states' id is from 20 to 500 but the ps4 one is 998 maybe that's where the issue comes from.

 

Here is link to the site : http://www.gamingtech.bg (it's still not finished)

PS3 platform filter works - http://www.gamingtech.bg/igri#/platforma-ps3

but PS4 filter does not - http://www.gamingtech.bg/igri#/platforma-ps4

 

Thank you !

Share this post


Link to post
Share on other sites

Not sure where this silly thing comes from, but can you try something for me?

 

Can you change the name of your PS4 product from

 

     ps4-mkx     (ps4 at the beginning)

 

to

 

    mkx-ps4    (ps4 at the end)

?

 

(I want to see if the PS4 at the beginning of the name, which is exactly the same as the platform name PS4, has anything to do with it.)

 

Let me know the result,

pascal.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Seems like when the product option id is more then 900 or so it won't work. Every option's id that is more than that doesn't work. I hope i'm not the only one facing this issue, otherwise I would have to start all over again.

 

EDIT: on a new site it's the same

Edited by sh3ppard (see edit history)

Share this post


Link to post
Share on other sites

Decided to create a new shop - gamingtech.bg/presta , deleted all the product features and created a new one called "model" - gave it 2 values "1" and "2", assigned each one to 2 products, fixed the layered navigation module to display this feature and the same thing 

When i click on "1" it shows the product, but if i copy the link it doesn't show on the new tab

And if i click on the name of feature "2" it shows all the products and i need to click the box to filter

 

gamingtech.bg/presta/admin123 

[email protected]

adminpassword

 

I haven't installed any modules or change any settings or mess with sql

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More