Jump to content

Aiuto ho fatto un pasticcio errore 404


Nefas
 Share

Recommended Posts

Ciao a tutti ho fatto un casino e non riesco a capire il perche'. Premetto che non sono un' esperto, ho un dominio e spazio su Aruba, ho istallato Prestashop dal mio pannello di controllo tramite l' application installer, fin qui tutto ok, sto creando il sito e leggendo unpo qua e la sono quasi riuscito a finirlo, dal momento che sono un venditore Eb*y ho delle immagini all' indirizzo es: www.miodominio.com/foto, tutte le foto dei miei articoli sono in questa cartella ma mi sono accorto aprendo le inserzioni che le foto non le visualizza piu dandomi quest' errore:

Not Found

The requested URL /prestashop/foto/nomefoto.png was not found on this server.

 

ora e' ovvio che non me le apre in quanto la root e' sbagliata dato che le foto non stanno nella cartella /prestashop ma stanno nella root prencipale in foto, il tutto da quando ho istallato presta, come mai? Praticamente mi vede la cartella foto come una sottocartella di prestashop, ma non e' cosi!

Spero qualcuno mi aiuti, grazie.

Share this post


Link to post
Share on other sites

Ok, allora ho risolto in parte nel senso che ho aperto il file htaccess, e stava:

 

RewriteEngine On #created by aruba do not touch this file!
#ATTENTION: Remove file index.(php|html|htm)
RewriteCond %{REQUEST_URI} !^/prestashop
RewriteRule ^(.*)$ prestashop/$1 [L]

 

Dato che no capisco quasi na sega :D ad intuito ho cancellato la parola prestashop e quindi :

 

RewriteEngine On #created by aruba do not touch this file!
#ATTENTION: Remove file index.(php|html|htm)
RewriteCond %{REQUEST_URI} !^/
RewriteRule ^(.*)$ /$1 [L]
 

Ora nelle inserzioni di Eb*y le immagini le visualizzo ma se digito il dominio, il sito non me lo apre piu' almeno che io non digiti www.miodominio.com/cartella_del_sito, qualcuno puo' aiutarmi a risolvere? Grazie.

Share this post


Link to post
Share on other sites

Risolto cosi: RewriteEngine On #created by aruba do not touch this file!

 

#ATTENTION: Remove file index.(php|html|htm)
RewriteCond %{REQUEST_URI} !^/
RewriteRule ^(.*)$ www.miodominio.xxx/$1 [L]

 

ora funziona.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More