Jump to content
Azachow

[resolvido] Problema na finalização de pagamento com o módulo pagseguro

Recommended Posts

Ola pessoal estou usando a versão 1.6.0.14, junto a versão oficial do presta shop.

 

E estou co um problema na finalização do pagamento, o botão confirmar esta sem link pelo que parece. 

 

 

post-989122-0-41604900-1431110632_thumb.jpg

post-989122-0-68341000-1431110814_thumb.jpg

Share this post


Link to post
Share on other sites

Não estou conseguindo criar tópico no forum!

vou tentar aproveitar esse aqui que tem o assunto parecido

 

 

então o modulo do pagseguro não funciona quando o HTTPS está ativado, na hora de finalizar a compra, aparece essa tela.

20576ep.jpg

 

ai quando eu clico em "CONFIRMO MINHA COMPRA" ele da esta mensagem , Este método de pagamento não está disponível!

 

isso com o HTTPS.

 

já quando uso http normal sem SSL, ai tudo finaliza a compra, alguém sabe como faço pra resolver isso ? to deis de semana passada tentando fazer funcionar e não consigo, eu já tentei modificar no código do modulo, mais não tive sucesso.

Share this post


Link to post
Share on other sites

Não estou conseguindo criar tópico no forum!

vou tentar aproveitar esse aqui que tem o assunto parecido

 

 

então o modulo do pagseguro não funciona quando o HTTPS está ativado, na hora de finalizar a compra, aparece essa tela.

20576ep.jpg

 

ai quando eu clico em "CONFIRMO MINHA COMPRA" ele da esta mensagem , Este método de pagamento não está disponível!

 

isso com o HTTPS.

 

já quando uso http normal sem SSL, ai tudo finaliza a compra, alguém sabe como faço pra resolver isso ? to deis de semana passada tentando fazer funcionar e não consigo, eu já tentei modificar no código do modulo, mais não tive sucesso.

Qual o endereço para vermos o problema (com SSL ativado)?

Share this post


Link to post
Share on other sites

Não consegui acessar.
Aparece uma mensagem de IP na BlackList e redireciona para outro site.

Deve acontecer o mesmo com o PagSeguro.

 

Verifique este problema com o seu host

Share this post


Link to post
Share on other sites

engraçado, primeira vez que alguém não consegue acessar o site, pois estou montando ele ainda e peço pra uns amigos testarem e nunca deu isso! será que isso pode ser alguma configuração de região do prestashop ? ou e host msm ?

 

sobre o pagseguro creio que não seja isso, porque quando esta só http ele funciona normal, quando vou no console do chrome mostra que o modulo faz uma requisição em um link pra validação, parece que o modulo e configurado pra sempre por http nesse link.

25jf3bt.jpg

 

eu já encontrei a parte no código onde aparece esse link, que no caso seria aqui.

private $paymentUrl = 'index.php?fc=module&module=pagseguro&controller=validation';

 

ele passa o endereço do meu site por essa variável  $paymentUrl e eu não conseguir fazer funcionar, pois ele só passa o http precisaria passar o https  eu não sei de onde essa variavel esta pegando o link.

Share this post


Link to post
Share on other sites

Atualize a versão do módulo do PagSeguro para ver se o problema se resolve.

(link do GitHub no post anterior)

 

 

amigo perfeito! eu não tinha prestado atenção no link do GitHub , essa versão 1.9 ficou filé de mais! ela da a opção de alterar os links. eu achava que estava usando a ultima versão do modulo, porque baixei esses dias direto do site do prestashop. agradeço de mais a sua ajuda viu! muito obrigado.

Share this post


Link to post
Share on other sites

Amigos,

Aproveitando o tópico, estou tendo o mesmo problema. Porém utilizo a versão 1.6.1.3 e ele não me permite mais eu subir o arquivo do GitHub. Como posso importar essa nova versão?

 

Abs

Share this post


Link to post
Share on other sites

Estou com o mesmo problema, ele abre o formulário index.php?fc=module&module=pagseguro&controller=validation  sem o https.

Mesmo forçando o uso do SSL no site todo, somente esse formulário fica sem e com isso fica gerando aviso de alerta nos navegadores.

Como arrumar esse problema?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More