Jump to content

Localhosttan ftp site taşıma problemi


motobros
 Share

Recommended Posts

Sitemi localhostta hazırlıklarını yaptım ve ftpden yükleme işlemine geçmiştim herşey iyi güzel gidiyordu fakat siteyi taşıdıkdan sonra sql bilgilerini settings.ini dosyasına yazdım ve hostuma oluşturdugum sql içine içe aktar yaptım. ama bir yerlerde hata yapmış olmalıyım çünkü domain adını yazınca otomatikman localhosttan siteye bağlanıyor ve admin paneli sayfasına ulaşmaya çalıştığımda resimdeki gibi bir ekran önüme çıkıyor tema problemi varmış gibi gözüküyor ama neden böle bişey oldu anlamış değilim.ama bundan ziyade problemim domain ismimi yazdığım da direk otomatik olarak local hosttan bağlanıyor. settings.ini dosyasında mı bi yanlıslık yaptım acaba ?? 

 

<?php

define('_DB_SERVER_', 'localhost');
define('_DB_NAME_', 'DATABASE ISMINI YAZDIM');
define('_DB_USER_', 'DATABASE KULLANICI ADINI YAZDIM');
define('_DB_PASSWD_', SIFREMI YAZDIM');
define('_DB_PREFIX_', 'ps_');
define('_MYSQL_ENGINE_', 'InnoDB');
define('_PS_CACHING_SYSTEM_', 'CacheMemcache');
define('_PS_CACHE_ENABLED_', '0');
define('_COOKIE_KEY_', 'xehFeT2tGFVeZXpBG6pA78yI0OWm9a2OMnCMbjky3gts758Zu0dMhIYQ');
define('_COOKIE_IV_', 'QsQ4dso4');
define('_PS_CREATION_DATE_', '2015-03-23');
if (!defined('_PS_VERSION_'))
define('_PS_VERSION_', '1.6.0.12');
define('_RIJNDAEL_KEY_', 'InpHdaLXGuOQZtNPtawLdjZtVoENNtwZ');
define('_RIJNDAEL_IV_', '+HTFvLAhO4a9CqlAyHZ68Q==');
 
müdahale etttiğim yerler haricinde diğer yerleri oldugu gibi biraktım nerde yanlıslık yapmıs olabilirim ??
şimdiden teşekkürler.
 

mGAAW4.jpg

Share this post


Link to post
Share on other sites

Şimdi sql içinde ps_shop_url içindeki tabloda domain ve domain_ssl olan kısma domain adımı yazdım psycial olan yeri boş bıraktım ve şuan admin panelimin görüntüsü düzeldi fakat şimdide web siteme girmeye çalıştığım da http://siteadım.comindex.php/ bu şekilde bir hata çıkıyor karşıma fakat ben url ye index.php gibi bir uzantı atamadım neden böyle bir problem çııktı anlamış değilim. Ayrıca kayıp şifre isteği dediğimde de admin panele girerken herhangi bir tepkime olmuyor taşıma işleminde bir sıkıntımı oldu acaba ? olduğu gibi taşıdım siteyi

Share this post


Link to post
Share on other sites

Aşağıdaki işlemleri sırayla yapın....

 

Altta verdiğim kodları myadmin de sıra ile sql alanında çalıştırın....

UPDATE ps_shop_url SET `domain`='www.siteadi.com';
UPDATE ps_shop_url SET `domain_ssl`='www.siteadi.com';
UPDATE ps_shop_url SET `physical_uri`='/';

0fnemHL.png

Share this post


Link to post
Share on other sites

  • 1 year later...

Arkadaslar bütün islemleri dogru yaptigim yaptigimi düsünüyorum ama asagidaki uyariyi aliyorum.

Not Found

The requested URL /www.domainim.com was not found on this server.

Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze19 with Suhosin-Patch Server at http Port 81
Localde Appserv kullaniyorum port 81 ayarlamistim. sanirim problem bundan kaynaklaniyor eger bundansa bu portu nerden duzeltebilirim
tesekurler.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More