Jump to content
des2006

Turn on Friendly URL get errors

Recommended Posts

Hi,

 

I am using PS1.6.0.14, upgraded from 1.6.0.13 by 1-click upgrade.  When I tried to turn on Friendly URL, 2 errors appeared:

 

1.  The route is not valid

2.  Route to modules:  Incorrect value

 

The route to modules  is default at :  module/{module}{/:controller}

 

When the errors still appeared, I pressed the save button again and it could be saved.  The friendly URL seems able to work on the front office.   Could anyone help advise if it is normal or bug?

 

Many thanks!

Share this post


Link to post
Share on other sites

Ditto. An error message is never normal. Would like to know:

 

(1) if something is wrong and needs to be fixed, or

(2) if nothing is functionally wrong, then which piece of code needs to be fixed so that this error will not throw.

 

To reproduce:

  • On a default, clean install of 1.6.0.14 (in my case, a clean upgrade to 1.6.0.14 from 1.4.11.0)
  • Friendly URL needs to be turned OFF initially, AND
  • You must enter SEO & URLs screen from a different page (not by toggling the setting back and forth and Saving)
  • Turn Friendly URLs ON
  • Hit Save

 

Error (screenshot attached):

 

2 errors 

  1. The route is not valid
  2. Route to modules : Incorrect value

 

post-964386-0-97484100-1427953233_thumb.png

Edited by finlanderid (see edit history)

Share this post


Link to post
Share on other sites

What are the url (meta) on the screen above... list them all apparently 2 of them are causing issues.

Share this post


Link to post
Share on other sites

Thanks for your reply. Please disregard my problem.

 

My error was happening because of a rewrite customization I made in v1.4.11.0 (before I upgraded recently to v1.6.0.14). In v1.4.11.0, I created a rewrite entry in the database for the index.php page. I forget the reason I did that. Probably to easily edit the meta tags or something. I can't remember. Anyway, these errors in 1.6.0.14 may be caused by that rewrite entry, for index.php, in the DB table.

 

I think I can just ignore it, because no rewrite for index.php is actually occurring. It is the root of the store and correctly resolves to the domain name. Like I said, I think I simply created the DB table entry in order to edit the meta tags. Everything else seems to be working fine. I will keep an eye on things in case it causes a problem.

 

I should add: I also created Controllers for custom modules (when I was using v1.4.11.0), like the old FAQ module, so that I could access the rewriting engine for the URL for the custom module. For example, if you do it that way, then you can have custom module URLs look like this:

 

    www.example.com/faqs

 

Instead of like this:

 

    www.example.com/modules/faqs/faq.php

 

I still have those entries in the 1.6.0.14 DB table after upgrading, so these errors might be occurring because 1.6.0.14 is looking for those modules, and I have not installed them on 1.6.0.14. 

 

If anyone else gets these errors, it's probably because of customizations to the rewrite system in a previous version of PS.

Edited by finlanderid (see edit history)

Share this post


Link to post
Share on other sites

For me, the problem comes from the insufficient rights on the htaccess file.
I have changed the original chmod (604) to 606 and solved the problem.

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

For me, the problem comes from the insufficient rights on the htaccess file.

I have changed the original chmod (604) to 606 and solved the problem.

You are a God! :D I had 666 and that blocked some modules :D

Share this post


Link to post
Share on other sites

@cooliyev how's that related to friendly urls? Images are broken once you turn on rewriting?

Share this post


Link to post
Share on other sites

@cooliyev how's that related to friendly urls? Images are broken once you turn on rewriting?

Yes that's right and appears 2 errors:

  1. The route is not valid
  2. Route to modules : Incorrect value

But I didn't change anything. I have tried to erase cache and changed chmod of htaccess to 604. But nothing help

Edited by cooliyev (see edit history)

Share this post


Link to post
Share on other sites

How does the route look like?
Is it images only being broken?

Share this post


Link to post
Share on other sites

The route is like default. I didn't change it.

Yes only images on the header doesn't show and pictures of product.

 

How does the route look like?

Is it images only being broken?

Share this post


Link to post
Share on other sites

You mean  you used an installer from your hosting? If so, and you didn't change any core file, I'd try replacing the whole classes and controllers folders with clean ones from a package you can get from prestashop.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More