Jump to content
inweb

[Module] Wordpress Blog Integration To Prestashop 1.3/1.4/1.5/1.6/1.7

Recommended Posts

hello,

 

I have a question.

Can i integrates WP with Prestashop if i don't have installed WP in a subdirectory only directory?

Share this post


Link to post
Share on other sites

I'm sorry for that, I don't speak english very well.

I have a wordpress site on domain (directory) www.klinikahorroru.pl and prestaShop on subdomain (subdirectory) www.sklep.klinikahorroru.pl

So can i integrates WP with Prestashop if i don't have installed WP on subfolder /blog only to home domain and prestashop to subdomain?

Share this post


Link to post
Share on other sites

It's not possible to do that due to technical limitation of the browsers.

Share this post


Link to post
Share on other sites

A new update of the PrestaShop Theme Provider module & WordPress Integration plugin have been released! It mainly comes with better CGI support what resolves the most common case why integration did not work some times (PHP running via CGI with HTTP authorization). It is also able to identify a lot misconfigurations and other issues and makes troubleshooting much easier for everyone.

 

PrestaShop Theme Provider module 1.4.13

  • HTTP authorization support with PHP running via CGI was added (PHP 5.4 or later required)
  • Verbose troubleshooting messages were added
WordPress Integration plugin 1.4.13
  • WebAppsDetector class was updated

Share this post


Link to post
Share on other sites

Hi inweb,

I'm trying to install PrestaShop Theme Provider module 1.4.13 on my local wamp test pc with PS 1.6.1.1. But I can't install zend guard loader - > error : Failed loadind zend guard loader. Do you know if it is possible to install zend guard loader on wamp (php 5.5). Is it possible to avoid installing it ? thank you for your help.


Hi inweb,

I'm trying to install PrestaShop Theme Provider module 1.4.13 on my local wamp test pc with PS 1.6.1.1. But I can't install zend guard loader - > error : Failed loadind zend guard loader. Do you know if it is possible to install zend guard loader on wamp (php 5.5). Is it possible to avoid installing it ? thank you for your help.

... As it is on a local pc, I can't provide ftp access to you

Share this post


Link to post
Share on other sites

Yes it is possible to install ZGL on the WAMP server. All you need to do is to adjust php.ini file as described in the attached README.txt file that come with ZGL.

Share this post


Link to post
Share on other sites

Yes it is possible to install ZGL on the WAMP server. All you need to do is to adjust php.ini file as described in the attached README.txt file that come with ZGL.

 

Thank you for your response. That's what I did, I added both lines

       zend_extension=<full_path_to_ZendLoader.dll>

       zend_extension=<full_path_to_opcache.dll>

 

But i'm getting the failed loading errors. I can see in the readme.txt, that the ZGL should work using   : Windows non-thread safe. I think that wampserver is installed with thread safe. How can I make it work ?

Should it be more simple using ioncube loader ?

Share this post


Link to post
Share on other sites

To make it work with WAMP (2.5):

  • Download ionCube Loader at https://www.ioncube.com/loaders.php: Windows VC11 (32 bits) or Windows VC11 (64 bits)
  • Extract the package and place the appropriate ioncube_loader_win_5.5.dll file to C:\wamp\bin\php\php5.5.12\zend_ext\ directory.
  • Edit C:\wamp\bin\php\php5.5.12\phpForApache.ini file and add to the bottom:

    zend_extension=C:\wamp\bin\php\php5.5.12\zend_ext\ioncube_loader_win_5.5.dll
  • Restart WAMP and you are done.
Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

Hello,

Does this module support prestashop 1.6.1.1?

 

Lastly, please advise, what are some of the advantages of using wordpress as my eCommerce blog instead of prestashop blog module?

 

I will be happy to hear from you soon

 

Thank you

Ronnie

Share this post


Link to post
Share on other sites

PrestaShop Theme Provider module is compatible with PrestaShop 1.3/1.4/1.5/1.6 including the latest PrestaShop 1.6.1.1 (the demo web site at demo.inveostore.com/prestashop16/blog/ is built on this version).

 

 

WordPress is a free and open-source content management system. Features include a plugin architecture with over 40,000 plugins available at the WordPress plugin directory: https://wordpress.org/plugins/ It means that once you integrate WordPress with your web site you will get a blog module with UNLIMITED features. Since WordPress is the most popular blogging system in use on the Web, at more than 60 million websites (according to Wikipedia), the community is huge and you will get always a top notch support with any problem you may have.

Share this post


Link to post
Share on other sites

Hello,

Thanks for your quick reply and i wish that all prestashop developers/community members respond the way. Back to my issue. Is there also a way to display wordpress other plugin products like wordpress booking plugin in prestashop  and do the booking on my prestashop site while the booking plugin is on wordpress? because i have noted that there are very many wordpress plugins for everything and most of all very affordable to buy such as; booking plugins, rent/hire plugins, sell music plugins,etc.

 

Lastly how about making it possible to login into wordpress through prestashop? such that when some one login to prestashop and with the integration of your module, does not need to login to wordpress again if he/she has to buy something running on my wordpress installed in a sub-domain.

 

Your advise on this will be highly appreciated

 

Thank you

Ronnie

Edited by ronelgon (see edit history)

Share this post


Link to post
Share on other sites

To make it work with WAMP (2.5):

  • Download ionCube Loader at https://www.ioncube.com/loaders.php: Windows VC11 (32 bits) or Windows VC11 (64 bits)
  • Extract the package and place the appropriate ioncube_loader_win_5.5.dll file to C:\wamp\bin\php\php5.5.12\zend_ext\ directory.
  • Edit C:\wamp\bin\php\php5.5.12\phpForApache.ini file and add to the bottom:

    zend_extension=C:\wamp\bin\php\php5.5.12\zend_ext\ioncube_loader_win_5.5.dll
  • Restart WAMP and you are done.

 

 

Hello,

 

Thank you for your help, I've been able to install ioncube on my WampServer.

 

Now I encounter an issue with activation. I can activate my S/N as developpement site, but when it gets back to the modules page (after a few seconds) I must activate it again. (Click here to activate). Note that I'm testing on a local machine with WampServer. What's going wrong, please ?

Share this post


Link to post
Share on other sites

Hello,

Thanks for your quick reply and i wish that all prestashop developers/community members respond the way. Back to my issue. Is there also a way to display wordpress other plugin products like wordpress booking plugin in prestashop  and do the booking on my prestashop site while the booking plugin is on wordpress? because i have noted that there are very many wordpress plugins for everything and most of all very affordable to buy such as; booking plugins, rent/hire plugins, sell music plugins,etc.

We are afraid this is impossible (unless you would add such a feature to the selected plugin manually).

 

Lastly how about making it possible to login into wordpress through prestashop? such that when some one login to prestashop and with the integration of your module, does not need to login to wordpress again if he/she has to buy something running on my wordpress installed in a sub-domain.

This is definitely possible to develop using the standard WP and PS API. However, it is outside of the scale of our solution - we fully focus to perfectly and smoothly integrate WP to PS (what requires quite a lot of magic coding and tricks) and we leave all such plugins to other developers. 

 

Now I encounter an issue with activation. I can activate my S/N as developpement site, but when it gets back to the modules page (after a few seconds) I must activate it again. (Click here to activate). Note that I'm testing on a local machine with WampServer. What's going wrong, please ?

What's the URL of your locally installed PrestaShop on WAMP? Thank you.

Share this post


Link to post
Share on other sites

 

What's the URL of your locally installed PrestaShop on WAMP? Thank you.

 

I'm using a local url : www.adp.fr

Share this post


Link to post
Share on other sites

It seems we found what's causing this glitch. Please re-download the PrestaShop Theme Provider module (you can use the same link) and re-upload it and then click the Activation link again. It should resolve the problem :)

Share this post


Link to post
Share on other sites

It seems we found what's causing this glitch. Please re-download the PrestaShop Theme Provider module (you can use the same link) and re-upload it and then click the Activation link again. It should resolve the problem :)

 

Thank you for your reply.

 

Now I can activate it. I've copied the api key into Wordpress plug-in (The PrestaShop Theme Provider module is connected!). But I can't get the header and footer from my PS 1.6. I'm using Twenty Fifteen theme

 

Other question : Does the free version can display the left column in  the blog page ?

Edited by kiteman (see edit history)

Share this post


Link to post
Share on other sites

Other question : Does the free version can display the left column in  the blog page ?

PrestaShop Theme Provider module FREE does not support that.

Share this post


Link to post
Share on other sites

PrestaShop Theme Provider module FREE does not support that.

 

thank you for your response. I understand that I will have to buy the full module for this feature. But I would like to be sure that it will work on my test local 1.6 PS. So, I think I've configured everything (in fact just the api key) but I can't get the headers and footers from PS.

Share this post


Link to post
Share on other sites

Please check the Private messages (click the "Messenger" link at the top right corner of this page) :-)

Share this post


Link to post
Share on other sites

hi

i will download worpress for presta

so

i buy wmoudle free wordpress and sing in in site

but i see not link for download

why?????????????????? :angry: :angry: :angry: :angry: :angry:

Share this post


Link to post
Share on other sites

Each order is validated by our staff. It means it may take up to 15 minutes to receive your download links (every customer is informed about this delay on the order confirmation page as well as in emails he receives when he submits an order).

 

If you did not receive your download links till now, please check your SPAM folder and let us know.

Share this post


Link to post
Share on other sites

I have used the module now, and it online here: fiskpaakrogen.dk/blog - can you tell me how to style it better, so it doesnt float out right? :)

Share this post


Link to post
Share on other sites

I INSTALL MOUDLE IN PRESTA AND PRESTA

AND RECIVE S/N AND API CODE

BUT AFTHER ACTIVE MOUDLE WORDPRESS NI DISPLAY WORDPRES

Share this post


Link to post
Share on other sites

I have used the module now, and it online here: fiskpaakrogen.dk/blog - can you tell me how to style it better, so it doesnt float out right? :)

  • WP admin - Appearance - Customize - Header - remove header image.
  • WP admin - Appearance - Customize - Site Identity - uncheck the "Display Header Text" option.
  • blog/wp-content/themes/twentythirteen/style.css file:

     

    Find:

     

    overflow-y: scroll;
    Replace with:

     

    /*overflow-y: scroll;*/
    Find:

     

    border-left: 1px solid #f2f2f2;
    border-right: 1px solid #f2f2f2;
    Replace with:

     

    /*border-left: 1px solid #f2f2f2;
    border-right: 1px solid #f2f2f2;*/
  • WP admin - Settings - WP Integration - check the "External Cascading Style Sheets" option and it will do the rest.

I INSTALL MOUDLE IN PRESTA AND PRESTA

AND RECIVE S/N AND API CODE

BUT AFTHER ACTIVE MOUDLE WORDPRESS NI DISPLAY WORDPRES

Please elaborate in English or post your link to your blog to see what's the problem.

Share this post


Link to post
Share on other sites

Hello,

I have tried several times to activate the module but the module has failed to work.Please give me simple steps to make it work for me too

 

Thank you

Ronnie

Share this post


Link to post
Share on other sites

In order to help you we will need to know the exact problem you are facing or link to your blog.

Share this post


Link to post
Share on other sites

 

  • WP admin - Appearance - Customize - Header - remove header image.
  • WP admin - Appearance - Customize - Site Identity - uncheck the "Display Header Text" option.
  • blog/wp-content/themes/twentythirteen/style.css file:

     

    Find:

     

    overflow-y: scroll;
    Replace with:

     

    /*overflow-y: scroll;*/
    Find:

     

    border-left: 1px solid #f2f2f2;
    border-right: 1px solid #f2f2f2;
    Replace with:

     

    /*border-left: 1px solid #f2f2f2;
    border-right: 1px solid #f2f2f2;*/
  • WP admin - Settings - WP Integration - check the "External Cascading Style Sheets" option and it will do the rest.

 

 

Hi. Thanks for the answer. I cant check the "external cascading style sheets" i cant check any of them :)

Share this post


Link to post
Share on other sites

The "External Cascading Style Sheets" option is a part of "Adjust CSS stylesheets" feature that instantly fix the design issues and the page layout of any WordPress template and is available only with the paid Theme Provider module. If you run a free version and you are facing CSS issue, you have to manually resolve them.

Share this post


Link to post
Share on other sites

Hello!

 

I've been trying to install your module and plugin to test it out, but I'm having a few issues.

 

I ended up installing ioncube instead of Zend Guard, but I think everything went fine.

 

My setup is on a local VM and both PS and WP are working perfectly on their own.

In PS's dashboard, the module isn't throwing any warnings, neither is the plugin on WP's dashboard.

 

I suspect something is wrong because at my PS frontend there is no "BLOG" option like in the demo. Did I forget or overlooked something? What would you need to be able to figure it out?

 

Thank you for your help,

 

João

Share this post


Link to post
Share on other sites

The PrestaShop Theme Provider module does not add any "blog option" to the frontend. What do you see on the demo web site is a regular link to the directory with WP (with WP Integration plugin installed) created by "Top horizontal menu" module.

 

What do you see when you click the link "Visit Site" at the top left corner in WP admin?

Share this post


Link to post
Share on other sites

We've updated the Downloads & Troubleshooting sections in the first post that help users with common issues :-)

Share this post


Link to post
Share on other sites

Does this module allow for full themes and customization of the Wordpress site in Prestashop? Also, can we remove the left navigation bar for more room for our Wordpress theme?

Edited by 69star (see edit history)

Share this post


Link to post
Share on other sites

Yes it allows WordPress original/full themes and supports all customization and plugins for WordPress.

Share this post


Link to post
Share on other sites

Removing the left or right column of the PrestaShop theme is supported (might require PAID PrestaShop Theme Provider module).

Share this post


Link to post
Share on other sites

HI

i install moudle in wordpress and prestashop

after  copy your code in ps and wp 

but after setup moudle in wp(wordpress) no display blog in wordpress

my wordpress : www.puzel.ir/blog

and no display in prestashop

post-899480-0-28091100-1449121115_thumb.png

post-899480-0-25653300-1449121116_thumb.png

post-899480-0-22203700-1449121337_thumb.png

post-899480-0-90507000-1449121338_thumb.png

Share this post


Link to post
Share on other sites

In order to help you with your issue, we need a public accessible URL to see it live.

Share this post


Link to post
Share on other sites

In order to help you with your issue, we need a public accessible URL to see it live.

you need accessible user/password for login to site

you need information prestashop or wordpress

Share this post


Link to post
Share on other sites

A new update of the PrestaShop Theme Provider module & WordPress Integration plugin have been released! It mainly resolves ionCube loader compatibility and PHP strict standards issues.

 

PrestaShop Theme Provider module 1.4.15

  • Certain issues with ionCube Loader were fixed
  • Complies with strict PHP standards again
WordPress Integration plugin 1.4.15
  • WebAppsDetector class was updated
  • WP 4.4 "Tested up to" tag
Merry Christmas everyone!

Share this post


Link to post
Share on other sites

The PrestaShop Theme Provider module does not add any "blog option" to the frontend. What do you see on the demo web site is a regular link to the directory with WP (with WP Integration plugin installed) created by "Top horizontal menu" module.

 

What do you see when you click the link "Visit Site" at the top left corner in WP admin?

 

Hi,

 

Thank you very much for this awesome module!!

 

I had same problem lol, I created a link to the WP Sub directory in the "Top Horizontal Menu" with label "Blog", but when you click it in PS it just opens the blog, as if I viewed the blog from word press.

 

I have installed both the modules on PS and WP, it shows they are connected. But I cant get the blog posts displayed like in your demo.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Are you running it on localhost (your local computer)? If you do then try to temporary disable the firewall and see if it helps (a free version support only "Isolated runtime" mode that requires Apache to be able to connect to itself).

Share this post


Link to post
Share on other sites

I have installed WP in a subfolder. 

I have installed WordPress integration to PrestaShop Plugin 
When I install psthemeprovider to my Prestashop Module I get the following error. 
 
[PrestaShop] Fatal error in module file :/home2/drapplec/public_html/modules/psthemeprovider/pkgs/ThemeProviderFree-guard-56.php: 
Incompatible file format: The encoded file has format major ID 6, whereas the Loader expects 7

Share this post


Link to post
Share on other sites

WordPress Integration to PrestaShop consists of 2 parts: WP Integration plugin (FREE) and PrestaShop Theme Provider module (there is FREE and PAID version).

Share this post


Link to post
Share on other sites

Click the PrestaShop Theme Provider FREE link and you will see you can download it free of charge ;-)

Share this post


Link to post
Share on other sites

Very, very, nice module.

 

My little contrib for display last post on the home page of prestashop with the native module BlockRSS (1.6)

 

Install on WP "RSS Image feed"

 

Override blockrss.php

 	function install()
 	{
 	 	if (!parent::install())
			return false;

		Configuration::updateValue('RSS_FEED_TITLE', $this->l('RSS feed'));
		Configuration::updateValue('RSS_FEED_NBR', 5);

		return ($this->registerHook('header') && $this->registerHook('leftColumn') && $this->registerHook('displayHome'));
  	}
	
    public function hookDisplayHome($params)
    {
                
        return $this->hookleftColumn($params);    
        
    }

Overide blockrss.tpl

<!-- Block RSS module-->
<div id="rss_block_left" class="block">
<h2>{$title}</h2>
	{if $rss_links}
			{foreach from=$rss_links item='rss_link'}
			<div class="col-xs-1 col-sm-2 col-md-4">				
				{$rss_link.content}<br />
				Publié le : {$rss_link.pubDate|date_format:'%d/%m/%Y à %Hh%M'}
			</div>
			{/foreach}
	{else}
		<div class="col-xs-12">
		<p>{l s='No RSS feed added' mod='blockrss'}</p>
		</div>
	{/if}
</div>
<!-- /Block RSS module-->

With a little CSS code, the display is perfect. I've worked for boule2poils.com if you want to see ;)

Share this post


Link to post
Share on other sites

I downloaded the Free wordpress ,module and uploaded it and this msg appears a white screen saying Hi there! I'm just a plugin, not much I can do when called directly. in my back-office when I deleted the file throw filezilla and checked throw file manager and file wasn't there but still facing same issue!!

 

**************************

 

I found the solution, in the file manger its called (wp-integration) - deleted the file and back office was back

 

Thank you 

Edited by BE UNIQUE (see edit history)

Share this post


Link to post
Share on other sites

I downloaded the Free wordpress ,module and uploaded it and this msg appears a white screen saying Hi there! I'm just a plugin, not much I can do when called directly. in my back-office when I deleted the file throw filezilla and checked throw file manager and file wasn't there but still facing same issue!!

 

**************************

 

I found the solution, in the file manger its called (wp-integration) - deleted the file and back office was back

 

Thank you 

 

I have the same issue. And the plugin works now ?

Share this post


Link to post
Share on other sites

You've

Hi there! I'm just a plugin, not much I can do when called directly.[/size]

You've uploaded WordPress plugin instead of the PrestaShop module (to PrestaShop). The solution is to delete modules/wp-generation/ directory and your web site will be back.

 

WordPress Integration to PrestaShop is currently perfectly fine-tuned with no known issue. Please spend a more time with reading instructions (after downloading everyone receive instructions what to do with files) to prevent your web site from being down.

Share this post


Link to post
Share on other sites

Hi there,

 

we installed the Wordpress plugin and the Prestashop free PlugIn. Shop Version is 1.6.1.1

 

In the Prestashop-Backend modules section i can see the "PrestaShop Theme Provider v1.4.15". The green "Install" Button does not work. Pressing it results in nothing. No message, no installation.

 

Zend Engine is 2.4.0

Zend Guard Loader is 3.3

 

I tried:

Upload Zip, unzip directly inter modules dir / delete

then

Upload  unzipped files in bin mode / delete

then

Upload via backend in prestashop

 

No success

 

Hints?

Share this post


Link to post
Share on other sites

Yes everything is fine with the setup which is used since a few weeks without any trouble installing or configuring modules

Share this post


Link to post
Share on other sites

Your PrestaShop version (1.6.1.1) is common with our module and should work fine (no similar report before). Please send us your classes/module/Module.php file or better FTP credentials and we will take a look at that.

Share this post


Link to post
Share on other sites

Your PrestaShop version (1.6.1.1) is common with our module and should work fine (no similar report before). Please send us your classes/module/Module.php file or better FTP credentials and we will take a look at that.

 

Thats also my view an this issue. I've investigated the link under the "green" Install Button in the moduls section of Prestashop: Looks like that?

 

https://domainname.de/admin1234abc/index.php?controller=AdminModules&token=79bf628516bf6b6234c24691a259d190#

 

As far as i can see there is missing something....

Share this post


Link to post
Share on other sites

Another try:

 

1.) redownload from your website (orders section)

2.) delete modul in prestashop

3.) Install new download via Prestashop Backend (Modules Section)

 

Same Problem. The Link behind the green Install Button points next to nothing (s. attached picture)

 

Strange.

post-1101538-0-47480500-1454325600_thumb.jpg

Edited by GeShoppo (see edit history)

Share this post


Link to post
Share on other sites

Your classes/module/Module.php file looks ok.

 

We've tested both PrestaShop Theme Provider FREE and PrestaShop Theme Provider FULL modules with PrestaShop 1.6.1.1 and everything is working 100% fine.

 

There is probably JavaScript/jQuery issue on your PrestaShop installation (try to install some other 3rd PARTY MODULE from the ZIP package and you will get the same problem).

Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

Arrgh. Prestashop again and again.... Sorry.

 

Well after your hint i tried to install another Modul. Same problem! You're right so far.... even that i installed recently a few modules (non shop retrieved addons) without any glitches or trouble...

 

Now guess what.... i manged to install the module without any changes..... i list it in the modulus backend section. Select it via a check mark and select "Install Selection" (Auswahl installieren in german) and it installs as expected. Added the required SN from your E-Mail Confirmation and here we go.... (s. attached picture)

 

-> green Install Button -> no success, not even a reaction (as Pciture in Post #171)

-> check mark, install selection -> fine to go

 

wtf (Sorry)

 

Anyway: thank you very much for your patience, help and support with this (still) very strange issue which is not related to the modul, its related to the backend / core of Prestashop. (Thats my view.)

post-1101538-0-87786900-1454413382_thumb.jpg

Edited by GeShoppo (see edit history)

Share this post


Link to post
Share on other sites

We are glad to help you! If you will have any other troubles, let us know again!

Share this post


Link to post
Share on other sites

Hi!

It's me again :(

I get this error when i try to view the wordpress blog:

Fatal error: Call to undefined function getallheaders() in /www/htdocs/xxxxxxxx/xxxxxxxxx/modules/psthemeprovider/pkgs/ThemeProviderFree-guard-54.php on line 2246

Setup is as follows

Shop: https://myshop.de
WP-Blog: https://myshop.de/blog

WP is installed in that subfolder (no redirection foo).

Disableing the integration plugin on the wordpress side shows me the blog as expected. Enabling it leads to the error mentioned above.

Additional information:

WP: very latest version 4.4.1

Theme: twentythirteen
No Header-Logo / removed
Disabled "Display Header Text" in Theme settings

Settings/Common/WordPress url = https://domain.de/blog
Settings/Common/Website url = https://domain.de/blog

Security-Key is identical in both PlugIns

API is not protected

WordPress PlugIn claims "The PrestaShop Theme Provider module is connected!"

Followed Troubleshooting Tipps in the first post. No luck.

Any hints?  :blush:

Share this post


Link to post
Share on other sites
  • What's your PHP version?
  • What's your HTTP server (Apache/IIS)?
  • What's the value of "disable_functions" directive in php.ini file?
Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

I have here:

 

1.)

PHP 5.4.45-nmm1

 

Zend Engine v2.4.0, Copyright © 1998-2014 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.0.11, Copyright © 2002-2015, by ionCube Ltd. with Zend Guard Loader v3.3, Copyright © 1998-2013, by Zend Technologies

 

2.) Apache, bute Version unknown to me

 

3.) Is set to  "no value" (phpinfo() result)

Share this post


Link to post
Share on other sites

Ok whatever it is the reason getallheaders() function is not available on your server.

 

Please re-download the ThemeProvider module (no need to make a new order - click the current download link) and upload it to PrestaShop again (there is a little change that getallheaders() function is called only if available). It should resolve the problem.

Share this post


Link to post
Share on other sites

Following your hints worked! I do not understand the magic, but finally it works!

 

Thanks again!

 

Cheers!

Share this post


Link to post
Share on other sites

Technical problems solved. :-D

 

Now for the design....

 

Is it possible to remove the copyright footer? Not suitable for a productional site at that point....

 

More problematic: there is a black < hr > Line in our in prestashop defined footer caused by "your" added footer... (s. attached picture).

 

Also the content is somehow "more left aligned / left aligned" but we use a centered layout. Is there a fix for that?

 

Is it possible to try out all features (sidebars for example) before buying? How?

post-1101538-0-16423800-1454449551_thumb.jpg

Share this post


Link to post
Share on other sites

The hr tag depends on your PrestaShop template (no HTML code is added to the source code). How the content is aligned depends on both WordPress and PrestaShop templates that are installed and active. Enabling/disabling left or right columns could help. The footer text does not come with FULL module.

 

There is no trial version available but we offer a full refund if it does not meet your requirements.

Share this post


Link to post
Share on other sites

Problem was CSS class / divs with same name in Wordpress and Prestashop Theme. Solved.

 

We will give the full version a try. Thanks!

Share this post


Link to post
Share on other sites

Today i've installed the full version and did some configuration finetuning.

 

Now it works and fits perfectly our needs. The integration and separation of the CSS for Wordpress and Prestashop is simply great.

 

Thumbs up!

Edited by GeShoppo (see edit history)

Share this post


Link to post
Share on other sites

Featurerequest :ph34r:

 

As soon as the problems are gone, the ideas spread... :-)

 

I have a page in my wordpress blog which contains selected blog-entries (articles) on one page. Think of a page or a content-page (in WP) that shows only articles from a specific category.

 

Is it possible to insert this wordpress-content-page in a hook on the prestashop frontpage?

Share this post


Link to post
Share on other sites

This could be possible by exporting the desired content (article links, titles and content) in WordPress via ATOM/RSS feed and then using RSS block in PrestaShop to display the exported entries (it's described earlier in this thread).

Share this post


Link to post
Share on other sites

I checked their website, to order a free module and when issued, they wrote to me that I had broken the rules and they do not give me the download link, what specifically I did not say violated, and leaving the live chat unanswered! Please share the link to download the module, as the authors are not interested in their customers!

---

Я зарегистрировался у них на сайте, сделал заказ бесплатного модуля и когда его оформил, они мне написали что я нарушил их правила и не дают мне ссылки на скачивание, что конкретно я такого нарушил не говорят, а без ответа уходят из лайв-чата! Прошу поделится ссылкой на скачивание модуля, поскольку авторы не заинтересованы в своих клиентах!

Share this post


Link to post
Share on other sites

To receive your download link you need to make an order with valid email accounts and details as per our terms.

 

Regarding the download link here in the forum, it was previously discussed earlier in this thread and approved by moderators.

 

Please read the instructions on our web site, follow the checkout process and you will get WP perfectly integrated to PS like a few hundreds users before you :-)

Share this post


Link to post
Share on other sites

To receive your download link you need to make an order with valid email accounts and details as per our terms.

 

Regarding the download link here in the forum, it was previously discussed earlier in this thread and approved by moderators.

 

Please read the instructions on our web site, follow the checkout process and you will get WP perfectly integrated to PS like a few hundreds users before you :-)

 

Check order #1601781 and tell me that I had broken, as in the store, you do not want to hard to answer!

Share this post


Link to post
Share on other sites

The order no. 1601781 was marked by our order auto-processing tool as invalid to protect our store against bots (it contains non-sense account details).

We can't give you any further details about this order because it is against our privacy policy we guarantee.

Share this post


Link to post
Share on other sites