Jump to content
inweb

[Module] Wordpress Blog Integration To Prestashop 1.3/1.4/1.5/1.6/1.7

Recommended Posts

Moderators: please keep this thread in the Paid modules section (do not move to the Free modules section). Thank you.

We made WordPress Integration to PrestaShop!

WordPress is a free and open-source content management system. Features include a plugin architecture with over 40,000 plugins available at the WordPress plugin directory: wordpress.org/plugins/. This means that as soon as you integrate WordPress with your website, you will get a blog module with UNLIMITED features. Since WordPress is the most popular blogging system in use on the Web, at more than 60 million websites, the community is huge and you will always get a top-notch support on any problem you may have.

With this solution you can get a fully featured WordPress blog integrated to PrestaShop!

Demo

It consist of 2 parts: the PrestaShop module and the WordPress plugin.

The PrestaShop Theme Provider module helps to integrate PrestaShop with any 3rd party web application. The WordPress plugin - "the connector" - is completely free. Connectors will always be available free of charge (currently available for phpBB and WordPress) - it means that if you buy the PrestaShop Theme Provider module you will pay once and you will be able to integrate multiple web applications (such as content management systems or forums) to your PrestaShop!

PrestaShop Theme Provider module Features

  • Integrates WordPress to PrestaShop just with a simple click

    You will get a fully featured WordPress blog system for PrestaShop with an easy installation.

  • Perfect compatibility with other WordPress plugins and PrestaShop modules

    Does not require file editing or class overriding - your WordPress and PrestaShop will stay compatible with thousands of other plugins and modules.

  • Safe and stable - no mixing of WordPress and PrestaShop PHP codes

    Provides a mode which keeps WordPress and PrestaShop in a completely sandboxed runtime environment and complies with the strict PHP standards.

  • Editing of the WordPress or PrestaShop template files not required

    Does not require editing of the WordPress or PrestaShop template files.

  • Produces a valid (X)HTML source code

    Without touching a single template file.

  • Displays left or right columns with just one simple click

    Displays PrestaShop's left or right column in WordPress just by changing the option in the PrestaShop BackOffice (it requires PrestaShop 1.5 or higher).

    No need to edit or adjust the PrestaShop template files!

  • Three modes of integration WordPress to PrestaShop

    Apart from the Isolated runtime mode it enables two other modes with significantly better performance and user experience: the Direct cache access mode for customers who prefer blazing-fast performance and the Shared runtime mode for those who prefer the entire content of the page to be fully dynamic and want to give an extraordinary user experience to their visitors.

  • Allows instant usage of any installed WordPress template

    Automatically adjusts the WordPress CSS selectors on-the-fly and restricts the WordPress styles only to the WordPress elements. Supports CSS 1, 2, 2.1 & 3 or any later backward compatible CSS version.

    It will instantly fix the design issues and the page layout of any WordPress template (it will resolve the CSS issues & conflicting styles) which means you can immediately use any WordPress template!

  • Outstanding technical support

    You will get our top notch email technical support.

Requirements

  • WordPress 2.7+ (installed in a subdirectory such as /blog/ or /news/)
  • PrestaShop 1.3.x.x/1.4.x.x/1.5.x.x/1.6.x.x/1.7.x.x with the PrestaShop Theme Provider module enabled
  • PHP 5 and later versions (Safe Mode is supported)

Demo

Demo (phpBB forum integration to PrestaShop)

Did you know... that when you integrate WordPress to PrestaShop you can use the following powerful plugins?

  • Contact Form 7 - Makes beautiful contact forms. (1+ million active installs)
  • Polylang - Makes WordPress truly multilingual. (100,000+ active installs)
  • NextGEN Gallery - Powerful engine for uploading and managing galleries of images. (1+ million active installs)
  • MailChimp for WordPress - MailChimp for WordPress, the absolute best. (400,000+ active installs)
  • bbPress - bbPress is forum software, made the WordPress way. (300,000+ active installs)
  • BuddyPress - BuddyPress helps you run any kind of social network on your web site. (100,000+ active installs)
  • WP Google Maps - Create a custom Google map with high quality markers. (200,000+ active installs)
  • Breadcrumb NavXT - Adds breadcrumb navigation showing the visitor's path to their current location. (400,000+ active installs)
  • YouTube - Embed a responsive video, YouTube channel gallery, or playlist gallery. (100,000+ active installs)
  • Disqus Comment System - The Disqus comment system. (200,000+ active installs)

Download

Troubleshooting

  • Problem: I get message "PrestaShop Theme Provider was not initialized because the file to load is corrupted (wrong md5 checksum)."

    Explanation: Some files are corrupted and in order to keep your PrestaShop up and running the built-in Inveo loader did not load the corrupted files.

    Solution: Re-upload all files using FTP client in BINARY mode or simply upload & install the ZIP package via PrestaShop BackOffice.

  • Problem: I installed both WordPress Integration plugin and PrestaShop Theme Provider module but it does not work.

    Explanation: Either the WordPress plugin or PrestaShop module is not configured correctly.

    Solution: 1) Make sure PrestaShop Theme Provider is activated (click the "Configure" button in the PrestaShop BackOffice - Modules panel). 2) Make sure the "API security key" in WordPress plugin is correct (double check!) or set "Protect API" to "No" in PrestaShop Theme Provider module configuration.

  • Problem: I am sure I've configured everything correctly but it still does not work.

    Explanation: There is either 1) allowed only limited IPs from address list for accessing the server 2) HTTP authorization with PHP running via CGI 3) Some HTTP functions are missing - please enable Shared runtime mode.).

    Solution: Add your server IP to the allowed IP address list in the .htaccess file if you are protecting your web site using IP address list 2) disable the HTTP authorization or setup PHP as an Apache module if you are using HTTP authorization 3) Upgrade PrestaShop Theme Provider module to the PAID version and set "Mode" to "Shared run-time" if HTTP functions are missing.

Our other FREE modules

Edited by inweb (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Update: 1.3.01

  • Wizard which guides user through the setup process was improved

Share this post


Link to post
Share on other sites

You can now integrate WordPress to PrestaShop completely for FREE!

 

WordPress plugin update: 1.4.00

  • PrestaShop Theme Provider Free module support added!
PrestaShop Theme Provider module: 1.3.00
  • A free version of the module was released!

Share this post


Link to post
Share on other sites

Hello,thank you very much for this module, I am trying to use it, but I have this error message:

The Inveo Theme Provider module was not initialized because the required loader had not been installed.
Zend Guard Loader is available without charge at www.zend.com/en/products/guard/downloads.
Inveo s.r.o. can assist you with loader installation on shared, VPS or dedicated servers. Should you need any help, feel free to contact us.

  
Is it necessary to install zen guard loader on the server?

 

Thank you

Share this post


Link to post
Share on other sites

Zend Optimizer/Zend Guard Loader is an extension developed by Zend who develop PHP as well.

 

Even if your web host doesn't have the Zend Optimizer/Zend Guard Loader installed, we are able to install it on most web servers (administrator/root permissions are not necessary). Please contact us at customer area at inveostore.com and we will take care of it.

Share this post


Link to post
Share on other sites

I asked my web host to install Zend Guard Loader... thx

Share this post


Link to post
Share on other sites

Hello,

My web host just installed it. Since I no longer have access to the "module" tab. Can there be related with that?

 

Thank you.

Share this post


Link to post
Share on other sites

Before PrestaShop module code is loaded, the integrity of the PHP files is always checked by built-in Inveo Loader. It means your problem should not be related. However, we would suggest you to manually delete modules/psthemeprovider/ directory and you will see if it helps (no files are edited or overloaded during the installation).

Share this post


Link to post
Share on other sites

Good evening,

 

Zend Guard Loader was installed.

I deleted the directories of the modul and access to the "modules" tab. I was able to download and install your module, but requested a registration code that I did not have and once back in the "modules" tab, the page is inaccessible. What to do, since the module is installed?

 

Thank you.

Share this post


Link to post
Share on other sites

The registration code is the SN you've received in the email with your free Download links. However, no matter if you have entered the SN, your module tab should be accessible anytime.

Share this post


Link to post
Share on other sites

Sorry for my bad English; I start again .

I installed your module and I have not entered the code , and since then I have no access to my " modules " tab ; how to uninstall your module without going through the backoffice of PS ?

Share this post


Link to post
Share on other sites

Manually delete modules/psthemeprovider/ directory.

 

Are you sure you are installing WordPress plugin to WordPress and PrestaShop module to PrestaShop?

Share this post


Link to post
Share on other sites

Hello,

 

I'm trying to install theme provider but i got a Zend requeriment message. My host says that i've to put the line "SetEnv ZEND_OPTIMIZER 1 " in the .htaccess file, but it still dont work.

Share this post


Link to post
Share on other sites

What's your host?

 

In general it is possible to install Zend Optimizer/Zend Guard Loader on most hosts either via custom php.ini file (SuPHP) or by tweaking the .htaccess file. If you or anyone else is in doubts, doesn't know how to do it or simply got stuck, then send us FTP credentials via customer area at inveostore.com and we will take care of it (we utilize this process perfectly since 2008).

Share this post


Link to post
Share on other sites

I'm on OVH server. There is a way to check if zend is really enabled?

 

My htaccess contains that:

 

SetEnv REGISTER_GLOBALS 0
SetEnv ZEND_OPTIMIZER 1
SetEnv IONCUBE 0
SetEnv PHP_VER 5

Share this post


Link to post
Share on other sites

If you see the error message Zend Optimizer/Zend Guard Loader is not installed then it is really missing (you can also check it via output of phpinfo() function).

Share this post


Link to post
Share on other sites

Your host is running PHP 5.4 which means you actually need Zend Guard Loader (=Zend Optimizer for PHP 5.3 and later). Since OVH does not support custom php.ini file, we would suggest you to contact your host support.

Share this post


Link to post
Share on other sites

Ok, i've set php 5.2 version and the error has been solved. But now i have that error :(

 

Inveo Theme Provider was not initialized because the file to load is corrupted.
(pkgs/ThemeProviderFree-guard-5.php file was not found)

Share this post


Link to post
Share on other sites
Re-upload all the files to your server or hosting account with the BINARY mode for FTP transfer (do not use ASCII/Text mode or critical files get corrupted). Inveo Loader loads only files with correct checksum to avoid a web site down time.

Share this post


Link to post
Share on other sites

Well. Now i have that error when i'm triying to install the module u.u

 

Warning: require_once(/home/lagallet/www/config/../classes/ThemeProviderPlugin.php) [function.require-once]: failed to open stream: No such file or directory in /home/lagallet/www/config/autoload.php on line 38

Fatal error: require_once() [function.require]: Failed opening required '/home/lagallet/www/config/../classes/ThemeProviderPlugin.php' (include_path='.:/usr/local/lib/php') in /home/lagallet/www/config/autoload.php on line 38

Share this post


Link to post
Share on other sites

It is a known problem and our mistake (there was a faulty package available for download for some time). All you need to do is to re-download re-install the module and it will get fixed.

Share this post


Link to post
Share on other sites

Hi inweb,

 

I am trying to install the PrestaShop Theme Provider FREE 1.3 module but it crashed my Backoffice, I was no longer able to access the module tab and was getting this error:

[PrestaShop] Fatal error in module file :/home1/xxxxxx/public_html/modules/psthemeprovider/ThemeProviderPluginPrestaShop.php:
Class 'ThemeProviderPluginCore' not found

And here is the error from my Host Errors Logs:

PHP Fatal error:  Class 'ThemeProviderPluginCore' not found in /home1/xxxxxx/public_html/modules/psthemeprovider/ThemeProviderPluginPrestaShop.php on line 17

Deleting the psthemeprovider folder in the module directory solved the issue with Backoffice.

 

Note: I tryied to installed both via the Module "Install from zip" in Backoffice and uploading via Filezilla (in BINARY mode) to the Module directory, both failed...

 

I am on Prestashop 1.6.0.14 running on PHP Version 5.2.17 and have Zend Optimizer enabled according to my phpinfo:

 

Zend Optimizer Optimization Pass 1 enabled Optimization Pass 2 enabled Optimization Pass 3 enabled Optimization Pass 4 enabled Optimization Pass 9 enabled Zend Loader enabled License Path no value Obfuscation level 3

 

 

 

Do I have to install WordPress blog integration module before or after the "PrestaShop Theme Provider FREE 1.3" module?

 

Any ideas why I get the error above trying to install the PrestaShop Theme Provider FREE 1.3 module?

 

(I suspect the .htaccess files contained in your module are causing this...)

 

Cheers

Dan

Edited by papagino (see edit history)

Share this post


Link to post
Share on other sites

Hi inweb,

 

I am trying to install the PrestaShop Theme Provider FREE 1.3 module but it crashed my Backoffice, I was no longer able to access the module tab and was getting this error:

[PrestaShop] Fatal error in module file :/home1/xxxxxx/public_html/modules/psthemeprovider/ThemeProviderPluginPrestaShop.php:
Class 'ThemeProviderPluginCore' not found

It seems this affects users with PHP 5.0-5.3. We will release the update soon. In the meantime, upgrading to PHP 5.4 and later should help. 

Share this post


Link to post
Share on other sites

Please excuse the "newbie" question but I'm confused.

 

I believe I now have everything installed on my sever, with WordPress in a subdirectory of my Prestashop domain. I had to upgrade my PHP version from 5.3 to 5.4 to avoid the fatal error shown above. Everything is now error-free.

 

The Theme Provider free module seems "happy". I've entered the security key. The WordPress integration module says "The PrestaShop Theme Provider module is connected!".

 

However I seem to be missing the rest of the story. I don't know what this integration actually does. I don't see anything "different" from looking at my WordPress ( at http://www.yorkshireyarns.com/blog/ ) that appears "integrated". I'm not sure what else I need to do to end up with an "integrated WordPress Blog" like on the http://www.inveostore.com/blog/

 

I've found this https://codex.wordpress.org/Integrating_WordPress_with_Your_Website and this http://moshublog.com/2005/07/05/integrate/ but I don't know how these articles relate to using the plugin and module integration of this thread.

 

Thanks for any help!

Share this post


Link to post
Share on other sites

It is a known problem and our mistake (there was a faulty package available for download for some time). All you need to do is to re-download re-install the module and it will get fixed.

I have downloaded the module again and reinstalled it and i have de same problem :(

Share this post


Link to post
Share on other sites

Please PM us your API security or better FTP credentials. We will take a look at that. It is a quite complex module but no worries sooner or later we will find what's the issue.

Share this post


Link to post
Share on other sites

An updated version which will resolve the "Fatal errors" with some PHP versions (5.0-5.3) is planned to be released on April 27.

Share this post


Link to post
Share on other sites

Hi inweb, I have updated my php to 5.4 and reinstalled the "PrestaShop Theme Provider Free" module and activated it.

And then I installed the WordPress integration to PrestaShop plugin in Wordpress and registered the API security key.

 

The problem I have is that I cannot change or edit any of the option in the plugin, the option are grayed out,see picture below...

 

post-406825-0-80262500-1429537370_thumb.png

 

And now, when looking a my blog page, the blog is integretate to my site, but it is all messed up, see here: http://www.miraxsupplements.com/blog/

 

Or screenshot of website blog:

 

post-406825-0-40344900-1429538442_thumb.png

 

In the "PrestaShop Theme Provider Free" module, there are setting for "Reset cache on hooks:", do I have to make changes to any of these settings?

 

Thanks

Dan

Share this post


Link to post
Share on other sites

The problem I have is that I cannot change or edit any of the option in the plugin, the option are grayed out,see picture below...

The grayed out options are only available in the full version of the Theme Provider module.

 

And now, when looking a my blog page, the blog is integretate to my site, but it is all messed up, see here: http://www.miraxsupplements.com/blog/

  1. in WordPress admin panel - Appearance - Themes activate Twenty Thirteen.
  2. in WordPress admin panel - Appearance - Header remove the header image.

This will help a lot. If there appear some CSS conflicts, you can either manually resolve them or upgrade to the full Theme Provider module which will transform any WP template on-the-fly.

 

In the "PrestaShop Theme Provider Free" module, there are setting for "Reset cache on hooks:", do I have to make changes to any of these settings?

No. You can leave defaults. It's only for very specific needs.

Share this post


Link to post
Share on other sites

Thanks inweb, done what you mentioned above, it helps, but I see the footer content of my site in two places, on top and the bottom of the page.

 

How can I resolved the footer appearing on the top?

 

See pic:

 

post-406825-0-25474600-1429541434_thumb.png

 

Cheers

Dan

Share this post


Link to post
Share on other sites

Please PM us your API security key. We will take a look whether the PS theme is properly extracted.

Share this post


Link to post
Share on other sites

Hello again inweb, I have found a Wordpress theme that closely match my Prestashop theme, but now, when accessing my Blog page, the page is Left aligned instead of being centered.

 

Check here:

http://www.miraxsupplements.com/blog/

 

Also, I still have the problem with the footer container being displayed in the top and the bottom of the blog content.

 

Any ideas on how to fix this? I tried different Wordpress themes will all the same result.

 

cheers

Dan

Share this post


Link to post
Share on other sites

Please PM us your FTP credentials (access limited only to public_html/modules/psthemeprovider/ directory is ok). We took a look more deeply at this issue and our previous reply that theme is extracted correctly was wrong. It's not extracted correctly and that's why it looks weird.

Share this post


Link to post
Share on other sites

Hi everybody,

I posted my question yesterday above in this thread but I think it got buried so I'm trying again. 

 

My blog is at

 

http://www.yorkshireyarns.com/blog/

 

but I don't see any "integration".

 

The WordPress plugin says:

WordPress integration to PrestaShop

The PrestaShop Theme Provider module is connected!

 

 

Am I missing something to get this to work?

 

thanks

Share this post


Link to post
Share on other sites

Hi everybody,

I posted my question yesterday above in this thread but I think it got buried so I'm trying again. 

 

My blog is at

 

http://www.yorkshireyarns.com/blog/

 

but I don't see any "integration".

 

The WordPress plugin says:

WordPress integration to PrestaShop

 

The PrestaShop Theme Provider module is connected!

 

 

 

Am I missing something to get this to work?

 

thanks

 

Your PrestaShop Theme Provider module does not seem to be activated. Search for the "Theme Provider" module in PS BackOffice and click the "Configure" button.

 

 

i use yoast seo wordpress

 

The problem you are having is not related to other plugins or modules you are using.

Re-upload all the files to your server or hosting account with the BINARY mode for FTP transfer (do not use ASCII/Text mode or critical files get corrupted). Inveo Loader loads only files with correct checksum to avoid a web site down time

Share this post


Link to post
Share on other sites

Thanks but still no luck. I had already clicked "configure" on the "Theme Provider" before (that's how I got the security key to enter in the WordPress integration plugin).

 

Anyway I re-downloaded both the theme provider and WP integration plugin .zip files from the link in my email, extracted to my hard drive (previously I just uploaded the .zip files from Prestashop and Wordpress to install), and set FileZilla to "binary mode" and uploaded over the old files. 

 

The "Theme Provider" now had a new security key so I put that in the WP Integration and once again, I got the message, "The PrestaShop Theme Provider module is connected!".

 

I don't have any errors in PrestaShop about ZendLoader or anything either.

 

I'd love to get this to work so any more ideas would be most appreciated.

 

My blog is at http://www.yorkshireyarns.com/blog/

 

Thanks!

Share this post


Link to post
Share on other sites

buzzworm, please post (or PM us) your phpinfo() page.

Share this post


Link to post
Share on other sites

A new version of the PrestaShop Theme Provider module has been released. It resolves all the reported issues.

 

1.3.01

  • All the Fatal errors with older PHP versions were resolved.
  • PrestaShop 1.6 compatibility was improved
  • Inveo Loader 2 was updated to 2.0.6 version
  • The configuration screen is automatically displayed during the installation
Feedback is welcome!

 

You can download this update by clicking the download link you've received or at the customer area at inveostore.com.

Edited by inweb (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

The PrestaShop Theme Provider module ZIP package was updated to further improve compatibility with the older PHP version (re-download if you still have any troubles or errors).

Share this post


Link to post
Share on other sites

A new versions of the PrestaShop Theme Provider module and WordPress Integration plugin have been released. They resolve compatibility issues with PHP 5.0-5.2.

 

PrestaShop Theme Provider module 1.4.00

  • PHP 5.0-5.2 compatibility fixed
WordPress Integration plugin 1.4.02
  • PHP 5.0-5.2 compatibility fixed
Our thanks go to tele28 & papagino for the cooperation when we were resolving those issues. Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

New versions of the PrestaShop Theme Provider module and WordPress Integration plugin have been released.

 

They come with a lot of fixes and improvements and also introduce the most requested feature: Display left or Display right column with just one simple click from configuration screen.

 

PrestaShop Theme Provider module 1.4.01

  • Display left or Display right column options were added (it requires PS 1.5 and higher)
  • PS compatibility was improved
  • Version compliancy with buggy PrestaShop version was fixed
WordPress Integration plugin 1.4.04
  • Support for update notices of the Theme Provider module was added
  • WebAppsDetector class was updated
  • Theme Provider module was updated to 1.4.01
  • UI improvements
  • Fixed the Theme Provider download link
  • Prepared for localization
Thanks everyone for reporting all the fixed issues and bugs as well as to those who upgraded to the paid Theme Provider module!

Share this post


Link to post
Share on other sites

New versions of the PrestaShop Theme Provider module and WordPress Integration plugin have been released.

 

They come mainly with fixed support for exceptions of module positions (blocks) and improved adjusting of CSS files.

 

PrestaShop Theme Provider module 1.4.03

  • HTTPS compatibility with recent PrestaShop versions was fixed
  • Support for exceptions of module positions (blocks) was fixed
  • Adjusting of CSS files was improved
WordPress Integration plugin 1.4.05
  • PHP notice was fixed
  • WebAppsDetector class was updated
  • Theme Provider module was updated to 1.4.03

Share this post


Link to post
Share on other sites

HI,

 

I am testing the ingratiation on my local host.

 

What i did:

 

Downloaded the 

#1 Inveo_WordPress_Integration_plugin_1.4.05_(INSTALL_TO_WORDPRESS) and Inveo_PrestaShop_ThemeProvider_FREE_1.4.03_(INSTALL_TO_PRESTASHOP)

 

#2 Installed the wordpress plugin. (Though I got a message to input my ftp details I skipped that by adding "define('FS_METHOD','direct');" to my wpconfig.php file )

 

#3 Wordpress installation successful. when I tried to set up the plugin it asked me to download the prestashop module and enter api key.

 

#4 when I paste the api key I got with the email it doesn't take all character but half. (Issue 1)

 

#5 When I installed the module on prestashop it says 

 

 

Fatal error: Incompatible file format: The encoded file has format major ID 7, whereas the Loader expects 6 in /var/www/prestashop_new/modules/psthemeprovider/pkgs/ThemeProviderFree-guard-55.php on line 0
[PrestaShop] Fatal error in module file :/var/www/prestashop_new/modules/psthemeprovider/pkgs/ThemeProviderFree-guard-55.php:
Incompatible file format: The encoded file has format major ID 7, whereas the Loader expects 6

 

The issue is with the encoding and decoding of zend loader I think. (Issue2)

 

#6 Now when I load my blog there is same error 

 

 

Fatal error: Incompatible file format: The encoded file has format major ID 7, whereas the Loader expects 6 in /var/www/prestashop_new/modules/psthemeprovider/pkgs/ThemeProviderFree-guard-55.php on line 0

 

 

Please note that I am using 

PHP Version 5.5.9-1ubuntu4.9

Zend loader has been loaded and I can see it's enabled on vie phpinfo(); request.

 

My pc is 64 bit and I have downloaded the php5.5 loader version. i.e.zend-loader-php5.5-linux-x86_64.tar.gz

 

Hope I have provide enough information to get a reply form you.

 

Thank in advance.

Share this post


Link to post
Share on other sites

Please re-download and re-install the PrestaShop Theme Provider module and let us know how it helps.

  • Like 1

Share this post


Link to post
Share on other sites

Thank You. I have initiated the download and it's just waiting for validation. I'll post the progress here.

Share this post


Link to post
Share on other sites

Okay but no need to re-order. You can just click the download link you've already got or you can re-download everything you need in the customer area at inveostore.com.

  • Like 1

Share this post


Link to post
Share on other sites

My mistake. I've ordered that again. Though you have mention that the new version is 1.4.05 the downloaded file was of 1.4.03.

 

The most important thing is worked. 

 

I am going to explore what can be done with this.

 

I have a question.

 

I have a customer on my prestashop store.

 

Can the customer access features of the wordpress ?

 

In simple can there be a unique login for both prestashop and wordpress ?

 

I want to make the wordpress as a forum and the customer can comment on the forum. I need my customers on prestashop directly access the forum and post comment. No need to create another user on wordpress. Is it possible ?

Share this post


Link to post
Share on other sites

Can the customer access features of the wordpress ?

 

In simple can there be a unique login for both prestashop and wordpress ?

 

I want to make the wordpress as a forum and the customer can comment on the forum. I need my customers on prestashop directly access the forum and post comment. No need to create another user on wordpress. Is it possible ?

This WordPress Integration to PrestaShop integrates WordPress in the meaning of the design and templates so if a user uses WP it actually looks he never left PrestaShop. However, for such a feature you may try to use some other WP/PS plugins and modules such as https://wordpress.org/plugins/prestashop-user-compatibility/

  • Like 1

Share this post


Link to post
Share on other sites

Ahhh! I have tested and works great only some css issues are there. I have tested on the default theme of prestashop and it the footer has some issues. As I told my requirements so this module can also help me ingratiating design part. Let me check the user part. 

 

Thank You very much for the help and interaction.

Share this post


Link to post
Share on other sites

If there are any CSS issue you can either resolve them by manually editing each template or with the paid module you can just simply turn on "Adjust CSS stylesheets: External Cascading Style Sheets" and it immediately does the trick for any installed WP template.

  • Like 1

Share this post


Link to post
Share on other sites

Thank You for the advice, but it'd have been great if we can integrate the user too. Hope you are planning something like this in the near future.

Share this post


Link to post
Share on other sites

Hello,

 

I was wondering if this module is what i'm looking for, i hope you can tell me.

 

I use the woocommerce plugin and for that THE t-shirt design plugin that only works in woocommerce in together only in wordpress.

I want a website theme that online works with prestashop.

 

So what i want is:

All the pages of the website have to look like the theme.

The t-shirt designer is displayed on 1 page but this one has to look like the rest so does have to have the theme around it.

Woocommerce has to look like the theme to ofcourse

 

Is it all possible with this module 

Edited by ilona (see edit history)

Share this post


Link to post
Share on other sites

If you mean whether the T-Shirt Designer plugin will work when WordPress is integrated to PrestaShop then the answer is YES and the Woocommerce page with the T-Shirt Designer plugin will use the selected PrestaShop theme. However, please bear in mind that Woocommerce orders will continue to go through Woocommerce and PrestaShop orders through PrestaShop. There is no exchange of order/customers between those ecommerce systems (unless you write a plugin/module for that).

Share this post


Link to post
Share on other sites

Hi Enrique Engblom,

 

Thanks for the notification. This topic was originally posted under the "Paid Modules & Themes" forum to follow the rules. It seems like some forum moderator recently moved this topic to the "Free Modules & Themes" forum. We will be glad if this topic will be moved back to the "Paid Modules & Themes" forum since breaking the forum rules is the last thing we want to do.

Share this post


Link to post
Share on other sites

A new version of the PrestaShop Theme Provider module has been released. It just increment the minor version number to appear as an update and fixes the recently reported compilation issue (was already fixed).

 

PrestaShop Theme Provider module 1.4.04

  • Compilation issue was fixed

Share this post


Link to post
Share on other sites

Hi, at some point when I installed one of the modules, I chose to install in testing mode.

 

So this appears on my blog page:

This web site is enhanced by Inveo WordPress integration for testing purposes only.

 

I think it was when I first installed the paid version, and I was trying to reserve the right for a refund if it didn't work (or something like that). 

 

Anyway, I'm running the paid version and am ready to get of rid of this message but I don't know how. Please advise.

 

Thanks!

glen

Share this post


Link to post
Share on other sites

In order to get rid of the message when activated on the web site as "Dev":

  • Uninstall the module
  • Re-install the module
  • Click the "Click here to activate" and you will have an option there to upgrade to "Live" web site.
:-)

Share this post


Link to post
Share on other sites

It seems like some people got confused about the activation schema.

In short both FREE and paid PrestaShop Theme Provider modules is possible to activate as "Dev" and "Live" (in case of a free module both activation are free of charge).

Have a nice weekend everyone! :)

Share this post


Link to post
Share on other sites

A new version of the PrestaShop Theme Provider module has been released. It mainly comes with fixed CloudFlare compatibility and doctype issue what also resolves displaying of LTR languages.

 

PrestaShop Theme Provider module 1.4.05

  • CloudFlare (Auto Minify) compatibility was fixed
  • Doctype issue was fixed
  • Adjusting of CSS files was improved

Share this post


Link to post
Share on other sites

A new version of the WordPress Integration plugin has been released.

 

WordPress Integration plugin 1.4.06 (changes since the last announced version)

  • UI improvements
  • Support for update notices of the Theme Provider module was added
  • PHP notice was fixed
  • WebAppsDetector class was updated
  • Fixed the Theme Provider download link
  • Prepared for localization

Share this post


Link to post
Share on other sites

A new version of the WordPress Integration plugin has been released.

 

WordPress Integration plugin 1.4.06 (changes since the last announced version)

  • UI improvements
  • Support for update notices of the Theme Provider module was added
  • PHP notice was fixed
  • WebAppsDetector class was updated
  • Fixed the Theme Provider download link
  • Prepared for localization

 

Hi there, I have a curious problem. Trying to install your integration, I accidentally loaded in modules tab the plugin. After that, I got the message "Hi there! I'm just a plugin, not much I can do when called directly." Now, every time I try to access the Modules tab, I get the same message, a white webpage with the words "Hi there! I'm just a plugin, not much I can do when called directly.". What can I do!

Share this post


Link to post
Share on other sites

Deleting public_html/modules/wp-integration/ folder should resolve your problem.

Share this post


Link to post
Share on other sites

A new version of the PrestaShop Theme Provider module has been released. It mainly comes with improved stability on servers with some disabled PHP functions and with fixed PHP 5.6 compatibility.

 

PrestaShop Theme Provider module 1.4.07

  • Stability on servers with some disabled PHP functions was improved
  • PHP 5.6 compatibility was fixed

Share this post


Link to post
Share on other sites

Hi,

 

How do I set activation back to development so that I can have the live version on another URL?

 

Thanks

 

Skye

Share this post


Link to post
Share on other sites

If you are running out of SN that are required for activation, simply make a new order and you will receive another one free of charge :)

Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

A new version of the PrestaShop Theme Provider module has been released. It comes with significantly improved compatibility and should work on any server setup.

 

PrestaShop Theme Provider module 1.4.08

  • General compatibility was significantly improved

Share this post


Link to post
Share on other sites

Hi

 

Thanks for sharing this powerful and valuable module.

 

is it simply possible with this module to have last posts, category, most viewed posts , and other wordpress widgets on home page or other pages , for example in footer ?

 

i saw the demo , and i didn't see this items on home.they are available just on blog page.

 

thank you .

Share this post


Link to post
Share on other sites

New versions of the PrestaShop Theme Provider module & WordPress Integration plugin have been released. They come with API security key requirement removed what was the most common step where users get stuck.

 

PrestaShop Theme Provider module 1.4.09

  • An option to make API access public or private was added
WordPress Integration plugin 1.4.09
  • The requirement to enter the API security key has been removed
  • WebAppsDetector class was updated
Enjoy summer everyone! :-)

Share this post


Link to post
Share on other sites

Hi, after install PrestaShop Theme Provider module from module section, Now I can't access to module section. The message that I get when I press the module section is "Hi there! I'm just a plugin, not much I can do when called directly" in white screen. I tried to restore from a backup but it didn't resolve the issue. Could you tell me what I need to do to work it again.

Share this post


Link to post
Share on other sites

You did not install the Theme Provider module to PrestaShop but the WordPress Integration plugin and that's why you see this message. In order to make it work you have to install PrestaShop Theme Provider module to PrestaShop and WordPress Integration plugin to WordPress.

 

To resolve the problem you are having, please delete public_html/modules/wp-integration/ folder on your FTP and then start from scratch.

Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

Special Offer: Free Installation service (valid August 1 - August 31)

Add "FREEINSTALLATION" code to the order comment and you will receive our installation service free of charge!

 

This offer applies to both PrestaShop Theme Provider FREE and paid versions.

Share this post


Link to post
Share on other sites

A new major update of the PrestaShop Theme Provider module & WordPress Integration plugin have been released! We call this release simply "fully working again" since it restores functionality that was broken on many servers since version 1.4.07. It also comes with more PHP packages and can be installed on much more servers than before!

 

PrestaShop Theme Provider module 1.4.10

  • Restored functionality on servers with Suhosin installed
  • ionCube support was added
  • A few PHP warnings fixed
WordPress Integration plugin 1.4.10
  • PHP warnings in certain situations were fixed
  • WebAppsDetector class was updated
Thanks to everyone for reporting all the issues!!

 

P.S. If it did not work for you, it's a right time now to give it a one more chance :-)

Edited by inweb (see edit history)

Share this post


Link to post
Share on other sites

A new update of the PrestaShop Theme Provider module & WordPress Integration plugin have been released! It comes with improved PrestaShop 1.6 compatibility and brand new Maintenance mode notification.

 

PrestaShop Theme Provider module 1.4.11

  • Compatibility with PrestaShop 1.6 was improved
  • Maintenance mode notification was improved
  • Some issues with HTTP functions were resolved
WordPress Integration plugin 1.4.11
  • WebAppsDetector class was updated
  • WP 4.3 "Tested up to" tag
Thanks to everyone for reporting all the issues! :-)

 

Don't forget: There is a special offer of Free Installation service (valid August 1 - August 31). Add "FREEINSTALLATION" code to the order comment and you will receive our installation service free of charge! This offer applies to both PrestaShop Theme Provider FREE and paid versions.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, I am affraid I have the same issue. Everything seems installed and activated, WP says The PrestaShop Theme Provider module is connected! - but it is not working...

www.lightworkers.cz/blog

Please excuse the "newbie" question but I'm confused.

 

I believe I now have everything installed on my sever, with WordPress in a subdirectory of my Prestashop domain. I had to upgrade my PHP version from 5.3 to 5.4 to avoid the fatal error shown above. Everything is now error-free.

 

The Theme Provider free module seems "happy". I've entered the security key. The WordPress integration module says "The PrestaShop Theme Provider module is connected!".

 

However I seem to be missing the rest of the story. I don't know what this integration actually does. I don't see anything "different" from looking at my WordPress ( at http://www.yorkshireyarns.com/blog/ ) that appears "integrated". I'm not sure what else I need to do to end up with an "integrated WordPress Blog" like on the http://www.inveostore.com/blog/

 

I've found this https://codex.wordpress.org/Integrating_WordPress_with_Your_Website and this http://moshublog.com/2005/07/05/integrate/ but I don't know how these articles relate to using the plugin and module integration of this thread.

 

Thanks for any help!

Edited by Alika (see edit history)

Share this post


Link to post
Share on other sites

We've checked your web site: The PS Theme Provider module API seems to operate fine but the WordPress Integration plugin doesn't. There are likely some troubles with HTTP functions.

 

Please PM me your WordPress credentials and FTP credentials. We will take a look what's the problem and let you know asap.

Share this post


Link to post
Share on other sites

Also before you PM us, please set WordPress Address (URL) and Site Address (URL) to http://lightworkers.cz/blog at WordPress BackOffice - General and see if it helps you.

 

Good news - it worked! I just removed www from website URLs.

 

Thank you very much!

Share this post


Link to post
Share on other sites

You are welcome. I would also suggest at WP - BackOffice - Appearance - Themes to choose "Twenty Thirteen" theme. It will better match your web site :-)

Share this post


Link to post
Share on other sites

Hi, 

 

I'm having this issue when I upload the prestashop plugin to the FTP/modules: Inveo Theme Provider was not initialized because the file to load is corrupted.

(wrong md5 checksum). Then when I activate it it crashes. What should I do? 

 

Thanks in advance

Share this post


Link to post
Share on other sites

Please make sure you are using BINARY mode for FTP transfer (do not use ASCII mode) or simply upload the module (ZIP file) via PrestaShop BackOffice.

Share this post


Link to post
Share on other sites

Ok, thanks it worked fine.

 

Can you tell me which wordpress theme works better for the integration?

How can I hide the wp theme footer and header?

 

Thanks. 

Share this post


Link to post
Share on other sites

We recommend the "Twenty Thirteen" theme from the pre-installed themes. You can cutomize header at WP - BackOffice - Appearance - Header section.

Share this post


Link to post
Share on other sites

Hello, appears to me the following error message:

 

Warning: [obfuscated](): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in ######/modules/psthemeprovider/pkgs/ThemeProviderFree-ioncube-55.php on line 0

 

I do not know how to fix it. Thanks

Share this post


Link to post
Share on other sites

Thanks for reporting. It will not cause any malfunction (as long as your WP domain matches the PS domain - which means both include or miss "www." - what is required/recommended). We will include a fix for this in the next update.

Share this post


Link to post
Share on other sites