Jump to content

table Advice_lang corrupted when saving DB since 16012 : Upgrade to 16014 fails


Recommended Posts

I Updated mid Feb from 1.6.0.9 to 1.6.0.12 and noticed only that items are written twice in FO. except for 1 product (amongst 12) strangely....any idea?

 

Anyway, hoping that  new "stable"1.6.0.14 would solve it, I jumped to the last update using 1click update facility, but unfortunately it failed: 

So I tried to revert but  DB failed to recover (only 3 tables were copied) !

 

After investigation of DB, it appeared that the 4th table (advice_lang) is corrupted in all  saved DB since 1.6.0.12, and had to be removed manually (with phpadmin) and replaced by a clean one (copied from 1.6.0.9 DB)... quite tedious ! After such repair and manual replacement of corrected DB, 1.6.0.12 works again.

 

However, even just after that DB clean-up, I tried again to upgrade to 1.6.0.14 but it is still impossible to upgrade to 1.6.0.14 because of corrupted DB.

 

How can I get out of that and upgrade to 1.6.0.14 ???

Share this post


Link to post
Share on other sites

Hello VertNautre,

 

try to use the cleaner module to check the integrity and clean the database, if you have problems yet maybe you can try to truncate the ps_guest table, that worked for me. 

 

The other option is to do the update manually...

 

 

Regards

Share this post


Link to post
Share on other sites

Thank you

 

The cleaner module did the job perfectly (cleaning+ integrity check of the database) reducingmeanwhile  its size of a mere 20Kb amongst 600Kb

 

Followed by the upgrade in 1 click to 1.6.0.14 : NICKEL

 

I 'll keep in mind that trick to roll a clean/integrity check before the next upgrade. That can't hurt.

 

Thanks again

 

By the way, the product description Pb previously seen in FO seems to have been partially corrected, since doubled references of items included previously shown have now gone, but instead, for the kits,  some references included are not listed anymore in the description..., 

Share this post


Link to post
Share on other sites

Now updated in 16014, I encounter in FO a Pb with the pack content description, which is now troncated to the 1st item only (listed and displayed)

This pb only appeared since 16014.

 

Despite various trials such as cache regeneration, DB clean-up (with dedicated module) and re-check of the packs in BO (which are OK) : the FO Pb remains.

you may see it more clearly on visiting my shop vertnature.fr with the KI and KIE items.

 

Any suggestion?

Share this post


Link to post
Share on other sites

Hello,

 

I can't see nothing weird, maybe the problem is your browser cache, try to open it in another browser or recharge the page with ctrl+f5. If the problem persist upload a capture a mark the wrong things.

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More