Jump to content
ProType3D

problème affichage des packs prestashop 1.0.6.0.13 et 1.0.6.14 [Résolu]

Recommended Posts

Bonjour,

 

Je me présente au passage ^^

Kevin, je me lance dans une nouvelle activité de E-Commerce dans le domaine de l'impression 3D.

j'ai 25 ans et suis passionné par les nouvelles technos...

 

 

Pour en revenir à mon problème, j'ai chercher avec mon ami GooGle mais pas trouver de cas similaire au mien sauf dans une version antérieur et la solution ne correspond malheureusement pas du tout à mon fichier...

 

Je précise qd mm que ce problème est apparu suite à la  mise à jour de la version 1.6.0.9 à 1.6.0.14

 

En gros je défini un pack dans mon BO et quand je vais dans le FO, dans la rubrique "Contenu du pack" seul le premier objet mis dans le BO apparait...

 

Dans mon BO tout les éléments sont bien présent dans la fiche du pack...

 

J'ai contrôler sur plusieurs PC différents (au cas ou un problème de cache) mais le problème est tjrs là

 

le lien que j'ai trouver concernatn le mm type de bug : https://www.prestashop.com/forums/topic/239287-pack-probleme-affichage/

même si personnelement le produit ne s'affiche qu'une seul fois...

 

 

Merci pour votre aide !

 

Edited by protype3d (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Je m’immisce dans la conversation car j'ai aussi le soucis...

 

De plus, si je modifie le produit en BO, j'ai un message : "Tous les éléments composant ce pack doivent se trouver dans le même entrepôt.", alors que je suis en mono boutique.

Share this post


Link to post
Share on other sites

Bonjour

 

Je déplace le topic dans Difficultés, panne ou erreur rencontrées. Qui semble plus adéquate à votre problème.

Share this post


Link to post
Share on other sites

Bonsoir,

 

Pour la partie stock des pièces, je suis en gestion des stocks avancé et toutes mes pièces sont stockés dans mes deux entrepôts et pas de soucis...

 

Mais nous ne serions que 2 à avoir ce problème ?

 

assez étonnant...

Share this post


Link to post
Share on other sites

Bonjour à toutes et tous,

je rencontre le même problème, avez vous trouvé la solution ?

Share this post


Link to post
Share on other sites

j'ai fait pas mal d'essais de modification du fichier pack.php mais rien n'y fait...

 

Si quelqu'un voit un autre fichier à regarder je suis preneur...

Share this post


Link to post
Share on other sites

Bonjour,

Même problème, seul le premier produit du pack s'affiche dans le détails.

Egalement preneur d'une solution.

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

Je rencontre le même problème après être passée à la version 1.6.0.14. J'ai cherché sur les forums mais je n'ai trouvé aucune réponse...

Share this post


Link to post
Share on other sites

Bonjour

 

Même probleme pour moi. Cependant c'est un probleme déja rencontré sur la version 1.6.0.13

 

http://forge.prestashop.com/browse/PSCSX-4810

 

 

Check out function name of getItemTable on Pack.php file.

Search for GROUP BY a.id_product_attribute_item and replace with GROUP BY a.`id_product_item`, a.`id_product_attribute_item`';

 

 if 0 attributes for the products the $packItems has just the first product inside.

 

 

Je viens de faire la modification sur mon installation en vesion 1.6.0.14 et tout fonctionne

 

Le fichier modifié est en pièce jointe : Pack.zip

 

Bonne journée à tous

 

 

  • Like 2

Share this post


Link to post
Share on other sites

C'est tout bon pour moi aussi !

 

Merci pour la solution je commençais à me demander comment j'allais pouvoir contourner le problème mais c'est qd même mieux de voir l'ensemble des produits...

 

++

Kevin B

Share this post


Link to post
Share on other sites

Bonsoir et veuillez m'excuser xi ma question est puéril,  mais ou trouver le fichier Pack.php sur le site

 

Merci pour votre aide

Share this post


Link to post
Share on other sites

Bonsoir et veuillez m'excuser xi ma question est puéril,  mais ou trouver le fichier Pack.php sur le site

 

Merci pour votre aide

 

Il suffit de cliquer sur le lien "Pack.zip" dans le post de Draguignol

ensuite tu le décompresse et tu le remplace dans ton site (le fichier ce trouve dans www.le lieu de stockage de son site\classes\Pack.php)

 

si tu ne trouve pas ou ce trouve le fichier, tu as une fonction de recherche de fichier intégré à windows ^^

 

Voilà,

ne pas oublier de faire une copie du fichier "Pack.php" avant de le remplacer, on ne sait jamais !

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour votre aide. J'ai remplacé le fichier pack.php.

 

Maintenant, j'ai effectivement la liste des produits du pack qui apparaissent, mais je n'ai pas les photos des articles du pack. (miniatures bien régénérées...)

 

Merci

Share this post


Link to post
Share on other sites

Salut,

 

Merci pour la solution , qui m'a bien aidé aussi :)

Share this post


Link to post
Share on other sites

Salut, 

 

merci pour le fichier zippé, tout fonctionne maintenant pour moi !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More