Jump to content
betal

Property Product->name is empty

Recommended Posts

Hi,

 

Following the migration of a shop from 1.3.4 to 1.6.0.11 that is was successful, i discoverd that i can not modify my product page !

 

Every attemp to change i get : Property Product -> name is empty.

And it change the 'name' of the product leaving only the first letter...

 

I checked in the table 'product_lang' the name column, but all seems ok, i can't find incorrect symbol for ex.

 

In debbug mode, i have only a warning on the page admincontroller at line 1377.

 

Big thank for your help !

 

Olivier

Share this post


Link to post
Share on other sites

Sounds like you have a single field which is being treated like an array. Try grabbing a clean .11 package, and replace the whole admin folder, it might just be a template issue

  • Like 1

Share this post


Link to post
Share on other sites

Thank you fot that answer, i test and come back.

Share this post


Link to post
Share on other sites

I have the same issue, the problem is half a year ago I did not have it and entered products, now when I want to add new products I get this message: Product Property -> name is empty. BUT as you see below the (correct) name was not empty as it is mentioned (Rainha - Brazilie) as is the correct ID

 

I did as Nemo suggested and replaced the admin folder, refreshed cache, but no results.

 

 

Anybody????

 

 

3 errors

  1. Rainha - Brazilie (Nummer: 512) kan niet opgeslagen worden
  2. Property Product->name is empty
  3. Pamwamba – Malawi (Nummer: 521) kan niet opgeslagen worden
Er zijn 2 warnings
  • Herschreven link voor (Nummer: 512) is herschreven als friendly-url-autogeneration-failed.
  • Herschreven link voor (Nummer: 521) is herschreven als friendly-url-autogeneration-failed.

Share this post


Link to post
Share on other sites

Hi Nemo,

 

I don't think I'm using any override.

I just put a fresh copy of PS on my mamp. Downloaded the product example csv and imported that into the mamp, succes. (looking back I don't know why?)

Then I tried my own csv, (deleting all products while importing my own,  same message property name is empty.

Then I tried to upload the original sample file again and then this one too will not go in anymore.

 

OK I found what is killing me here:

 

I changed the php version.

When I first was succesful I was using php version 5.6.10.

As we were putting it on a live server we used a php 7.0

Looks like all works fine, but not the csv-import 

 

Changing it on my mamp solved this but. Looks like Prestashop is very sensitive to php versions?

 

The live server has 7.0 is there any way I can change something in the code, that will make my current shop work with php 7.0 as well?

Share this post


Link to post
Share on other sites

ok I posted the last question in the forum that goes about php and ps 1.6  called:

Prestashop 1.6 With Php 7.0 - Experience, Problems, Solutions

 

I would never think that that was the problem as it looked like everything was working well. But your question Nemo put me in the right direction by letting go of the csv and thinking i did something wrong there.

Share this post


Link to post
Share on other sites

It might be using some deprecated function in the importcontroller. You can turn on dev mode and see if you get any warning/fatal error

Share this post


Link to post
Share on other sites

I had the same problem. finally after several attempts I solved the problem by recreating the product.

 

bye

Share this post


Link to post
Share on other sites

I believe you have some empty lines at the end of the CSV file. To check that out you can open the CSV with notepad or something similar.

I had the same issue and deleting the commas at the end solved it for me.

Share this post


Link to post
Share on other sites

I have same issue now.. I am developing a module and I am stuck in the admin product trying to submit form having this error..

Share this post


Link to post
Share on other sites

can you take a screenshot of the full error, with debug mode enabled?

Share this post


Link to post
Share on other sites

I have same issue now.. I am developing a module and I am stuck in the admin product trying to submit form having this error..

here is the screenshot with the dev mode enabled..

Screenshot_1.png

Share this post


Link to post
Share on other sites

the issue is resolved.. it was indeed a php version issue... i downgraded it to below PHP version: 7

Share this post


Link to post
Share on other sites

Hi,

can you please help me

 

Test Pro (ID: No ID) cannot be saved

Property Product->name is empty

these errors are annoying me

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More