Jump to content

non invia la mail al cliente


sklere
 Share

Recommended Posts

Ciao a tutti,
premetto che sono molto soddisfatto di PS e di come tutti voi lo seguiate, avrei un problemino che non sono riuscito a risolvere, in poche parole quando simulo l'acquisto di un prodotto, mi arriva la mail all'amministratore ma non al cliente.
Non capisco cosa possa essere e non sono riuscito a trovare nessun 3d che ne parlasse.
Ho installato l'ultima versione disponibile in italiano 1.2.5.0, ho un hosting linux e non so che altro vi potrebbe servire per capire il problema.
vi ringrazio tutti fiducioso in una valida risposta.
Ciao

Share this post


Link to post
Share on other sites

Ciao,
e benvenuto....


...non hai trovato nessun 3d perché è una cosa strana
la mail di registrazione arriva? Variazioni degli ordini? Hai settato in italiano? Sei sicuro non finisca in spamming?
Guarda se ci sono i file in mail/it/order_confirmation. o txt o html a differenza dei tuoi settaggi....

...il file che fa partire la mail è:
classes/PaymentModule.php

Ma non ci sono problemi di questo genere.

Share this post


Link to post
Share on other sites

ciao disarci, hai ragione mi sono accorto ora che la mail mi arriva ma in spam, la cosa che non riesco a capire è perchè mi arriva in spam in una casella di posta gmail.com, ma non mi arriva proprio in una casella di posta hotmail.com, non è che per caso ho dei blocchi di spam sul server? ed eventualmente c'è qualche "trucchetto" per far si che non venga considerata spam?
Grazie mille

Share this post


Link to post
Share on other sites

oh.. comunque mi sono reso conto che il problema è a livello "mondiale" e non si è riuscito a trovare alcuna soluzione.
Mi dispiacerebbe molto dover cambiare piattaforma ma non posso permettermi di non ricevere e di non far ricevere email ad utenti che hanno hotmail.
possibile che nessuno si sia preoccupato di questo problema?
Inoltre se imposto l'invio della mail configurando l'SMTP, non me la invia proprio.
Molto ma molto strano.
Vabbè continuo a cercare anche se ripeto che non ho trovato nessuno che ci sia riuscito.
Ciao a tutti

Share this post


Link to post
Share on other sites

Ciao

Allora per risolvere questo problema essenzialmente devi cambiare l' oggetto di tutti i messaggi, perchè gli antispam tengono in considerazione le parole contenuto nell' oggetto.

Quindi con un pò di pazienza cambiando l' oggetto delle mail risolvi il problema.

PS. considera che una parte dell' oggetto viene presa dall' intestazione del tuo shop, potrebbe anche essere questa intestazione che l' antispam non gradisce.

Spero di essere stato chiaro.

Ciao

Share this post


Link to post
Share on other sites

Ciao Paman, grazie per la risposta, il fatto è che ho provato a modificare i file contenuti nella cartella mails/it, ma non mi cambia assolutamente niente.
Ero anche io convinto che parte dei problemi erano dovuti all'intestazione del messaggio, ma non riesco per esempio a trovare la stringa da dove prende il nome del negozio, inoltre come dicevo precedentemente se imposto l'SMTP manualmente non mi funziona proprio, ovvero una volta che invio un messaggio al cliente dal BO mi rimanda all'index del negozio senza inviarla. Hai per caso idea se esiste qualche gestore di mail gratuito tipo GMAIL che si può utilizzare per inviare le mail?
Inoltre rimango veramente stupito dal fatto che un sistema così ben costruito e flessibile faccia acqua per colpa di Hotmail e parenti.
Mah!!

Ciao e Grazie

Share this post


Link to post
Share on other sites


Inoltre rimango veramente stupito dal fatto che un sistema così ben costruito e flessibile faccia acqua per colpa di Hotmail e parenti.
Mah!!


Non Spariamo sulla Croce Rossa, passami la battuta, ma il problema dello spam non dipende da PS ma da tanti fattori, oltre a quelli detti da paman ve ne è un altro, il server da cui generi le mail non è che il gruppo di IP a cui appartiene è finito in una BlakList?

Io proverei un altro server per vedere l'effetto che fa.

Ciao

Sèvero

Share this post


Link to post
Share on other sites


ciao severo, quindi tu non hai problemi con utenti hotmail?


No nessun problema e ne ho diversi il sito è il primo in firma.


come hai configurato l'invio della mail?


Ho lasciato le impostazioni di dafault.


hai letto che ho problemi anche nel configurare l'SMTP? sapresti darmi una mano tu?


Su questo no, ma una piccola domanda su che host sei?

Ciao

Sèvero

Share this post


Link to post
Share on other sites

ciao, allora io sto su misterdomain.eu
l'ip del server è 89.188.136.42
giorni fa feci anche un controllo nelle black list, ed in realtà risultava segnalato su tre liste (diciamo).
Contattai subito il mantaiener e spiegai il problema, però mi rispose così:
"Il 100% delle black list più importanti accetta la nostra posta, per noi non c'è quindi nessun problema."

ora, la mia domanda è questa:
per evitare di ritrovarmi magari su un altro server che poi abbia lo stesso problema, è possibile ,e se si come, configurare l'inivo delle mail con un indirizzo esterno tipo GMAIL o roba del genere?
poi.. come e dove va a prendere il nome del sito il "sistema" e quindi lo mette come intestatario del mittente?
secondo me si può aggirare il problema, l'unica cosa è capire come. Io ci sto impazzendo e ripeto che cercando in tanti altri 3d del forum (francesi, olandesi, tedeschi, spagnoli) non ci sono riuscito.
booh!
è una settimana che sto fermo.

ciao

Share this post


Link to post
Share on other sites

Ciao

Hai modificato anche il file lang.php contenuto nella cartella \mails\it ?

traducendo le seguenti voci

$_LANGMAIL['Your new admin password'] = 'Your new admin password';
$_LANGMAIL['Your password'] = 'Your password';
$_LANGMAIL['Welcome!'] = 'Welcome!';
$_LANGMAIL['Order confirmation'] = 'Order confirmation';
$_LANGMAIL['Message from contact form'] = 'Message from contact form';
$_LANGMAIL['My personal informations'] = 'My personal informations';
$_LANGMAIL['Message from a customer'] = 'Message from a customer';

Share this post


Link to post
Share on other sites

si ci ho provato, l'unica cosa che non riesco proprio a trovare, è da dove cavolo prende il nome del mittente della mail ovvero per intenderci il nome del negozio.
Io vorrei modificare anche il mittente oltre all'oggetto della mail, ma non riesco proprio a capire dove cacchio è.
vabè continuo a cercare

Share this post


Link to post
Share on other sites

  • 1 month later...

Ciao a tutti, sono nuovissimo sia del forum che nell'uso di PS. Ho installato la versione 1.2.5, aggiornato il file lang, poi ho cominciato a fere le varie prove... cliente fittizio, acquisto, controllo mail di conferma, ecc... Il primo scoglio da superare è stato il dover modificare il file bankwire.html per poter visualizzare correttamente i dati necessari al cliente per eseguire il bonifico bancario. Ora, e vengo al punto, sono alla ricerca di una soluzione al problema delle e-mail che vengono scambiate per spam dai vari siti (io ho potuto provare con gmail.it e libero). Alcune passano, altre finiscono nel cestino. Il server che ospita la mia installazione è ilbello.com, uso la funzione mail() di php, e pare che funzioni bene perchè le mail partono, ma alcune non arrivano. Volevo chiedervi: c'è un modo per togliere le parentesi quadre che stanno prima e dopo il nome dell'e-shop nell'oggetto delle e-mail??? Ho letto diversi post su come modificare l'oggetto, ma nulla che parlasse di come togliere le parentesi quadre. Grazie a chi mi vorrà dare una dritta in tal senso.
Bye.

Share this post


Link to post
Share on other sites

  • 8 months later...

Scrivo ma già so che non ricevero nessuna risposta come del resto sono abituato su questo forum.
Il problema sostanziale di prestashop in questa situazione è che se si seleziona il metodo tramite configurazione manuale dell'SMTP come nel mio caso, invia correttamente al cliente le mail ma non le invia all'amministratore del negozio, cosa importantissima per chi ha piu store e deve gestire gli ordini in maniera celere.
Nessuno in cosi tanti mesi ha risolto il problema?

Share this post


Link to post
Share on other sites

Scrivo ma già so che non ricevero nessuna risposta come del resto sono abituato su questo forum.
Il problema sostanziale di prestashop in questa situazione è che se si seleziona il metodo tramite configurazione manuale dell'SMTP come nel mio caso, invia correttamente al cliente le mail ma non le invia all'amministratore del negozio, cosa importantissima per chi ha piu store e deve gestire gli ordini in maniera celere.
Nessuno in cosi tanti mesi ha risolto il problema?

Ciao
Prova a spuntare le caselle Entrambi e PHP mail .

Share this post


Link to post
Share on other sites

Ciao TORO,

immagini che quello che tu dici, sia che il server di posta è esterno allo stesso dominio?

Nel senso, se io uso php per inviare ad una mail di un altro dominio funziona, nel caso in cui li mandi ad altri e non a te stesso, forse c'è un problema di DNS (cioè hai la gestione dei dns MX su un altro server)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More