Jump to content
GAELLE

cherche module pour remplacer module cadeau au panier "gift on order"

Recommended Posts

Bonjour!

 

Je suis actuellement en version 1.3, cependant je devrais passer en version 1.6.0.8 dans peu de temps

 

A ce jour, j'ai sur ma boutique le module Gift on order de aleacorner : http://addons.prestashop.com/fr/merchandising-vente-modules-prestashop/442-gift-on-order-ajout-de-cadeaux-au-panier.html

 

Malheureusement ce module n'est pas compatible avec la version 1.6.0.8, j'ai tenté de contacter le dev à plusieurs reprises ces derniers mois pour savoir s'il serait compatible mais je n'ai jamais eu de réponse..

 

Je me résigne donc à chercher un autre module qui pourrait convenir à ma boutique.

 

J'e cherche un module qui pourrait faire ceci :

 

J'ai plusieurs offres sur ma boutique, notamment celles ci :

5 lettres achetés au choix = 1 collier pour animaux offert
(le client choisi 5 lettres ou plus parmis les 26 lettres de l'alphabet et dès que le client a ajouté ses 5 lettres, un collier en cadeau se met automatiquement dans le panier)

 

Voici la fiche produit pour exemple : http://www.gueule-damour.com/lettres-strass-swarovski-pour-colliers-chiens-et-chats-/22-petite-lettre-strass-swarovski-pour-collier-chien-et-chat-10-mm.html

 

Est ce que qu'une personne connait un module qui aurait les mêmes posibilités ? 

 

J'ai repéré sur addons celui ci : http://addons.prestashop.com/fr/fonctionnalites-front-office-modules-prestashop/4738-ajout-automatique-produit-assurance-cadeaux-au-panier.html

 

mais je crois qu'avec ce module le cadeau se met dans le panier à partir d'un certain montant, marque mais pas de quantités, qu'en pensez vous ? 

 

Merci beaucoup pour votre aide, à très bientôt j'espère!

 

bonne journée à toutes et tous!!

 

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour votre réponse.

Je viens de regarder, mais je ne veux pas que le client rentre un code pour obtenir son cadeau, je veux que le cadeau s'ajoute automatiquement au panier

 

à moins que j'ai raté quelque chose, un onglet?

Share this post


Link to post
Share on other sites

Bonjour,

 

le module est annoncé comme compatible 1.5.6.2 donc, il y a de fortes chances qu'il fonctionne sur 1.6.

Share this post


Link to post
Share on other sites

Ok, merci pour l'info! je vais essayer!

 

Si oleacorner pouvait me répondre directement, çela serait sympa;-)

Share this post


Link to post
Share on other sites

Bonsoir,

 

Comme le dit Mediacom87... Majoritairement, les modules tournant sous 1.5 tournent sous 1.6 sans trop de problèmes.

 

Toutefois, si vous n'aviez pas de réponses et que le module n'est pas disponible en update majeure (et donc requérant une nouvelle licence), vous pouvez également faire appel à un freelance pour la mise en conformité sur votre version.

 

Cela arrive souvent que j'ai des demandes en ce sens, pour toutes versions confondues, à dire vrai. C'est parfois plus simple de mettre à jour un module pré-existant et bien connu du marchand que d'en trouver un autre qui collerait à moitié, finalement :)

Share this post


Link to post
Share on other sites

ça m'étonne énormément qu'ils n'aient une mise à jour pour 1.6, quand on voit le nombre de ventes et le prix du module...

Share this post


Link to post
Share on other sites

Merci! j'ai bien pris note de vos messages!

 

J'espère recevoir une réponse de Oléacorner mais j'en doute car depuis des mois pas de réponses...

Share this post


Link to post
Share on other sites

Je l'ai contacté en message privé pour lui donner le sujet directement, nous verrons. ;-)

Share this post


Link to post
Share on other sites

Merci beaucoup c'est vraiment sympa de votre part! J'espère avoir des ses nouvelles!

 

"le module est annoncé comme compatible 1.5.6.2 donc, il y a de fortes chances qu'il fonctionne sur 1.6." £

 

mais dans ce cas pourquoi n'a t-il pas mit compatible 1.6 ? Si je l'installe tel quel, j'ai peur des bugs qui pourraient se produirent sur la nouvelle boutique...Non? 

Share this post


Link to post
Share on other sites

Avec plaisir.

 

En fait, nous devons - en tant que contributeur - dire de nous-même que le module est compatible pour une nouvelle version de PrestaShop.

Dans le cas de ce module, il est possible que son développeur (en l’occurrence OleaCorner) l'ai oublié ou n'a simplement pas eu la possibilité de le faire.

 

Ne lui souhaitant rien de grave, mais envisageant la possibilité, il se pourrait que celui-ci ai eu des empêchements et imprévus dans sa vie professionnelle (et privée) qui font qu'il n'a pu mettre cette information à jour. D'où, éventuellement, le manque de réponses possibles de sa part.

 

Ce dernier ayant été quelqu'un de disponible et d'actif sur le forum, je suis moi-même surpris de son manque de réponses si, comme vous le dites, cela fait plusieurs temps et plusieurs fois que vous faites la tentative de contact.

 

Pour en revenir à la compatibilité et à votre question, c'est tout à fait possible. L'idée serait de pouvoir réaliser un test sur les fonctions de bases du module pour une version vierge de PrestaShop 1.6. Ainsi, lors de l'installation et à la configuration, vous remarquerez assez vite si celui-ci n'est pas pleinement fonctionnel.

Share this post


Link to post
Share on other sites

Après un test sur une version 1.6.0.8 de base,  le module ne fonctionne pas, cela provoque une erreur en BO et celui ci devient inutilisable au niveau des modules....

 

il faut maintenant que je trouve une solution pour faire fonctionner ce module sur la nouvelle version 1.6.0.8 !

 

Merci à tous pour vos réponses rapides, c'est super sympa :-)

Edited by GAELLE (see edit history)

Share this post


Link to post
Share on other sites

Vous avez bien la dernière version du module ?

 

Si oui, on peut certainement vous l'adapter pour la 1.6

Edited by Mediacom87 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

oui j'ai en ma possession le module "gift on order", quel serait le tarif pour cette adaptation ? Répondez moi en MP si vous le souhaitez ;-)

Share this post


Link to post
Share on other sites

Bonjour!

 

Concernant le module gift on order, dans la doc, je n'ai que les modifications pour la version 1.4 et inférieur.... pas de modifications pour la version 1.5

 

Comment faire dans ce cas ? Oleacorner ne me répond pas...Comment récupérer la dernière version ??

 

Merci!!

Share this post


Link to post
Share on other sites

Bonjour,

 

De fait, vous êtes en 1.3. La version qui serait compatible 1.5 (et éventuellement 1.6) n'est surement pas la même ; il s'agit souvent de ce que l'on appelle une mise à jour majeure du module et cela nécessite l'acquisition de celui-ci à nouveau.

 

Tout dépend si vous avez effectué votre achat sur Addons ou autre, mais voyez si celui-ci est disponible dans votre compte client, éventuellement.

Share this post


Link to post
Share on other sites

Je viens de regarder, j'ai bien acheté le module Gift on order sur Addons, 160 euros...

Edited by GAELLE (see edit history)

Share this post


Link to post
Share on other sites

Et vous n'avez donc pas de mises à jours disponibles pour celui-ci ? Dernière version possible pour vous, c'est laquelle ?

Share this post


Link to post
Share on other sites

non je n'ai pas de mise à jour...Enfin je ne sais pas, je n'ai pas de réponse du dev...

 

J'ai acheté ce module en septembre 2011,  je n'ai que les modifications pour la version 1.4 et inférieur

 

Dois je racheter de nouveau ce module? :-(

Edited by GAELLE (see edit history)

Share this post


Link to post
Share on other sites

Pas spécifiquement.

 

Normalement, je vous ai transmis dernièrement mon adresse mail par messagerie privée, l'avez-vous reçue ? Vous pouvez envisager de me connecter afin que je puisse vous éclairer sur les modifications à faire et sur le temps de réalisation que ça prendrait, ou si il est préférable pour vous de passer par l'achat.

 

N.B. : Pour vous expliquer un peu, on considère (chez PrestaShop) que certaines mises à jours sont de l'ordre des mises à jours majeures. Cela entraine une maintenance de plusieurs versions de modules pour un développeur et cela nécessite d’acquérir à nouveau une licence. Malheureusement, il n'existe pas encore d'options pour offrir une mise à jour majeure à un client ayant déjà acquis celle-ci moins chère, par exemple. Voici, ceci afin d'illustrer votre problématique, donc.

Share this post


Link to post
Share on other sites

Pour l'info, j'ai eu la possibilité de testé le module (dernière release) sur une v1.6 de PrestaShop à l'instant. Elle n'est pas compatible et fonctionnelle en l'état.

Share this post


Link to post
Share on other sites

ok, merci beaucoup pour l'info, c'est sympa:-)

 

Donc concrètement, le mieux serait que je rachète la dernière version ?

 

Mais étant donné qu'elle n'est pas fonctionnelle en l'état, sera t-il possible d'adapter le module pour la version 1..6.0.8?

Edited by GAELLE (see edit history)

Share this post


Link to post
Share on other sites

Avec plaisir.

 

Donc, en effet. En prenant la dernière version, vous en aurez une qui ne nécessite pas de grandes adaptations pour être fonctionnelle avec les versions 1.6, en effet.

 

Et, oui, j'ai testé pour voir, c'est possible d'adapter le module, sans soucis :)

Share this post


Link to post
Share on other sites

Hello

Je ne sais pas si quelqu'un lira et si ce post est toujours d'actualité mais tant pis je me lance !!!

 

J'ai aussi pour un client le module GiftOnOrder v5.0.2 - par Oleacorner

Ce module est sensé fonctionner avec V1.6.1.0  mais impossible de faire passer les cadeaux automatiquement dans le panier si commande minimum atteinte  et idem si l'on paramètre plusieurs cadeaux :  le client doit choisir un cadeau dans la liste des cadeaux qui s'affiche mais on clique et rien ne va dans le panier

 

 

Et bien sur a part de me dire une fois de réinstaller OLEACORNER ne réponds plus depuis +1 mois!  vu le tarif du module c'est vraiment pas top !

 

Quelqu'un aurait une idée sur la question ?

Merci pour vos lumières

Edited by bretweb (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More