Jump to content
josemaria

[SOLUCIONADO]Error con las traducciones de los mails, %7B, %7D

Recommended Posts

Hola a tod@s, 

 

Voy a tratar de explicar el problema que tengo; he estado varios días buscando problemas similares por el foro y he probado varias opciones que otros usuarios han comentado. Al ver que no solucionaba mi problema, me he decidido a registrarme y preguntar...

 

En primer lugar, voy a explicar el tema:
 

Estoy editando los mails de mi tienda, desde las carpetas:

/themes/mitema/mails/es 

/themes/mitema/modules/nombre_del_modulo/mails

todo vía FTP.

 

En principio todo esto se hace correctamente, y los mails se traducen y se envían como deben pero, cuando voy a "Localización -> Traducciones" y edito cualquiera de ellos, ya sea los de la carpeta /mails/es... como los de los módulos.

La plantilla de emails, se vuelve a su condición inicial (por defecto) y no solo eso, sino en los simbolos { } se convierten en su código %7B y %7D respectivamente. 

 

¿A qué puede ser debido?

En la pantalla de traducciones no da ningún error ni mensaje. 
 

Pero me tiene algo contrariado el hecho de que se cambien las plantillas por si solas... edito una, y las 70+ plantillas de email, se cambian a su situación inicial...

 

Cosas que he probado:

- Deshabilitar caché y forzar compilación

- Editar también los mails de las carpetas mails y moduiles del directorio raiz

 

Está claro que en no editando los mails desde Localización->Traducciones, no voy a perder los cambios, pero ya es por la intrigra o el querer saber que pasa... 

 

Muchas gracias de antemano,

 

Saludos
Jose

 

Edited by josemaria (see edit history)

Share this post


Link to post
Share on other sites

He encontrado la solución al problema...
 
En el ftp, dentro de la ruta:
/controllers/admin/AdminTranslationsController.php
 
Busca la linea:
file_put_contents($path.$mail_name.'.'.$type_content, Tools::purifyHTML($content));
 

Y reemplazala por:
file_put_contents($path.$mail_name.'.'.$type_content, $content);

 

Nota:  Después de este cambio, ya no se volverá a editar el { } por los %7B y %7D

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Funciona de maravilla ... desaparece este fondo verde que se generaba cuando se clic en guardar desde  traducción ... por ejemplo para el template account fonciono de maravilla ...

Pero en el template bankwire ya no esta el fondo verde ... pero genera una pagina blanca et no puedes concluir tu pedido  :wacko:   parece que traducción daña las plantillas!!?? sera un Bug del 1.6.11 ???

Share this post


Link to post
Share on other sites

Efectivamenent es un BUG ...

Ya reportado ... y con la solucion de jose maria ...

http://forge.prestashop.com/browse/PSCSX-4594?jql=

 

solucion Original...

https://www.prestashop.com/forums/topic/413406-solved-email-templates-urls-broken-after-editing-and-saving-%7B-%7D/

 

Igualmente hay que estar seguro de tener disable PHP Magic Quotes

 

https://www.prestashop.com/forums/topic/394827-html-for-default-email-template-not-working/

  • Like 1

Share this post


Link to post
Share on other sites

Muchas gracias por la respuesta tenía este problema y me estaba comiendo la cabeza ! 

Share this post


Link to post
Share on other sites

hola a todos, yo estoy con Prestashop Cloud y no puedo acceder  a esta ruta:  /controllers/admin/AdminTranslationsController.php

 por lo cual no logro que la modificación de emails tenga un buen resultado aún no se muestra el logo de mi marca y ademas no se donde modificar el email del link ''enviar a un amigo'' no aparece en la lista mails/es

Alguien que pudiera ayudarme por favor,  ah y además cuando un cliente quiere recuperar su contraseña el link que aparece en el mail para recuperar dicha contraseña no funciona, qué puedo hacer por favor.

Gracias !!!

Lucy

 

 

Lucy

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More