Jump to content

[Resolu] Mes modules n’apparaissent pas dans l’interface d’administration!?


Recommended Posts

Bonjour,

Je viens de "monter" de nouveaux modules sur mon serveur.

Uploadés par FTP dans le dossier Modules, pourtant lorsque je vais dans ADMIN > Modules, il m'est impossible d'installer les modules car ils n'apparaissent pas dans la liste.

J'ai fais une recherche sur le forum et je suis tombé sur des messages similaires, mais sans réponses permettant de résoudre le problème malheureusement.

Est-ce que vous avez des suggestions?

En vous remerciant.

Damien

Share this post


Link to post
Share on other sites

Une piste :
le nom du répertoire du module doit être exactement le même que la variable $name dans le fichier .php
Vérifiez bien les majuscules/minuscules

[edit]
nom du répertoire, nom du fichier et contenu de la variable doivent être les même

Share this post


Link to post
Share on other sites

Bonjour,
Soit le module n'est pas compatible avec la version de prestashop Ex : module pour presta 1.1 peut ne pas être valide pour presta 1.2.5,
verifiez que le dossier "module " n'est pas un sous-dossier.

Comme le dit olea
le nom du répertoire du module doit être exactement le même que la variable $name dans le fichier .php.

Share this post


Link to post
Share on other sites

Merci beaucoup pour vos réponses.

En regardant dans "nomdumodule.php" si le nom du module dans le constructeur était le même que le nom du dossier, je me suis aperçu que le "display name" était diffèrent du nom du module. Autrement dit, ce que je cherchais était sous mon nez, mais avec un nom auquel je ne m'attendais pas. Duuuhhh!!!

Merci beaucoup à vous, il n'y a plus de problème... il faut juste que je fasse un peu plus attention!

A+

Damien

Share this post


Link to post
Share on other sites
  • 2 months later...

Bonjour,

Je viens d'acheter le module slideshow chez prestatore.
Je l'ai téléchargé et ensuite uploader dans le repertoire module
Ce dernier n'apparait pas dans mon back end.
J'ai lu vos posts et verifier tout ce qui a été dit et le module slide show n'apparait toujours pas.

Quelqu'un peut il m'aider ?

Merci

Luc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More