Jump to content
Sign in to follow this  
Pat64

[Résolu] -[Tips] Résolution du problème du bloc "catégories" lorsqu’il est vide

Recommended Posts

Tel qu'il est conçu, le fichier /root/modules/blockcategories/blockcategories.tpl renvoit une erreur de validation w3c lorsqu'aucune catégorie n'est encore créée.

 

Voici le petit correctif (fichier intégral) :

 

[pre]<!-- Block categories module -->

<div class="block_title">

<img src="{$module_dir}logo.gif" alt="" title="{l s='Categories' mod='blockcategories'}" /> {l s='Categories' mod='blockcategories'}

</div>

<div id="categories" class="block">

{if $categories}<ul class="category">

{foreach from=$categories item=category}

<li><a href="{$link->getCategoryLink($category.id_category, $category.link_rewrite)}">{$category.name}</a></li>

{/foreach}

</ul>{/if}

</div>

<div class="block_footer"></div>

<!-- /Block categories module -->[/pre]

 

Comme vous pouvez le constater, une condition {if...} teste l'existance de catégorie, et affiche, le cas échéant, le code xhtml de la liste non ordonnée ; sinon, la liste ne s'affiche pas.

 

Cordialement,

Patrick.

 

 

Share this post


Link to post
Share on other sites

@Matthieu,

 

Merci d'ajouter ce correctif dans la prochaine release.

 

Cordialement,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More