Jump to content

Αναβάθμιση απο 1.4.7.3 σε 1.6.xxxx


grgdmrs
 Share

Recommended Posts

Καλησπέρα σας,

Χρησιμοποιώ την έκδοση 1.4.7.3 και ο admin μου μου είπε πως μετά απο 3 χρόνια φουλ λειτουργία θα πρέπει να αναβαθμίσω την πλατφόρμα.

ΟΚ λοιπόν. Πάμε. 

  1. Με τη αναβάθμιση θα πρέπει να μεταφερθούν πέραν των αυτονόητων, ( ειδών, πελατών, διευθύνσεων κλπ κλπ κλπ) θα πρέπει να ακολουθήσουν και οι loyalty points που έχει ο κάθε πελάτης μου. ΜΕ ΛΙΓΑ ΛΟΓΙΑ ΤΑ ΠΑΝΤΑ. Θα πρέπει να υπάρχει μια συνλεχεια με τους πελάτες μου. Και αυτό επειδή πουλώ αναλώσιμα είδη και έχω σταθερούς πελάτες. Οι loyalty points είναι κάτι που το κοιτάνε έντονα. Αυτό πόσο εύκολο ή γρήγορο μπορεί να είναι??? 
  2. Κανένα απο τα templates που κοιτώ δεν μου αρέσει. Οπότε σκέφτομαι να δω την περίπτωση να αναβαθμιστώ αλλά να κρατήσω το ίδιο Theme. Είναι αυτό εφικτό? Θα μου δημιουργήσει πολλά προβλήματα???

Ευχαριστώ προκαταβολικά για όποια βοήθεια για σκέψη μου δώσετε.

 

Η σελίδα μου είναι www.vaporsolutions.gr

Share this post


Link to post
Share on other sites

Το αυτόματο upgrade (με την χρήση του "1-Click Upgrade" module) θα πρέπει λογικά να σου δουλέψει, διατηρώντας και όλα τα δεδομένα του eshop σου. Το module που χρησιμοποιείς για Loyalty Points είναι από τα ενσωματωμένα του PrestaShop ή το αγόρασες έξτρα; Αν είναι ενσωματωμένο, θα διατηρηθούν και τα Loyalty Points κατά την αναβάθμιση.

 

Ίσως χρειαστεί να κάνεις πρώτα ένα ενδιάμεσο βήμα upgrade, στην τελευταία σταθερή έκδοση της σειράς 1.4.x (1.4.11.0) και μετά στην τελευταία σταθερή έκδοση της σειράς 1.6.x (αυτήν τη στιγμή είναι η 1.6.0.11, αλλά από ώρα σε ώρα αναμένεται η 1.6.0.12).

 

Εννοείται πάντα πως ΔΕΝ κάνεις upgrade το live site σου στα τυφλά, αλλά πρώτα:

1. Παίρνεις πλήρες backup του live site (αρχεία και βάση δεδομένων)

2. Μεταφέρεις το backup σε ένα δοκιμαστικό/development περιβάλλον. Αυτό θα μπορούσε να είναι ακόμη και στον ίδιο server αν το επιτρέπουν οι δυνατότητες του hosting πακέτου σου. Ή τοπικά σε ένα PC σου, που έχεις εγκαταστήσει κατάλληλη υποδομή (π.χ. μία εικονική μηχανή Virtualbox με Linux περιβάλλον). Έτσι δημιουργείς ένα αντίγραφο του live site

3. Στο αντίγραφο λοιπόν, δοκιμάζεις το upgrade για να σιγουρευτείς ότι όλα θα πάνε καλά

 

Στο τελευταίο που ρωτάς:

Δυστυχώς το template πρέπει να είναι ρητά συμβατό με 1.6.x., και στην περίπτωσή σου κατά πάσα πιθανότητα δεν είναι. Μετά το test upgrade, θα πρέπει να το δεις αυτό το θέμα και να το λύσεις, είτε ξεκινώντας από το default template του 1.6 και κάνοντας επεμβάσεις σε αυτό είτε αγοράζοντας ένα έτοιμο template για 1.6 και παραμετροποιώντας το...

Edited by parsifal (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More