Jump to content

[MODULE] Rotating Fading Text - Create multiple customizable texts that will be rotated using a fade effect


Recommended Posts

This module is especially useful for "News and Updates", "Customer Feedback" and "Special Events", but can be used for whatever you need...

It lets you create multiple customizable texts, select the order they will be displayed (or random) and choose the time between each rotation.

http://www.presto-changeo.com/prestashop-free-modules/26-rotating-fading-text.html

V1.1 was just released, it includes:

* Ability to enter as much text as you need (previously the total limit was about than 30,000 characters).
* Ability to define a delay for each content.
* $iso language bugfix.

Since a new table is used to store the content, your existing content will be discarded.

V1.1.1 was just released, it fixed a UTF-8 encoding issue when using tinyMCE and a missing first text.

V1.1.2 released, it includes a TinyMCE fix for PS 1.3+, and support for PS 1.4

 

v1.3 released

* Added support for PrestaShop 1.6

17006_bsc1jClTmt22LavRcRBm_t

17007_8gAJFSzs6ZuvUWlH8OlI_t

  • Like 2

Share this post


Link to post
Share on other sites

Thanks, it still shows up fine on my browser, can you (or anyone else who also sees this problem) start a live chat on my site so I could fix it and have you check it out.

Share this post


Link to post
Share on other sites

@ tomerg3

Looks really great buddy, although i have a error when i installed the module.
The module install fine but when i go to configure i get this message

 Warning: ksort() expects parameter 1 to be array, null given in /home/gadgets2/public_html/modules/blockfadingtext/blockfadingtext.php on line 223



Any ideas how to solve this ?
The module works but i don`t like the fault error.

Thanks again for sharing this module with us.

Best regards,

ysco..

Share this post


Link to post
Share on other sites
@ tomerg3

Looks really great buddy, although i have a error when i installed the module.
The module install fine but when i go to configure i get this message
 Warning: ksort() expects parameter 1 to be array, null given in /home/gadgets2/public_html/modules/blockfadingtext/blockfadingtext.php on line 223



Any ideas how to solve this ?
The module works but i don`t like the fault error.

Thanks again for sharing this module with us.

Best regards,

ysco..



Someone else also told me about this.

I was not able to reproduce it locally, and it worked fine for him after the first time.

I will look into it, let me know if the problem persists.

Share this post


Link to post
Share on other sites

Hello tomerg3

Will play with it more tomorrow and see what happens, besides the error message the module still works 100% .
Did not see strange behavior, will let you know if the error still persist.

Best regards,

ysco..

Share this post


Link to post
Share on other sites
Can the height be auto adjusted? I have some content is short, and some are long.

This is a great module for advertisment. Thank you very much.


I had it auto adjust at first, but it makes everything below it "jump" when it changes the height.

It didn't not look good, and was a bit confusing and distracting.

It is automatically adjusted to the height of the longest text, so there is no resizing.

If you really want it to adjust based on the current text's height, I can tell you which lines to comment out.

Share this post


Link to post
Share on other sites
@ tomerg3

Looks really great buddy, although i have a error when i installed the module.
The module install fine but when i go to configure i get this message
 Warning: ksort() expects parameter 1 to be array, null given in /home/gadgets2/public_html/modules/blockfadingtext/blockfadingtext.php on line 223



Any ideas how to solve this ?
The module works but i don`t like the fault error.

Thanks again for sharing this module with us.

Best regards,

ysco..



This was fixed in V1.0.2.
There is no need to upgrade since it "fixed itself" once at least one text field was entred

Share this post


Link to post
Share on other sites
Can the height be auto adjusted? I have some content is short, and some are long.

This is a great module for advertisment. Thank you very much.


I had it auto adjust at first, but it makes everything below it "jump" when it changes the height.

It didn't not look good, and was a bit confusing and distracting.

It is automatically adjusted to the height of the longest text, so there is no resizing.

If you really want it to adjust based on the current text's height, I can tell you which lines to comment out.


Thank you very much. It is a good enough reason. Thanks.

Share this post


Link to post
Share on other sites

Hi tomerg3,

Great little Module. Thank you.

A couple of questions.

1. What's TinyMCE?
2. I have to turn on TinyMCE to see all the font/text options etc. Once I've edited the text and updated I have to turn TinyMCE again if I want to edit any text. Is that supposed to happen?

Regards

Share this post


Link to post
Share on other sites
Hi tomerg3,

Great little Module. Thank you.

A couple of questions.

1. What's TinyMCE?
2. I have to turn on TinyMCE to see all the font/text options etc. Once I've edited the text and updated I have to turn TinyMCE again if I want to edit any text. Is that supposed to happen?

Regards


1) TinyMCE is the "Rich Text" editor which is used is many place on prestashop.
2) For some reason it doesn't work with the drag and drop feature to sort the order of the text, which is why I made a button what will enable it, and not have it always enabled.

This problem may be fixed by a newer version of TinyMCE, but I am using the version that comes with prestashop...

Share this post


Link to post
Share on other sites

great module!

i think i find a bug:

after removing the 1st post from the configure panel, the block does not show the rest(s). even if i reinstall the module, it remains the same.

(ps 1.2.5)

regards!

Share this post


Link to post
Share on other sites
great module!

i think i find a bug:

after removing the 1st post from the configure panel, the block does not show the rest(s). even if i reinstall the module, it remains the same.

(ps 1.2.5)

regards!


Hi, you're right, that is a bug :)

You can fix it if you drag one of the text contents (from the module interface), you can drag it down one spot and then back up to where it was, that will sync it once again and resolve the problem

I will probably fix that in the next release (so you won't need to do the drag step).

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Bonjour :-) ,
Ce module est excelent :-) ,
par contre, je cherche à ce qu'il s'affiche au centre de la page mais mal-grès le reglage de position du module, celui-ci ne s'affiche pas :down:
Pouvez vous me dire qu'elle modif doit etre faite à ce module pour que cela fonctionne ? Merci :-)
A bientôt
Steph

Hello :-),
This module is excellent :-),
by cons, I look at what appears in the center of the page but ill-sandstone position adjustment module, it does not appear :down:
Can you tell me that it modifies must be made to this module for this to work? Thank you :-)
Soon
Steph

Share this post


Link to post
Share on other sites

I have noticed it yesterday in another module, PS1.1 has an older version of TinyMCE which doesn't support activation after the page has loaded, or at least not that I can find, I'll try to research some more.

You can however open a TinyMCE editor in another window (like the homepage editor), create your message, and then copy the html source to my module.

Not the prettiest solution, but will work for now.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello tomerg3

Question about your perfect free module, i had it installed without any problems and was working fine but i have updated tiny_mce from this thread here " http://www.prestashop.com/forums/viewthread/44223/third_party_modules/solvedworking_tinymce_update/ " thats the new version 3 with a lot off new features.
Tiny_mce is working when edit/ using it in categories and other stuff but not anymore in you module, i have try`t to figure out to solve it but i can`t find the solution.
I would really appreciate it if you can look at it and let me know how to fix this problem as i like your module very much and i use it on my site.

Best regards,

ysco..

Share this post


Link to post
Share on other sites

I will try to take a look, but I have some many things going on right now, that modification for my free modules are very low on my priority list.

Share this post


Link to post
Share on other sites

Hello tomerg3.

Thanks for the fast reply, if you want i can pay some small fee to get this done as i like your module and hope that it works again.

I also understand that the free modules has low priority but it`s no problem to pay a small fee if you can make some time for it.
Please let me know ;)

Best regards,

ysco..

Share this post


Link to post
Share on other sites

Great work. This is very usefull and should be considerd as a must for everyone. Allowing messages or images to rotate and create life to a dead space is great. A+

Thanks for creating this

Cheers

Share this post


Link to post
Share on other sites

Bonjour :-) ,
je viens de découvrir un petit bug après la mise à jour vers tinyMCE_v.3 telechargeable ici http://www.prestashop.com/?ACT=29&fid=10&aid=9417_5gWrZ0LaLkFKes6GXCkN&board_id=1
depuis ce tread http://www.prestashop.com/forums/viewthread/11087/P90/third_party_modules/tinymce_update

le basculement vers tiny ne fonctionne plus :red:

Merci beaucoup pour le petit coup de pouce :-)
A bientôt
Steph

------------------


Hello :-),
I just found a little bug after upgrading to tinyMCE_v.3 downloadable here http://www.prestashop.com/?ACT=29&fid=10&aid=9417_5gWrZ0LaLkFKes6GXCkN&board_id=1

Since this tread http://www.prestashop.com/forums/viewthread/11087/P90/third_party_modules/tinymce_update

the tiny switch to longer works :red:

Thank you very much for your help :-)
Soon
steph

Share this post


Link to post
Share on other sites

I think I could really benefit from this module for which I thank the creator.

However, I get an error when I try to configure the module in the Back Office. It says that "iso is an undefined variable in line 92 (has to do with langs)."

Everything else works fine... it appears in the BO and the FO within its own module and I can transplant it to it appropriate positions... I just can't edit it!

I've noticed that a few people have gotten this module to work on v. 1.2.5 (my PS version), so what might the problem be and is there an easy fix?

Thanks.

Share this post


Link to post
Share on other sites

So I was able to get this undefined variable : iso error figured out. For anybody else having this issue:

add to line 55

global $cookie;
$iso = Language::getIsoById(intval($cookie->id_lang));



Honestly, I haven't messed around with this module too much yet... so I'm not sure if this is a permanent fix or a good fix at that, but I'm able to configure the module from the BO without an error.

Anybody with more experience, please let me know if this code is not appropriate and may cause problems later.

Thanks.

Share this post


Link to post
Share on other sites

Greetings,

Does anybody know if each block of text is stored in the database? If so, what is the name of the table?

I had it working in the BO, but when I entered my first block of text and clicked "update" it gave me a php notice... something about an undefined offset. So I clicked "back" on the browser and pressed "update" again... this time it gave me the same error plus another one: PHP Warning: Illegal offset type in C:\mysite\modules\blockfadingtext\blockfadingtext.php on line 223

I've uninstalled the module and reinstalled it again multiple times, and now I can't even access the module's config interface without this error. So I am thinking the information from the first block of text is still stored somewhere and not indexing correctly.

Any help would be appreciated. Thanks.

Share this post


Link to post
Share on other sites

The text is store in the prestashop configuration table.

I'm going to update this to a new database table in the next version, and possibly add a couple of small new features.

Share this post


Link to post
Share on other sites
The text is store in the prestashop configuration table.



Hi Thanks for sharing the module. I have already set up a table faq in the center column. Is there a way, like change some lines so that this modules will read the data from the faq table? Thank you again for the module.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

V1.1 was just released, it includes:

* Ability to enter as much text as you need (previously the total limit was about than 30,000 characters).
* Ability to define a delay for each content.
* $iso language bugfix.

Since a new table is used to store the content, your existing content will be discarded.

Share this post


Link to post
Share on other sites

Hi tomerg3,

I have installed this module but am having some trouble with it - I am using Moon theme which seems to overide the css of this module. It uses the sytem css from the themes global.css. I am supposing that I need to create a div in my theme? I have fixed the module to my homepage under the slider.

I can't seem to get it to support French - I've tried entering everything in HTML but it doesn't seem to want to handle the accents like if it was not in UTF-8 ? I'm getting those little square things for each accent.

I noticed there is a fr.php file in the module so obviously you have created it to be bilingual - Tried looking in the BO with translation tool but there is no content in there but found it in database and everything is in there in HTML alright - but no lge1 lge2 option anywhere.

what am I doing wrong?

Thanks!

Share this post


Link to post
Share on other sites

Hey Tomer, thanks for this awesome module. I orginally had a previous version of this module installed on my shop, and I found great use of it. A couple of days ago, I upgraded to your newest version. I must say the install went great and I had no error messages when I added/updated the rotating text. Since everything went so well in the BO I didn't really pay too much attention to the FO. However, last night I noticed that the first block of text was not showing up.

I don't know if anybody else have had this problem... I am able to successfully enter text and update it in the BO, which I've done for a few blocks. However, in the front office every block of text appears except whatever text is in the first block. It definately recognizes something being in the block but doesnt display any text.... Iknow this because all the texts will rotate through including the first block except instead of text its shows only the header then moves on successfully to the next block of text which then appears.

I've uninstalled it, cleared the database, deleted it, and reinstalled it, but I seem to always get the same results... Idon't know if its a bug or just my version.

Thanks for any advice you might have.

Share this post


Link to post
Share on other sites
Hey Tomer, thanks for this awesome module. I orginally had a previous version of this module installed on my shop, and I found great use of it. A couple of days ago, I upgraded to your newest version. I must say the install went great and I had no error messages when I added/updated the rotating text. Since everything went so well in the BO I didn't really pay too much attention to the FO. However, last night I noticed that the first block of text was not showing up.

I don't know if anybody else have had this problem... I am able to successfully enter text and update it in the BO, which I've done for a few blocks. However, in the front office every block of text appears except whatever text is in the first block. It definately recognizes something being in the block but doesnt display any text.... Iknow this because all the texts will rotate through including the first block except instead of text its shows only the header then moves on successfully to the next block of text which then appears.

I've uninstalled it, cleared the database, deleted it, and reinstalled it, but I seem to always get the same results... Idon't know if its a bug or just my version.

Thanks for any advice you might have.



Same here, the first block does not appear.

Share this post


Link to post
Share on other sites

Re-Hello


mytheory. - 30 Mars 2010 03:11 PM
Hey Tomer, thanks for this awesome module. I orginally had a previous version of this module installed on my shop, and I found great use of it. A couple of days ago, I upgraded to your newest version. I must say the install went great and I had no error messages when I added/updated the rotating text. Since everything went so well in the BO I didn’t really pay too much attention to the FO. However, last night I noticed that the first block of text was not showing up.

I don’t know if anybody else have had this problem… I am able to successfully enter text and update it in the BO, which I’ve done for a few blocks. However, in the front office every block of text appears except whatever text is in the first block. It definately recognizes something being in the block but doesnt display any text…. Iknow this because all the texts will rotate through including the first block except instead of text its shows only the header then moves on successfully to the next block of text which then appears.

I’ve uninstalled it, cleared the database, deleted it, and reinstalled it, but I seem to always get the same results… Idon’t know if its a bug or just my version.

Thanks for any advice you might have.


I have the same problem the first bloc does not appear and remains white, and always turns in rotation.
accents are not taken into account UTF-8.
I'm going to hand to the paw to see if I find the bug.
Bye Bye
sorry for my English %-P

Share this post


Link to post
Share on other sites
V1.1.1 was just released, it fixed a UTF-8 encoding issue when using tinyMCE and a missing first text.



I see another problem, text goes out of the box if the line is wider than the width of the box, same for height

Share this post


Link to post
Share on other sites
V1.1.1 was just released, it fixed a UTF-8 encoding issue when using tinyMCE and a missing first text.



I see another problem, text goes out of the box if the line is wider than the width of the box, same for height




Looks like it works, my bad

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Hey Tomerg! THanks for the utf-8 fix - any chance this may become multiple language? There are NO multiple language news modules or anything of this nature available...
At least... i haven't found any :( - bit of a bummer on a multi language store!

Share this post


Link to post
Share on other sites

thanks for your response - I'll sit patient! - I've been trying to modify a certain number of modules (editorial) but just cannot get the backoffice to pickup {l s=’your expression’ mod=’module’}... didn't seem that complicated, but it's beyond my coding knowledge! Will try to get something simple figured tho' as all I really want is a static text block and it be translatable! ;)

Good luck on catching up... wish I could help.

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...

tomerg3,

wonderfull module, but if can give you one idea to make it more wonderfull :-)

If you enter a testimonial with long text then you have a large square field that is empty if other texts are short.

maybe you can do something like showing the first 200 characters followed by a persons name and to make it complete just add a rating :-) from 1 to 5? and a button, show all?

then you have something like :

This module is free ofcourse and my ideas can help you to be a big hit :-)

included an example that would be nice.
and yes I'm allready using yours :-)

29423_VrlsNJKjulJ24wVuLBbq_t

Share this post


Link to post
Share on other sites
  • 3 months later...

Excellent work! But as it would be possible to be done so that the text can be in several languages. That is to say, the news that are published to be able to write them in several languages for when the user changes of language all the news.
With this I mean that not only is the headed one of unit in different languages, if not the news and updates that one writes.
For example, I publish the following news:
“it has left a new module that is excellent, you do not stop visiting the unloading area”. Ok, since I can do so that if the user selects the English language, only sees it in English?
I believe that it would be a good option for the next update of the module, to allow to write the news in several languages. Thank you.

Best Regards

Share this post


Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...
  • 1 month later...

Thank you, downloading now; preparing myself for trying the 1.4 upgrade this weekend and if everything alright will buy the Duplicate module.

Share this post


Link to post
Share on other sites
  • 3 weeks later...

It is set to automatically set the height to that of the longest text.

You can change it in blockfadingtext.tpl line $51

$("#bft_fade"+x).height(bft_max_height);



Replace bft_max_height with the height you want to use.

Share this post


Link to post
Share on other sites
  • 5 weeks later...

I will look into it, in the meanwhile you can use any of the other tinymce windows and paste the html in the module.

Share this post


Link to post
Share on other sites
  • 10 months later...
  • 5 months later...
  • 2 months later...
  • 2 weeks later...