Jump to content

Recommended Posts

Oi pessoal, veja se alguém pode me ajudar , meu php.ini não está alterando esta configuração
 
Aviso! Seu provedor de hospedagem está utilizando o script de PHP Suhosin, que limita o número máximo de campos permitidos em um formulário: 1000 para suhosin.post.max_vars.
1000 para suhosin.request.max_vars.
Favor solicitar ao seu servidor de hospedagem para aumentar este limite para 2611 pelo menos, ou você terá que editar os arquivos de tradução.

 

Eu estou utilizando uma hospedagem da intelhost , mas testei em outra e deu o mesmo erro 

 

este é o meu php.ini

 

    ; By Exadra37 - Optimized php configuration for servers that use Prestashop Online Stores
    ; Some are changed and i add others rules
    ; Feel free to contribute with more tips to this php.ini file to optimize more the Prestashop Compability and Performance in the server
 
    ;;;;;;;;;;;;;;;;;;;
    ; About php.ini   ;
    ;;;;;;;;;;;;;;;;;;;
    ; PHP's initialization file, generally called php.ini, is responsible for
    ; configuring many of the aspects of PHP's behavior.
 
    ; How many GET/POST/COOKIE input variables may be accepted
    max_input_vars = 10000
 
    ; Allow files to be uploaded
    file_uploads = On
 
    ; Allow external URLs to be opened
    Allowllow_url_fopen = On
 
    ; Disable PHP register globals
    register_globals = Off
 
    ; Enable GZIP compression at the default level for best performance
    zlib.output_compression = On
    zlib.output_compression_level = 6
 
    ; Load mcrypt extension
    extension=mcrypt.so
 
    ; Disable PHP magic quotes
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
 
    ; Load PDO MySQL extension
    extension=pdo.so
    extension=pdo_mysql.so
 
    ; Set memory limit in megabytes
    memory_limit = 128M
 
    ; Set maximum execution time in seconds
    max_execution_time = 120
 
    ; Set maximum file upload size in megabytes
    upload_max_filesize = 32M
 
    ; Set maximum post size in megabytes
    post_max_size = 32M
 
    ; Set maximum input time in seconds
    max_input_time = 180
 

Share this post


Link to post
Share on other sites

Adicione estas 2 linhas:

suhosin.get.max_vars = 10000
suhosin.post.max_vars = 10000

Share this post


Link to post
Share on other sites

Antes de mais nada, vc. possue poderes para alterar os valores do servidor com php.ini próprio ? Se nao entao vc. pode adicionar o que quiser lá que nao terá efeito mesmo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More