Jump to content
  • 0
Elixe

Run Live Edit > TECHNICAL ERROR: Failed to load module list

Question

Hello everybody,

I try to edit modules positions and I get this error.  Unavaibled to change anything or save. I dont know how to fix this in Prestashop Cloud.

TECHNICAL ERROR:

Failed to load module list

 

 

Any idea?

 

Thank you.

 

 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Hi there!


 


I had the same problem today, and I found out that you can solve it by making sure you are connected to the back office and front office on the same domain.


an example:


 


I access my back office using: http://myshop.ps-web....com/backoffice


I access my front office using: http://myshop.com


 


 


In the above example, the error will occur.


 


Try accessing your back office using the same domain as your shops front office.


Like this:


 


Access the back office using: http://myshop.com/backoffice


Access the front office using: http://myshop.com


 


I hope this makes sense. It worked for me.


 


-Simon


  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I tried the solution using several different employee logins and still have not been able to get past this error "failed to load module list" on live edit. Are there any other solutions that anybody knows of? 

Share this post


Link to post
Share on other sites
  • 0

Same problem for me. Nothing works. It's kind of ridiculous when you think about it that we must try to use a workaround in order for it to work. Our company wants to switch our online store with prestashop but since we are unable even in a demo mode to even do anything we are starting to have doubts about this product. Let's just say this is not a good start at all!

Share this post


Link to post
Share on other sites
  • 0

This is totally ridiculous! Tech support answered me: A rep will be reaching out to you in email to help you get this resolved. Best regards,Dave.

 

 The rep send us a link to pay for a support plan for a year! Nobody helped us with anything. We are not even live and still in demo mode and testing and they want us to pay in advance for something that is not working???

 

If someone offered you a vacuum cleaner for free and told you it was not working but that it could possibly work if you paid in advance for maintenance and repairs... would you take it???

Share this post


Link to post
Share on other sites
  • 0

Hello all,

 

For me it's worked like this:

I reinstalled prestashop (using softaculous) and in the beggining of instalation when you have to choose from the field "choose protocol" select from the drop down meniu  "  http://www.  "   don't leave the first option  , the default one,  wich is :  " http://   "   in this way .

In this way you are connected to the back office and the front office on the same domanie because "www" it is important as jonza12 mention on the:  https://www.prestashop.com/forums/topic/99636-error-al-utilizar-live-edit-failed-to-load-module-list/

Share this post


Link to post
Share on other sites
  • 0

This is totally ridiculous! Tech support answered me: A rep will be reaching out to you in email to help you get this resolved. Best regards,Dave.

 

 The rep send us a link to pay for a support plan for a year! Nobody helped us with anything. We are not even live and still in demo mode and testing and they want us to pay in advance for something that is not working???

 

If someone offered you a vacuum cleaner for free and told you it was not working but that it could possibly work if you paid in advance for maintenance and repairs... would you take it???

 

 

I finally found the answer, You are probably using SSL.  Log into the back office with your https url...

so now when you click live edit your browser will have this address

example.pswebstore.com/?live_edit=1&ad=backoffice&liveToken=ae75956456451042fec1e850241d&id_employee=3&id_shop=1

add the https back to the front of the url like this...

https://example.pswebstore.com/?live_edit=1&ad=backoffice&liveToken=ae75956456451042fec1e850241d&id_employee=3&id_shop=1

 

-Best regards, Dave

Share this post


Link to post
Share on other sites
  • 0

it actually has to do with the cloud load balancer not enforcing the https on the page load.  You can demonstrate it to yourself by going to a site page directly without https.  The load balancer will not enforce and reload the page as ssl.  Every page after will be https because the site corrects it in the links everywhere... by navigating around.  However the live edit button launches a new tab and it is not enforcing the SSL/https

Share this post


Link to post
Share on other sites
  • 0

to make ik complex I have a multi-store environment and half of the shops have a SSL certificate and the other half not. I think it is part of the issue and other part the "www" or "http". But still no solution for the problem in prestashop 1.6.1.4

Share this post


Link to post
Share on other sites
  • 0

Hi all,

 

The error ocurs when your admin session expires.

 

Try access backoffice using option "keep me logged in".

 

Worked for me! :D

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

a simple solution is first: you load the "live edit" and second you replace wwww.myshop.com manually by myshop.com

 

it works for me

 

Ornot :) :) :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More