Jump to content

[RESOLU] Impossible d'éditer une page CMS car celle ci est introuvable en BO


Recommended Posts

Bonjour,

 

Voilà mon problème :

 

J'ai créé des catégories CMS que je peux modifier sans problème en backoffice.

 

Par contre, lorsque je créé une page CMS et que je l'enregistre, je ne la retrouve plus dans mes catégories CMS et je ne peux donc pas la modifier.

 

Pourtant, elle s'affiche correctement en Front Office.

 

Ais-je fait une fausse manip? Peut être que je ne regarde pas au bon endroit?

 

Vous trouverez en pièces jointes quelques screenshot pour illustrer mes propos:

 

- Le 0001 correspond à l'étape de création de la page CMS avant enregistrement

- Le 0002 correspond au contenu de la sous catégorie auquel la page CMS devrait être rattachée

- Le 0003 correspond à l'affichage de la fameuse page CMS en Front Office

 

Infos complémentaires :

- Je suis sur Prestashop 1.6

- La catégorie CMS parente de cette page est bien activée dans le module "Menu haut horizontal"

- La page CMS recherchée à pour titre "Test 2"

- Si besoin d'autres infos, n'hésitez pas à m'en faire part

 

Auriez-vous une solution?

 

Merci d'avance

post-800870-0-47661200-1423128085_thumb.png

post-800870-0-30933300-1423128097_thumb.png

post-800870-0-46137500-1423128124_thumb.png

Edited by Helmut Van Hutten (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

j'ai commencé directement avec la 1.6

 

Si ça peut aider aussi :

- je suis sur le thème de base

- quelques modification effectuées sur le thème mais celles-ci étaient purement esthétique (que du css)

- si besoin d'autres choses, n'hésitez pas à me le faire savoir ;)

Edited by Helmut Van Hutten (see edit history)

Share this post


Link to post
Share on other sites

Merci pour votre réponse,

 

Par contre comment procéder? Y'a-t-il un bouton quelque part dans le back office?

Le fait de restaurer tous ces fichiers va-t-il supprimer toutes les modifications précédemment faites? que ce soit les modif esthétiques ou autres tels que le type ou l'ordre d'affichage des produits (grille/liste et populaires/nouveautés) par défaut, paramétrage de la navigation à facette etc.

 

Veuillez m'excuser pour toutes ces questions, mais en tant que néophyte je ne voudrais pas faire de bêtises ^^'

Edited by Helmut Van Hutten (see edit history)

Share this post


Link to post
Share on other sites

Avant toute chose, effectuez une sauvegarde de votre répertoire ftp.

 

Les modifs esthétiques sont dans le thème, donc pas concernées.

Les paramétrages (grille, liste, etc) sont en base de données, donc pas concernés

 

Les fichiers listés ci-dessus correspondent aux fichier d'origine de la solution Prestshop et ne doivent être modifiés que par une version supérieure.

il faut donc télécharger le fichier zip correspondant à votre version (https://www.prestashop.com/fr/versions-developpeurs bas de la page) et remplacer les fichiers modifiés par ceux contenus dans le zip.

  • Like 1

Share this post


Link to post
Share on other sites

Je suis en train de télécharger mon www via mon ftp

 

Je vais faire le perroquet mais je voudrais m'assurer d'avoir bien tout compris ^^'

 

Je suis en version 1.6.0.6 et je télécharge la même version sur le lien que vous m'avez donné, merci au passage ;).

Installer la 1.6.0.11 n'apportera rien, sera compliqué, entrainera des problèmes?

 

Ensuite, une fois que j'ai téléchargé la bonne version, je remplace tout les fichiers modifiés (a savoir, adminXXXX/themes/default/template/... , js/jquerry/..., etc.) sauf les fichiers /module.

Serait-il possible de commencer par remplacer que les js/jquerry/... , voir si ça résous le problème et laisser les autres fichiers tranquilles ou vu toutes les modifs, il vaut mieux mieux tout changer?

 

Dans tout les cas, si je fais une fausse manip je n'aurais qu'à remplacer, via mon ftp, mon nouveau www par celui que je suis en train de télécharger et tout redeviendra comme avant n'est ce pas?

Share this post


Link to post
Share on other sites

C'est exactement ça.

Effectivement, vous pouvez commencer par les js.

 

Pour être franc, les versions 1.6 ne sont pas vraiment stables, les nouvelles corrigent des bugs mais en apportent de nouveaux, donc patientez encore un peu avant de faire une mise à jour^^

Share this post


Link to post
Share on other sites

J'ai remplacé les js, rien de changé malheureusement.

 

Je vais continuer avec les autres fichiers mais y'a-t-il d'autres manip (vider cache smarty, cache navigateur, etc. ?) à faire pour m'assurer que le changement a bien eu lieu.

 

Autres remarque, dans le ftp j'ai téléchargé le dossier js local vers le dossier js distant en indiquant de remplacer tout les fichiers existants par les nouveaux, par contre quand je vais dans "Informations" dans les paramètres avancés du back office, ces fichiers js apparaissent toujours dans la liste. Est-ce normal?

Share this post


Link to post
Share on other sites

oui il faut vider vos caches Presta/navigateur à chaque modif.

 

Par contre, les fichiers restaurés ne devraient plus apparaitre comme étant modifiés.

Vous avez pris la bonne version ? (numéro à verifier dans /config/settings.inc.php : define('_PS_VERSION_',....)

Share this post


Link to post
Share on other sites

J'ai vidé les caches smarty/navigateur après avoir réeffectué l'opération en transférant le dossier js en entier (j'avais juste téléchargé Prestashop 1.6.0.6\prestashop\js\jquery\plugins tout à l'heure).

 

Par contre toujours impossible de retrouver mes pages CMS et les fichiers js apparaissent toujours dans la liste des fichiers modifiés.

 

Je suis bel et bien en version 1.6.0.6

define('_PS_VERSION_', '1.6.0.6');

Sur le site que vous m'avez transmis j'ai pris cette version

PrestaShop v1.6.0.6 - Publiée le 10 Avril 2014 -

 

A noter que j'ai effectué les transferts à partir de la version dézippé de ce dossier.

Share this post


Link to post
Share on other sites

Bonjour

 

J'ai remplacé tous les dossiers exceptés les /modules et vidé les caches prestashop/navigateur mais le problème persiste.

Je peux créer une page CMS, l'associer à une catégorie CMS et la voir en front office mais je ne la retrouve toujours pas dans le backoffice.

 

A noter que la liste des fichiers modifiés est toujours la même dans les informations prestashop (cf pièce jointe).

Par contre, dans cette liste est indiqué qu'il manque un fichier, en l'occurence : modules/blockstore/store.jpg

Il ne me semble pas vitale donc je n'ai pas cherché à l'ajouter mais sait-on jamais?

 

je vous ai rajouté également (cf pièce jointe "screen1") le reste des informations présents dans les paramètres avancés, celles-ci vous aideront peut être?

liste des fichiers modifiés.txt

post-800870-0-61571700-1424165227_thumb.png

Edited by Helmut Van Hutten (see edit history)

Share this post


Link to post
Share on other sites

J'ai testé sur le site qui est resté en local (c'était celui la que j'avais basculé chez OVH).

Je n'y ai pas touché depuis la liaison avec OVH (excepté le fond du site dans global.css)

 

Effectivement, le problème est présent également.

 

En pièce jointe je vous ai mis la liste des fichiers modifiés

 

liste fichiers modifies site local.txt

Share this post


Link to post
Share on other sites

Ô joie! ça marche! merci beaucoup :)

 

J'ai pu créer une page CMS, la retrouver en BO, ajouter des images etc.

Un autre problème, relatif à la vente de produits hors stocks, a même été réglé.

 

Par contre, ça a supprimé tous les éléments esthétiques et autres (j'avais ajouté un bout de code, trouvé sur ce même forum, pour avoir l'affichage des produits en grille par défaut plutôt que par liste, l'affichage des produits populaires devant les nouveaux produits en page d’accueil, etc.)

 

Quels autres éléments ont pu être réinitialisé (tous les modules, toutes les modifs dans global.css, etc)?

Edited by Helmut Van Hutten (see edit history)

Share this post


Link to post
Share on other sites

Le dossier thème n'a pas du bcp changer.

Pour les modifs, si vous savez sur quels fichiers vous les aviez faites, il suffit de remplacer les tpl correspondants depuis votre sauvegarde y compris pour les css.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More