Jump to content

Recommended Posts

Bonsoir à tous,

Je tente de démarrer sous PrestaShop. Plus conviviale que OS Commerce que j'abandonne pour créer mon nouveau site.
Un peu de mal tout de même à prendre mes marques.

Depuis le panneau d'administration, j'ai installé 2 modules (Bloc informations clients et Bloc liens permanents) dans Top of pages.
Juste en dessous je me suis créer une bannière.
Vous pouvez visualiser mes premiers pas dans l'image jointe.

Je n'arrive pas à aligner sur la même ligne les 2 modules, c'est comme si il y avait un retour chariot quelque part.

J'ai bien tenté de modifier les valeurs dans les blocs du fichier global.css, mais sans succès
J'ai modifié le fichier header.tpl pour supprimer (par une mise en commentaire) le logo standard et intégré ma bannière.

J'ai attaché les extraits des fichiers pour une compréhension du code

Si quelqu'un a un idée pour m'aider....

Merci

16854_GKbHmqeok8sSe5iya7dZ_t

extrait.txt

Share this post


Link to post
Share on other sites

Bonjour,

J'avance un peu dans mon header, voir l'image.
Mais comme vous pouvez le constater, un autre pb est la couleur de fond du header (blanc) identique à mon # page dans global layout.
Alors que je souhaite obtenir la même couleur dans mon header que ma bannière et mon background-color du body

Une piste serait d'intégrer les 2 modules "informations" et "Liens" directement sur ma bannière
J'ai utilisé le code ci-dessous pour intégrer ma bannière en lieu et place du code "header" d'origine dans global.css

#banniere {
background: transparent url('banniere.jpg') no-repeat top left;
float: left;
height:150px;
width: 1024px;


et voici mon code dans header.tpl ou j'ai mis en commentaire le logo

<!-- Header -->


<!--

{$shop_name|escape:'htmlall':'UTF-8'}

-->




{$HOOK_TOP}



 



Je pense qu'il y a une notion de suppression de Div, mais j'en ai pas la maîtrise.
Si quelqu'un peut m'aider, merci

Emmanuel

16898_Zjdj1znEnr83zqD7oD0v_t

16899_4EOUthysimlM1ERCmzNx_t

Share this post


Link to post
Share on other sites

Et voici mon code dans header.tpl ou j'ai mis en commentaire le logo

<!-- Header -->

<!--

{$shop_name|escape:'htmlall':'UTF-8'}

-->




{$HOOK_TOP}



 



Pour répondre à votre problème il y a 2 en trop + 1 div mal orthographiée "div" ?, en bref il faudrait avoir :

<!-- Header -->

<!--   -->
{$HOOK_TOP}
 



Testez bien sur les autres navigateur votre intégration ;)

Cordialement

Share this post


Link to post
Share on other sites
  • 2 months later...

Pourriez vous m'aider svp ?
Est-ce que l'un d'entre vous saurez comment aligner à droite le "top of page". Parce que depuis que j'ai viré les "block liens permanents", il me centre la barre de recherche :s

Si vous savez également sur quel fichier je peux intervenir pour ne pas que mon image sur le header est d'espace, c'est à dire, quel soit collé en haut de page, ça m'intéresse.

J'espère que vous pourrez m'aider je galère franchement... :'(

21093_ZeIPopj22tm5VjPWkxfC_t

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More