Jump to content
klni

CMS Block Links auf "selected" stellen funktioniert nicht wenn Smarty Cache Aktiv

Recommended Posts

Hallo zusammen,

 

Ich habe eine Lösung gefunden um die Links im CMS Block genauso anzuzeigen wie die Kategorielinks

 

blockcms.tpl:

{foreach from=$cms_title.cms item=cms_page}
	{if isset($cms_page.link)}
		<li> 
		{if $smarty.get.id_cms == $cms_page.id_cms}
		<a id="{$cms_page.meta_title|escape:'html':'UTF-8'}" href="{$cms_page.link|escape:'html':'UTF-8'}" title="{$cms_page.meta_title|escape:'html':'UTF-8'}" class="selected">
		{$cms_page.meta_title|escape:'html':'UTF-8'}
		</a>
	{else}
		<a id="{$cms_page.meta_title|escape:'html':'UTF-8'}" href="{$cms_page.link|escape:'html':'UTF-8'}" title="{$cms_page.meta_title|escape:'html':'UTF-8'}">
                {$cms_page.meta_title|escape:'html':'UTF-8'}
                </a>
	        {/if}
	</li>
	{/if}
{/foreach}

Das Problem an der Sache ist, dass die Variable $smarty.get.id_cms nicht mehr korrekt angezeigt wird wenn der Smarty Cache aktiviert ist. Kann mir vielleicht jemand da weiterhelfen? Raufe mir da jetzt schon etwas länger die Haare und hab keinen Bock auf Glatze. Danke im Vorraus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More