Jump to content
Sign in to follow this  
bruno matos

Erro ao atualizar prestashop "foi detectado um erro de javascript (parsejson)"

Recommended Posts

Uso a versão 1.6.0.9 e ao tentar atualizar para a versão 1.6.0.11, não conclui e aparece  a mensagem

"foi detectado um erro de javascript (parsejson) para esta ação "BackupDB". iniciando reposição..."

 

Alguém sabe como resolver?

Edited by bruno matos (see edit history)

Share this post


Link to post
Share on other sites

Provavelmente problema de permissões no seu servidor de hospedagem.

Se seu servidor vc não tiver permissões automáticas, o módulo de atualização não consegue criar/atualizar arquivos e pastas.

E provavelmente terá estes e outros erros. 

Share this post


Link to post
Share on other sites

Olá Daniel

Tenho um servidor dedicado, mas não entendo muito de configuração de servidor, vou pesquisar e ver se consigo corrigir.

 

Se alguém souber no servidor onde faço isso, agradeço

 

Desde Já agradeço Daniel

Share this post


Link to post
Share on other sites

Se estiver rodando o cPanel/WHM, basta recompilar o apache (EasyApache) com a opção suPHP/suExec ativada, em seguida configure o PHP para rodar por ele.

Se for outro painel de controle, recomendo que contate o suporte dele para consultar sobre esta opção.

 

Cabe lembrar que é importante vc ter um backup completo do seu servidor e saber o que está fazendo, caso contrário pode desconfigurar tudo. 

Share this post


Link to post
Share on other sites

Olá Daniel,

 

A configuração do servidor parece que já está ativa , o que poderia ser então

 

Current Configuration
Option Configured Value Default PHP Version (.php files) 5 PHP 5 Handler suphp     Apache suEXEC on Apache Ruid2 off

Share this post


Link to post
Share on other sites

Pode ser um problem da versao php em uso. Qual versao vc. está usando ? Eu por exemplo nao tenho suPHP ativado como o Daniel indicou, pois uso fast-cgi com opcode. Para mima a melhor configuracao em termos de speed.

Share this post


Link to post
Share on other sites

Pessoal

Vi o log de erro e o texto é "POST Content-Length of 12593258 bytes exceeds the limit of 8388608 bytes in Unknown on line 0"

 

Fiz o seguinte:

Instalei a versão 1.6.14 em outro domínio no mesmo servidor e instalou sem erros, porém, na black office/ parametros avançados/informaçõesdeconfiguração

"

Parâmetros obrigatórios OK

Parâmetros opcionais Por favor corrija o(s) seguinte(s) erro(s)

  • magicquotes"

 

Este fato tem relação com impossibilidade de atualização da loja 1.6.0.9 para a 1.6.0.14

Share this post


Link to post
Share on other sites

O módulo magicquotes no seu servidor deverá ser colocado em "off" . magicquotes nao mais sustenta versoes php 5.3.+

 

se vc. nao tem acesso ou o seu provedor nao quiser alterar o valor do módulo, vc. tem como alterar para prestashop editando o ficheiro /config/config.inc.php e adicionando lá a linha:

ini_set('magic_quotes_runtime', 0);

ficando ent ao assim:

/* Improve PHP configuration to prevent issues */
ini_set('upload_max_filesize', '16M');
ini_set('default_charset', 'utf-8');
ini_set('magic_quotes_runtime', 0);
ini_set('memory_limit','64M');
Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More