Jump to content
Sandrineve

Problème sur livraison en Italie bug sur "contient des états"

Recommended Posts

Bonjour,

 

J'ai un gros problème avec la livraison sur la zone Italie.

 

Alors que je suis arrivée à configurer plusieurs pays (Suisse, Belgique etc...), il m'est impossible de configurer la livraison vers ce pays.

j'ai l'impression que le bug vient de la demande d'un état (que je désactive pourtant sur la fiche pays, mais qui réapparait toujours lors de la commande).

 

Du coup le client soit n'a pas de frais de port, soit n'a pas de transporteur affecté à son adresse!

 

Pouvez-vous me dire comment faire pour régler ce problème?

 

Merci d'avance

 

Prestashop 1.6.0.9

theme transformer

Share this post


Link to post
Share on other sites

Il doit y avoir une erreur qq part.

 

J'ai aussi un problème avec ce pays. 

 

Je ne pense pas que le problème viens du fait que le client puisse choisir un état.

Si tu veux supprimer le choix d'un état il te faut désactiver la fonction dans ton pays mais aussi supprimer la ligne correspondante :

 

firstname lastname

company
address1
address2
postcode city
State:name    <<<ICI
Country:name
phone
 
Je penche plus pour un problem de code ISO mal définit qq part dans les méandre du php et autre code.
Pour a part j'ai fait un tour dans la base de données et je n'ai pas vu d'anomalie concernant la table ps_country.
 
Par contre je constate une anomalie avec le transporteur mondial relay.
Si je paramètre un mode de livraison pour l'Italie le code ISO utilisé est UI. Or le bon code ISO est IT.
 
J'ai tenté de modifier les différentes table concernée notamment ps_mr_method pour mondial relay et de verifier mes différentes correspondance de zones, pays et transporteur mais j'avoue que mes connaissance sont assez limitée.
 
Le résultat est qu'un client italien paye les meme frais de port qu'en France. De plus mondial relay bloque le processus de commande. Il demande un point relay alors que seule la livraison a domicile est autorisé pour l'Italie. 
Ducoup il ne trouve pas de point correspondant.
 
 

Share this post


Link to post
Share on other sites

J'ai trouvé la solution a mon problème. Peut-etre que cela pourra vous aider.

 

Si vous allez dans le BO > Localisation > Etats vous pourrez constater si les états italiens correspondent bien a la zone que vous avez choisie pour l'italie.

 

Le premier état est "Agrigento" et le dernier "Viterbo" il y en a un peu plus de 100 il me semble.

Share this post


Link to post
Share on other sites

Merci beaucoup, 4 ans après vous m'avez enlevé une épine du pied ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More