Jump to content
Sign in to follow this  
Fluorite

(Résolu)Probléme réglement Paypal SVP (finalise)

Recommended Posts

Salut à tous

Je me retrouve avec un problème lorsque j'effectue un paiement via Paypal.
Lorsque j'effectue le paiement via paypal c'est bon.
Mais je n'ai pas de retour sur la boutique, et Paypal propose alors un retour sur la boutique après le paiement via un bouton , lorsque je clique sur celui si je reviens donc sur le site, mais,mais le panier reste plein et dans le back-office statue des commandes, aucune commande n'apparaît.
Lorsque je clique sur le nom du client plus bas voir image on voie bien qu'il y'a eu une commande avec le transporteur mais rien n'apparaît dans le statue.

l'argent lui a bien étais transférais sur le compte marchand de paypal.J'ai aussi tester et paramétrer le retour automatique sur paypal et fait un second test et c'est pareil.

La boutique fonctionne avec ssl j'ai loupé un truc a configurais sur paypal? Ou sur préstashop.

La boutique devrait être en ligne la semaine prochaine après avoir bossé 1ans dessus on finalise.Je demande donc de l'aide si vous avez une solution merci.
Bonsoir
Yannick

16604_nV79rk0z1QfujhszhJyn_t

16605_oMm5cwECoA1BAd4BSBoH_t

16606_DTrJPVlRF7mWJ27EEgzj_t

Share this post


Link to post
Share on other sites

Re

Que j'active ou non le ssl c'est pareil le paiement s'effectue bien sur le compte marchand,mais rien dans le statue des commandes et le client ne recois aucun Mail et le panier reste plein.

Je signale au passage que j'ai bien suivi le Wiki pour la configuration.

J’ai testé avec l'API et voici ce que me retourne le site(laboutiques) il y'a déjà eu ce genre de problèmes, mais les posts n'ont reçu aucune réponse c'est désolant tout de même.

Merci pour l'aide

bonne soirée

   1. Making new connection to 'api-3t.sandbox.paypal.com/nvp'
  2. Connect with CURL method sucessfull
  3. Sending this params:
  4. METHOD=SetExpressCheckout&VERSION=53.0&PWD;=*********&USER;= lafouillasse_api1.gmail.com&SIGNATURE;=*********&Amt=4.01&PAYMENTACTION=Sale&ReturnUrl=https://www.lafouillasse.fr/modules/paypalapi/payment/submit.php?fromPayPal=1&CANCELURL=https://www.lafouillasse.fr/order.php&CURRENCYCODE=EUR&NOSHIPPING=1
  5. Send with CURL method sucessfull
  6. PayPal response:
  7. TIMESTAMP -> 2010-01-03T23:59:57Z
  8. CORRELATIONID -> 258b0cf6c0e38
  9. ACK -> Failure
 10. VERSION -> 53.0
 11. BUILD -> 1105502
 12. L_ERRORCODE0 -> 10002
 13. L_SHORTMESSAGE0 -> Security error
 14. L_LONGMESSAGE0 -> Security header is not valid
 15. L_SEVERITYCODE0 -> Error
 16. PayPal a retourné une erreur

Share this post


Link to post
Share on other sites

Salut

Merci de ta réponse, sebseb

mais comme dis dans mon message précédent tous est configurais sur paypal et vérifié et re-Vérifié.que ce soit avec paypal ou paypal API j'ai un problème j'espère qu'une bonne âme seras m'aider.
Bye
Yannick

Share this post


Link to post
Share on other sites

Re
Petit question qui me trotte: faut t'il avoir un compte Business pour ce servir des modules paypal et paypal API?.
merci pour les réponses.
Yannick

Share this post


Link to post
Share on other sites

Me semble bien que oui, mais sans certitude, car il faut configurer l url de retour, transport etc ....

Share this post


Link to post
Share on other sites

Non, pas besoin de compte Business pour un bon fonctionnement des modules.
Ce type de compte est requis mais pour des raisons comptables et juridiques.

Share this post


Link to post
Share on other sites

Bonsoir
UP
bon pas de solution à mon problème? j'ai d'ailleurs regardé les log IPN de Paypal et ça me retourne une erreur 403.
j'ai vue pas mal de post sur le sujet et ben ça ne mène pas a grand chose.
ça commence sérieusement a me Blasé...
bonne soirée
Yannick

Share this post


Link to post
Share on other sites

Re
Problème de .htaccess faut pas chercher à comprendre...
Merci pour vos réponses à tous.
Yannick

Share this post


Link to post
Share on other sites

@ BobyLaFleche

Bonjour,

pourriez vous détailler la solution, j'ai exactement le même problème.
Merci d'avance

Share this post


Link to post
Share on other sites

+1 à avoir ce problème....

Si quelqu'un à la solution...

Manu

Share this post


Link to post
Share on other sites

En virant tous les comptes de test chez Paypal , & sandbox=no sur presta, ca fonctionne enfin !.

Par contre j'ai pas mis de SSL, et l'ecran de paiement avec API ressemble étrangement a l'écran sans API . C'est normal ??

Share this post


Link to post
Share on other sites

roohh la la, on est beaucoup à avoir exactement le même souci !!!!!!!!!!

QUE FAIRE ?

J'ai pas mal de commandes sur mon shop et ça commence a devenir vraiment embêtant là !

Il y a a un gros souci avec le module paypal, V1.6 et prestashop 1.2.5.0

SVP pour tous les utilisateurs de prestashop qui sont dans la même m**** que nous, faites qqch et aidez nous a résoudre ce problème au combien important !!!!

Share this post


Link to post
Share on other sites

hello,
j’ai du nouveau :

1. Allez dans le BO, désinstallez le module PayPal sous le menu Modules.
2. Sur votre FTP, supprimer le dossier PayPal qui se trouve dans le dossier modules (modules/paypal)
3. Ré-uploadez le dossier paypal et donnez lui les droits 777 pour le dossier et mettez validation.php en 644.
4. retournez dans le BO et installez à nouveau le module paypal (n’oubliez pas de le reconfigurer en mettant votre adresse mail et en mettant le sandbox à non).

Il s’agissait à mon avis effectivement d’un problème de droits (merci à nicolas92 qui m’a mis sur la piste). Maintenant je ne comprends pas pourquoi les commandes ne passaient pas même si les fichiers et dossiers avaient les bons droits, car une fois le module désinstallé et réinstallé, tout fonctionne de nouveau très bien chez moi.

Ceux qui ont aussi des soucis comme moi, essayez de le faire aussi et venez me tenir au courant, je suis curieux de savoir si ca marchera aussi chez vous.

voilà salutations et bonne journée.

PS: allez consulter ce post :
http://www.prestashop.com/forums/viewthread/39862/P30/commandes_fantomes_

  • Like 1

Share this post


Link to post
Share on other sites

Oups, non je suis allé trop vite...je venais d'écrire que ça a fonctionné. Et bien non, toujours le meme problème pour moi....

Manu

Share this post


Link to post
Share on other sites

Bonjour,

toujours pas d'infos sur la solution de Boby La Flèche ? Quid de son .htaccess ?

Merci

Share this post


Link to post
Share on other sites
bon
j’ai utilisé le module beta paypal 2.0 : http://www.ecartservice.net/wp-content/uploads/2008/11/paypal_2_0_b2.zip
et bien tout marche nickel (même avec free !!)

je suis en 1.2.5, les commandes fonctionnent, le panier se vide, le stock est débité, aucun message d’erreur !!!


Salut,

D'une fois que tu as téléchargé le module, tu fais comment pour l'installer, stp?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More