Jump to content

SOLUCIONADO - Error con PayPalAPI


Davidninja
 Share

Recommended Posts

Saludos a todos,

hace como una semana que los clientes que intentan pagar mediante Paypal no consiguen hacerlo.

 

Recibo un correo con el siguiente texto:

Informe de error a partir de su módulo PayPalAPI   Un cliente ha encontrado un problema con el módulo PayPalAPI:   PayPal response:
->

 

Hasta ahora iva todo bien y no he hecho ningún cambio en la web. Funcionamiento óptimo durante más de un año seguido!

 

Uso: 

- Prestashop 1.4.2.5

- Plantilla por defecto

- Modulo PayPal v.3.4.5

- La tienda está en http no en https (supongo que el problema con POODLE no tendrá nada que ver con esto)

 

Si alguien tiene alguna sugerencia o tiene el mismo problema estaré muy agradecido si lo comentan.

 

Gracias.

 

Edited by Davidninja (see edit history)

Share this post


Link to post
Share on other sites

Buenas, a mí también me ha pasado con la version 1.5.4 pero lo he solucionado actualizando el modulo, a la derecha pone actualizar o actualización. Luego no hizo falta introducir los campos de PayPal.

Espero que te sirva a ti también.

 

Un saludo.

Share this post


Link to post
Share on other sites

Muchas gracias nmtoro por contestarme.

Cuando dices la versión con la que tenías problemas, ¿te refieres a la versión de Prestashop o la del módulo de Paypal? En mi módulo de Paypal no hay ningún botón para actualizar (o al menos no soy capaz de encontrarlo).

 

Repito, muchas gracias. Ojala consiga recuperar esta importante funcionalidad.

 

Saludos.

Share this post


Link to post
Share on other sites

Es la version de prestashop.

 

post-626553-0-22007600-1421867500_thumb.jpg

 

Esto es lo que me sale a mi, le di a actualizalo que esta a la derecha y me corregi el error, otra opcion, siempre despues de hacer las copias de seguridad tanto de la base de datos como del programa en ftp es que actualizes a una version posterior de prestashop, si no tienes instalado ningun theme especial, y de ahi actualizar el paypal, de todas formas, ¿has probado a reinstalar el modulo?.

Un saludo.

 

Edited by nmtoro (see edit history)

Share this post


Link to post
Share on other sites

Buenas tardes,

 

En las versiones 1.4 no tiene la opción de actualizar tiene que descargar el módulo desde addons:

 

http://addons.prestashop.com/es/pagos-prestashop-modulos/1748-paypal.html

 

Recuerde que debe tener instalado también el siguiente módulo:

 

http://addons.prestashop.com/es/administracion-prestashop-modulo/6222-backward-compatibility.html?search_ab=2

 

Si desea aplicar un recargo por usar la forma de pago paypal puede usar nuestro módulo que es compatible con Prestashop 1.4

 

http://www.alabazweb.com/es/modulos-para-el-pago-prestashop/173-modulo-pago-paypal-con-recargo-para-prestashop-14.html

Share this post


Link to post
Share on other sites

Buenos días a todos.

Estos días estoy con un pico de trabajo y no puedo dedicarme a la web. Tan pronto como consiga una hora libre me pongo con la solución de AMA1D.

Para salir del paso he desactivado el módulo PayPal y solo cobro mediante transferencia. Está claro que no es una solución pero al menos el cliente no recibe mensajes de error ¡que queda fatal!

 

Lo dicho, tan pronto pueda os informo del progreso y, espero, el feliz desenlace.

 

Muchas gracias a nmtoro y AMA1D por la ayuda!

 

Saludos.

Share this post


Link to post
Share on other sites

A nosotros nos sucede ese error de forma aleatoria a pesar de tener paypal actualizado y prestashop también.... Por suerte pasa muuuuy de vez en cuando, pero es mosqueante.

 

Yo sospecho que tiene que ver con el modo guest checkout de paypal. Es decir el que invita a pagar sin registrarse en la tienda...

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hola a todos, ya lo he solucionado y paso a explicar el proceso que he seguido:

 

me bajé de Addons el módulo de PayPal tal y como dijo AMA1MD. Voy a la trastienda y hago clic en <Módulos> <+Añadir un móludo a partir de mi ordenador>. Busco el archivo que me bajé de Addons y aún comprimido lo subo a la web. En este punto probé a hacer una venta y me salió un error distinto al primero (ahora me indicaba error 10472).

- De los nervios!

Hice clic en <Preferencias><Rendimiento> y forzar compilación <SÍ>, después de guardar hago otro intento de venta y ¡YA ESTÁ!

Volver a dejar Forzar compilación en <NO>.

 

De momento la tienda vuelve a funcionar.

 

Muy agradecido a todos por la ayuda.

 

¡Buena gente en este foro!

 

Saludos y gracias.

 

PD.: No entiendo como puede estropearse el módulo en el servidor. No lo toqué para nada, ¿como puede corromperse el módulo? Si alguien tiene respuesta le agradeceré la explicación. De momento, feliz del resultado.

Share this post


Link to post
Share on other sites

Buenas noches,

 

Usted recibio un correo de paypal donde se le indico que se cambiaba el protocolo de seguridad y usted debia actualizar el módulo de paypal para poder seguir recibiendo pagos por este medio. Su módulo no se corrompio, simplemente la tecnologia que usa paypal ha cambiado y debia actualizar el módulo.

 

Un saludo.

Share this post


Link to post
Share on other sites

Como ya hemos dicho algunos, incluso actualizando el modulo a su ultima versión se produce el error de forma aleatoria. De hecho el error ya se producía de forma aleatoria desde hace meses.

 

En cualquier caso al ser algo muy puntual por ahora no le hemos dado demasiada importancia en nuestro caso.

Share this post


Link to post
Share on other sites

Antakarana estas mezclando temas, una cosas es el error inicial de este post que imposibilita de compra a través de paypal a todos los clientes y otro error es el tema que comentas que sucede de forma esporadica.

Revisa los accesos a los servidores de paypal dado que te bloquean de forma esporádica por disitintos motivos. En cualquier caso es un problema distinto, se debe tratar en un nuevo post.

Share this post


Link to post
Share on other sites

Si te aparece el error de forma intermitente significa que desde tu server no se puede acceder al servidor de paypal en esas contadas ocasiones, dependiendo del apoyo que te preste tu proveedor de hosting conseguiras o no arreglar este problema.

Share this post


Link to post
Share on other sites

La verdad es que el apoyo del hosting es excelente siempre que lo he solicitado asi que la próxima vez que ocurra les pediré los logs por si hay algo que pueda averiguar y les indicare lo que comentas por si fuera algo que pudiera depender de ellos.

 

En nuestro caso es algo que sucede una vez cada dos meses por decir algo, por eso no nos hemos preocupado demasiado.

 

Gracias igualmente

Share this post


Link to post
Share on other sites

  • nadie locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More