Jump to content
Fashionresidenz

Prestashop speed, zu langsam?

Recommended Posts

Liebe Community,

mein Shop ist zu langsam, eine Durchschnittliche Ladezeit von 10sek ist einfach inakzeptabel. Dass ich dadurch sehr viele Kunden verliere ist mir bewusst, deshalb würde ich das Problem gerne so schnell wie möglich angehen.

Allerdings weiß ich nicht genau ob die langsame Geschwindigkeit auf den Server zurück zu führen ist (all inkl) oder ob es an meinem Shop liegt, dass dort Code Fehler oder ähnliches vorliegen.

Wie könnte ich heraus finden was die langsame Geschwindigkeit verursacht?

 

Es geht um folgenden Shop: www.fashionresidenz.de

Liebe Grüße
Lucas

Edited by Fashionresidenz (see edit history)

Share this post


Link to post
Share on other sites

dazu müsste man mehr über deinen Server wissen.

Sinnvoller wäre es da Allinkl. direkt zu fragen!

 

poste doch mal Deine Erweiterte einstellungen - Systemeinstellungen

Share this post


Link to post
Share on other sites

Hey Kulli,

 

bevor ich an all inkl ran trete wollte ich erstmal abklären ob es nicht auch noch an anderen Ursachen liegen könnte.

 

Also meine Systemeinstellungen ist folgende:

 

 

SERVERDATEN

 

Serverdaten Linux #109-Ubuntu SMP Tue Dec 9 16:45:49 UTC 2014 x86_64

 

Version der Server-Software Apache

 

PHP-Version 5.3.28-nmm1

 

Speichergrenze 256M

 

max_execution_time 30

 

 

DATENBANK

 

MySQL-Version 5.5.40-nmm1-log

 

MySQL-Server localhost

 

MySQL-Name d01a4dc5

 

MySQL-Anwender d01a4dc5

 

Tabellen-Präfix ps_

 

MySQL-Engine InnoDB

 

 

Es ist ein Shared Server, laut all inkl teile ich mir diesen mit noch 30 anderen.

 

Viele Grüße

Lucas

Share this post


Link to post
Share on other sites
Hallo Lucas,
 
du hast aber auch eine Menge üppig dimensionierter Fotos auf der Startseite (in der Regel über 300 kG goße JPG-Formate). Das kostet Ladezeit, ebenso wie die vielen eingebauten Javascripts. Und schau dir auch mal an, welche CCC-Einstellungen du im BO unter
 
Erweiterte Einstellungen --> Leistung

hast.  Es wäre gut, sie würden so aussehen:

 

post-452242-0-02790300-1421599237_thumb.jpg

 

Der Wert für die max_execution_time ist mit 30 zu gering angesetzt. Vorteilhaft wäre folgende PHP-Konfiguration:

 
memory_limit = 2048M
max_execution_time = 1000;
max_input_time = -1;
post_max_size = 15M;
upload_max_filesize = 15M;
max_input_vars = 10000;
suhosin.get.max_vars = 10000;
suhosin.post.max_vars = 10000;

Deine aktuelle Konfiguration kannst du abfragen, indem du eine Datei mit folgendem Inhalt im Stammverzeichnis deines Webspace anlegst:

<?php
// Zeig mir alle PHP-Informationen
phpinfo();
?>

Nenne sie z.B. php-infp.php.

 

Aufruf mit : <shop-URL>/php-infp.php

 

Falls die Werte nicht optimal sind, kannst du versuchen, selbst eine php.ini im Stammverzeichnis deines Webspace anzulegen. Sie sollte folgenden Inhalt haben:

<?php
memory_limit = 2048M
max_execution_time = 1000;
max_input_time = -1;
post_max_size = 15M;
upload_max_filesize = 15M;
max_input_vars = 10000;
suhosin.get.max_vars = 10000;
suhosin.post.max_vars = 10000;
?>

Wenn das nicht funktioniert, frag deinen Provider, ob du Änderungszugriff auf die php.ini hast, die sich vielleicht in einem anderen Verzeichnis befindet.

Share this post


Link to post
Share on other sites

Hey Eleazar,

 

die Bilder sind schon runter gescaled, wie sieht es denn mit den Javascripts aus, was könnte ich dagegen machen? Habe an denen noch garnichts gemacht sind die standart Scripts von meinem Template.

Die CCC Einstellung habe ich so geändert wie von dir empfohlen, das hat schon mal etwas gebracht die Ladezeit hat sich um eine Sekunde gebessert :)

Bezüglich der PHP Konfiguration, habe ich deinen Rat versucht allerdings hat das nicht den gewünschten Effekt gebracht, daraufhin habe ich meinen Provider kontaktiert, diese sagten mir dass die Einstellung per .htaccess verändert werden muss. Ich denke mal dass der Code dort anders geschrieben werden muss, weißt du zufällig wie ich die PHP änderung in der .htaccess schreiben muss?

Viele Grüße
Lucas

Share this post


Link to post
Share on other sites

Soweit habe ich jetzt die Veränderungen vorgenommen, die Ladezeit hat sich etwas verbessert, liegt jetzt statt 10sek. bei 8,6 sek.
Was schon mal ein Schritt in die richtige Richtung ist aber noch immer nicht akzeptabel. Denke dadurch sind eine Menge Kunden abgeschreckt :/

Share this post


Link to post
Share on other sites

Hey Eleazar,

 

Bezüglich der PHP Konfiguration, habe ich deinen Rat versucht allerdings hat das nicht den gewünschten Effekt gebracht, daraufhin habe ich meinen Provider kontaktiert, diese sagten mir dass die Einstellung per .htaccess verändert werden muss. Ich denke mal dass der Code dort anders geschrieben werden muss, weißt du zufällig wie ich die PHP änderung in der .htaccess schreiben muss?

 

Viele Grüße

Lucas

 

Das ist nicht viel anders, nur: Kein Gleichheitszeichen, kein Semikolon, dafür pro Zeile ein einleitendes php_value! Das Format für PHP-Einstelungen in der .htaccess ist wie folgt:

php_value Einstellung-Name Einstellung-Wert

Also z.B.:

php_value max_execution_time 1000

Und das Ganze sollte oberhalb der ersten Zeile der von Prestashop generierten .htaccess stehen. Sonst läufst du Gefahr, dass es bei der nächsten Generierung der .htaccess überschrieben wird.

Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

im Bereich Speed ist einiges zu beachten. 

Das fängt beim Hoster an und hört bei den Modulen auf !

 

Wie elezar es erwähnt hat du hast Bilder die sind 1,1MB Groß !  82b_men banner 2.JPG oder Boom Bap u.sw 

 

Dein Server ist auch nicht für die Performance ausgelegt.

 

 

Es gibt aber eine einfache Lösung :

 

Kauf dir das Modul und du hast kein stress mehr ...

 

https://www.xtendify.com/en/modules/prestashop/front-office-features/111-express-cache-speed-up-your-prestashop

 

 

Trotzdem solltest du deine Fotos in der Optimalen Größe abspeichern :

 

Photoshop   --->  Web Speicher unter     Jpeg   60% 

 

Viel Spass

Edited by roccomedia (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

beide Module machen genau das gleiche nur das bei Page Cache die einzelnen Timeouts  jeweils pro Page (Category, Product, Cms ) eingestellt werden können. 

Was Express Cache leider nicht kann, die Funktion benötigen wir aber für unsere Projekte nicht. Wir benutzen das Plugin schon fast 2 Jahre und muss sagen es funktioniert einwandfrei, zum support kann ich leider nichts sagen. 

 

Ich denke aber das Page Cache auch ein Sinnvoller Vorschlag für seine Problematik ist.

Edited by roccomedia (see edit history)

Share this post


Link to post
Share on other sites

Hallo,

 

machen die Module auch den Admin-Bereich schneller?

(Dei Demos auf der Homepage funktionieren nicht)

 

 

gruß

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

Hallo,

 

machen die Module auch den Admin-Bereich schneller?

(Dei Demos auf der Homepage funktionieren nicht)

 

 

gruß

 

Hallo kulli,

 

Da kann ich nur für Page Cache sprechen, da ich das Modul für Joe Martin ins Deutsche übersetzt habe und daher ganz gut kenne. Da zumindest geht es - sogar sehr differenziert.

Und das ist auch gut so, denn bei häufigen Aktualisierungen von Artikeln ist es wenig sinnvoll, Daten aus dem Cache zu lesen. Du willst schließlich bei Aktualisierung von z.B. Artikeln die jeweils letztgültige Form sofort auf dem Bildschirm haben.

Aber, wie gesagt, das kann man einstellen.

 

Gruß,

eleazar

Edited by eleazar (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Vielen vielen Dank für eure tollen Vorschläge und Ratschläge

 

Also ich habe jetzt mal Prestashop Presta Speed als Modul getestet und die Bilder drastisch verkleinert.
Damit bin ich mittlerweile von 10 sek. auf 3.9 sek. runter gekommen, was natürlich schon mal ein super Wert ist :)

Aber was könnte ich denn jetzt noch weiteres tun? Würde gerne unter die 2 sek. Marke kommen.

Liebe Grüße
Lucas

Fashionresidenz

Share this post


Link to post
Share on other sites

Eins von den angesprochenen cache-modulen, wir haben nun das modul von mitrocops gekauft

und ich kann bis jetzt nichts negatives berichten

Share this post


Link to post
Share on other sites

Eins von den angesprochenen cache-modulen, wir haben nun das modul von mitrocops gekauft

und ich kann bis jetzt nichts negatives berichten

 

frage zu diesem modul. hab im forum von "express cache" gelesen, dass man da dann das problem hat, dass das EU Cookies Modul auf jeder Seite angezeigt wird, ist das bei diesem Modul auch? kann man das dann definieren oder wie schaut das aus?

 

besten Dank lg sigls

Share this post


Link to post
Share on other sites

kann ich nicht bestätigen; welches cookie modul?

wir benutzen das von silbersaiten und nach dem schließen ist es weg und taucht auch in dieser session nicht mehr auf

Share this post


Link to post
Share on other sites

kann ich nicht bestätigen; welches cookie modul?

wir benutzen das von silbersaiten und nach dem schließen ist es weg und taucht auch in dieser session nicht mehr auf

danke. in dem fall nutze ich das eu cookies modul von vekia, aber das silbersaiten-modul kenne ich auch, verwende ich auf einer anderen seite....

 

bin technisch nicht so beschlagen (man eignet sich natürlich zwangsläufig einiges an :o), muss man an den einstellungen von dem mitrocops viel basteln?

Share this post


Link to post
Share on other sites

soweit sind wir noch nicht, das ist so ziemlich das letzte was getestet wird, bevor es online geht;

da giebt es noch zuviele andere Baustellen die erstmal laufen müssen. Wichtig ist dass es funktioniert, was man von anderen Kauf-Modulen nicht behaupten kann.

 

die Einstellungen haben wir fast gar nicht verändert; es ist zwar grottenschlecht übersetzt (bzw. nur mit g**gle oder noch schlechterem)

aber größtenteils selbsterklärend.

 

Die für Dich besten Einstellungen mußt Du eh selbst herausfinden/testen.

Und wenns Probleme gibt sofort an den Entwickler schreiben (notfalls auch mit dem g**gle Übersetzer (mit dem Hinweis: sorri vor mei bäd inglisch:-))

Share this post


Link to post
Share on other sites

@ BluTiGeS

 

Ja an einen Serverwechsel habe ich auch schon gedacht, allerdings tuen viele Anbieter sich da schwer mit einem Umzugsservice, da ich von Serverarbeiten / DBs usw. nur wenig Ahnung habe möchte ich das nicht selber machen, bevor ich mir da irgendwas zerschieße.

Den Link den tu geteilt hast, liest sich ja wirklich gut, allerdings sind die angebotenen Speichergrößen für meine Vorstellung etwas gering, klar kann man auch ne 30GB SSD Variante nehmen, allerdings steht das für mich in keiner Realation zum Preis. Das Angebot mit 5 oder 10GB ist noch okay für den Anfang vom Preis, nur glaube ich nicht mit 5 0der 10GB hinzukommen.

Gibt es da noch bessere/preislich optimiertere Varianten?

Viele Grüße
Lucas

 

Share this post


Link to post
Share on other sites

Was hast du denn für eine Größe auf dem ftp ? Also 5 oder 10 gb webshop wäre schon riesig meiner Ansicht nach. Vll brauchst du auch ein managed Server da hast du viel mehr Speicherplatz .

 

 

Grüße

Share this post


Link to post
Share on other sites

Also zur Zeit belegen wir auf unserem FTP knapp 3gb und das ist erst ein Bruchteil von dem was wir vor haben. Hast du erfahrungen mit den managed Servern bei den von dir genannten Anbieter?

Grüße
Lucas

Share this post


Link to post
Share on other sites

dazu müsste man mehr über deinen Server wissen.

Sinnvoller wäre es da Allinkl. direkt zu fragen!

 

poste doch mal Deine Erweiterte einstellungen - Systemeinstellungen

Hallo,

ich habe genau das gleiche Problem, aber bei mir ist alles noch viel langsamer. Ich habe unheimlich viele Kaufabbrüche und ich nehme an das es deswegen ist. Konntest du schon etwas positives aendern? Ich habe auch einen sehr langsamen Server, habe ihn testen lassen. Ich bin am Ueberlegen ob ich zu 1und1 ziehe auf einen virtuellen server XL. Dort gibt es genug Speicher und der Preis pro Monat scheint akzeptabel.

Ich suche nur Leute die Prestashop auf diesem Server haben um ihre Erfahrungen zu hören.

Share this post


Link to post
Share on other sites

Also ich konnte kurzzeitig eine Verbesserung verbuchen. Allerdings seit gestern ist es nun ganz katastrophal, die Ladezeit hat sich von 4 - 5 Sekunden auf nun fast 22! Sekunden verlängert, von den einen auf den anderen Tag, habe schon mit meinem Betreiber gesprochen, diese konnten keine Serverbeeinträchtigung feststellen.

Wie kann das sein dass sich die Seite von den einen auf den anderen Tag derartig verschlechtert?

Gemessen wurde wieder mit pagespeed.de

Lieb Grüße
Lucas

Share this post


Link to post
Share on other sites

Hallo,

 

ich will auch den Server wechseln und ich habe da ein bezahlbares Angebot bei 1und1 gesehen mit ausreichend Speicher und Geschwindigkeit und die Leute die dort mit Prestashop arbeiten haben gesagt das sie bis jetzt keine Probleme hatten. Ich habe auch den Speed meines Shops gemessen mit: http://www.webpagetest.org/

Schau mal hier ob was passendes dabei ist fuer dich:  http://hosting.1und1.de/vserver-tarife?linkId=hd.subnav.vserver#server

 

Ich bin auch kein Experte bei Server und muss mir jemanden suchen der mir beim Serverumzug helfen kann. Vielleicht gibt es ja hier im Forum jemanden der helfen kann.

 

;)

 

 

 

 

Share this post


Link to post
Share on other sites

Also die Server gehen eigentlich alle, es liegt meistens nicht an den Vorraussetzungen (obwohl man da bei Presta schon lieber etwas höher ansetzt), sondern wieviel Leute noch am Rechenzentrum hängen, bzw daran nuckeln.

wir haben da leidvolle Erfahrungen mit einem Großen gemacht HostEurope

egal welches Upgrade wir gemacht haben: am Schluss auch vserver - zu den Hauptzeiten wars ne katastrophe

 

jetzt sind wir bei einem "Kleinen" mit einer garantierten maximalen Anzahl Kunden je server

einem echten 1GB uplink

echtes Hosting (kein Reseller)

 

da hatten wir bis jetzt noch keinerlei Einbrüche oder ähnliches.

 

zu 1+1 kann ich nur sagen, dass deren Support nicht der beste sein soll...

 

 

und zu Presta: das ist in der Grundausstattung opensource und deswegen so langsam:-)

ihr müsst euch eins von den cache-modulen kaufen.

 

unsere Testseite unten läuft mit dem modul  Website Cache für Prestashop von mitrocops

 

gruß

  • Like 1

Share this post


Link to post
Share on other sites

Also ich konnte kurzzeitig eine Verbesserung verbuchen. Allerdings seit gestern ist es nun ganz katastrophal, die Ladezeit hat sich von 4 - 5 Sekunden auf nun fast 22! Sekunden verlängert, von den einen auf den anderen Tag, habe schon mit meinem Betreiber gesprochen, diese konnten keine Serverbeeinträchtigung feststellen.

 

Wie kann das sein dass sich die Seite von den einen auf den anderen Tag derartig verschlechtert?

 

Gemessen wurde wieder mit pagespeed.de

 

Lieb Grüße

Lucas

 

Hab's mir gerade auch noch mal angesehen - ja, die Ladenzeit war mit etwas über 21 sec wirklich unterirdisch, aber die Bilder kommen dabei gut weg. Die sind also nicht das Problem. (Falls du Prestashop 1.6.0.11 einsetzt, solltest du unbedingt das Modul crontask deaktiviert, weil das sogar selbst die Cloud-Version ausbremst.)

 

Aber das allein würde es auch nicht bringen. Ich habe da mal bei Pagespeed einen von mir betreuten 1.5er-Shop mit ca. 9.000 Artikel und einer Unzahl Bildern gegengesetzt - der kam auf Ladezeiten von 0,985 sec.

 

Deine Bilder sind jetzt super verschlankt, dein Template schlägt allerdings mit satten 0,743 Megabyte(!) [unkomprimiert] in zwei ellenlangen Javaskripts und fast einem halbe Megabyte CSS-Styles alle Rekorde. Zum Vergleich: Das 1.6er-Bootstrap-Template von Prestashop hat insgesamt nur halb soviel CSS auf und ein Drittel deines Java-Codes.

Ich glaube fast, dein Template bremst dich am meisten aus, u.a. auch der Slider von Themepunch Tools, der zumindest in meinem Firefox sowieso nicht korrekt funktioniert. Oder gibt es da nur ein Bild? Dann wäre viel Javaskript-Code überflüssig an dieser Stelle.

 

Warum der Seitenquelltext anstelle der Font-Family jeweils Hunderte von Backslashes anzeigt, weiß ich auch nicht. Werden da irgendwelche spezielle Fonts aus dem Internet geladen?

 

Ich habe jedenfalls den Verdacht, dass es vielleicht gar nicht am Server liegt ...

 

Grüße

eleazar

Share this post


Link to post
Share on other sites

Hey Eleazar,

 

ersteinmal vielen Dank für deine Mühe und die ausführliche Antwort :)

 

Wie du schon selbst gesagt hast, die Bilder habe ich jetzt schon versucht soweit es sie zu komprieren, klein zu halten, noch viel weniger geht da fast garnicht. Eher werden es in Zukunft noch mehr ^^.

Also der Slider hat nur ein Bild, ich verwende Ihn halt nur weil er die Möglichkeit bietet, zwei verschiedene Blöcke rein zu "faden". Wenn es eine schlankere Variante als den Revolution Slider gibt, gucke ich mir das gerne an, dieser war halt nur vorinstalliert bei meinem Template dabei.

 

Was genau könnte man machen um dieses Template zu beschleunigen? Ich denke nicht dass der Programmierer sich für mich da die Mühe macht es kleiner zu machen :D. Dass dort viel CSS zum Einsatz kommt ist mir auch schon aufgefallen, ich höre auch immer öfters, dass man CSS in weniger Datein zusammen fügen sollte, nur leider kann ich mir nur schwer etwas darunter vorstellen.

 

Warum dass mit den Backslashes so ist, weiß ich auch nicht genau, die werden schon im BO beim Template Editor unter den Font Varianten angezeigt, ich könnte ja dort schon mal versuchen diese zu entfernen, vielleicht ist es dann schon mal etwas geordneter.

Na gut, wenn du sagst dass es nicht am Server liegt, muss es ja am Shop an sich liegen, allerdings fahren wir mit dem Template designtechnisch recht gut, weshalb für mich eine Optimierung eine bevorzugte Variante wäre, anstatt es zu tauschen.

Grüße
Lucas

Edited by Fashionresidenz (see edit history)

Share this post


Link to post
Share on other sites

Ok, man kann jetzt die eingebunden Google-Fonts Volkhov und Open Sans sehen, da sind aber immer noch ein paar überflüssige Backslashes.

Das sieht aber nach Fehlern im CSS-Code aus. Da die Fonts per Link eingebunden werden, sollte dort die absolute URL stehen, also z.B.

</style><link href='http://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700&subset=latin,latin-ext' rel='stylesheet' type='text/css'><style>body {					font-family: 'Open Sans', sans-serif
Stattdessen steht da aber mal ein verküppelter Link:
</style><link href='//fonts.googleapis.com/css?family=Open+Sans:400,300,600,700&subset=latin,latin-ext' rel='stylesheet' type='text/css'><style>body {					font-family: 'Open Sans', sans-serif
oder auch nur:
font-family: Volkhov\\\', serif
Da ist Nacharbeit angesagt.

 

Der einzige Browser, der mit eurem Template umgehen kann, ist übrigens der Internet Explorer. Offenkundig ist es nur für den IE optimiert, weil der recht schnell lädt. Ganz schlimm ist die Darstellung im Chrome. Da sieht man fast eine halbe Minute nur eine weiße Seite, und möchte schon abschalten - und ich habe einen sehr schnellen VDSL-Zugang!

 

Firefox baut zwar sehr träge die Seite auf - vor allem beim Slider kann man geradezu zusehen -, aber es ist jedenfalls nach ein paar Sekunden überhaupt was zu sehen.

 

Das heißt: Nur der Browser, den kaum noch jemand nutzt (IE), zeigt den Shop relativ zügig an. Und der wird ja bekanntlich von Microsoft nicht mehr weiter entwickelt. Das sollte dir zu denken geben!

Im Übrigen entspricht der Checkout deines Templates sowieso nicht den rechtlichen Anforderungen. Hast du denn die Diskussion dazu hier im Forum gar nicht verfolgt?

Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

 

Firefox baut zwar sehr träge die Seite auf - vor allem beim Slider kann man geradezu zusehen -, aber es ist jedenfalls nach ein paar Sekunden überhaupt was zu sehen.

 

Das heißt: Nur der Browser, den kaum noch jemand nutzt (IE), zeigt den Shop relativ zügig an. Das sollte dir zu denken geben!

kann ich nicht bestätigen:

habe gerade eben (Uhrzeit: 6:05) mit dem fierfox (ESR 31.4.0) neu angesehen, schön schnell,

ledichlich der Slider brauch ein bisserl

gefühlt (nicht gemessen) kann ich keinen unterschied zu IE 64 (11.0) und chrome (64 bit 39.0) feststellen

Share this post


Link to post
Share on other sites

kann ich nicht bestätigen:

habe gerade eben (Uhrzeit: 6:05) mit dem fierfox (ESR 31.4.0) neu angesehen, schön schnell,

ledichlich der Slider brauch ein bisserl

gefühlt (nicht gemessen) kann ich keinen unterschied zu IE 64 (11.0) und chrome (64 bit 39.0) feststellen

"Ein bisschen"? Ja, Gefühle können eben täuschen! ich hoffe, dir ist auch die Fehlermeldung im Chrome nicht entgangen, bevor geladen wird.

Außerdem solltest du vielleicht nicht mit dem Testshop im Footer deiner Posts vergleichen. Dessen Ladezeiten sind mit über 4 sec auch nicht gerade berauschend. ;)

Share this post


Link to post
Share on other sites

ich hatte keine Fehlermeldung in chrome

und mehr als 2 sekunden konnte ich weder in mit einem "nackten" chrome noch ie64 bei unserem testshop feststellen.

 

sicher kommt es auch noch auf die Internetverbindung an....(Bandreite ist nicht gleich Schnelligkeit)

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

UUUUnd:

 

was auch viel ausmachen kann: Antivierusprogs auf dem Rechner, hier gibt es ja den einen oder anderen schlimmen Kandidaten....

 

und und und und........

Share this post


Link to post
Share on other sites

Ich meinte eigentlich nicht den heimischen PC und die Stoppuhr, sondern Testmaschinen wie pagespeed.de oder webpagetest.org. :)

Share this post


Link to post
Share on other sites

naja 2,6 sekunden mit einer dieser komischen "Testseiten",  da lag ich mit meiner Schätzung gar nicht schlecht....

 

edit: lustig, da hat schonmal jemand die seite mit pagespeed getestet...

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

@eleazar

 

also die Fehlermeldung die du ansprichst, kann ich in keiner Weise nachvollziehen, haben die Seite getestet, sowohl mit IE, also auch mit Firefox, Chrome und Safari und in keinem haben wir ein Darstellungsproblem oder irgendwelche Fehlermeldungen.

 

Das mit Google Fonts hat sich erledigt, die haben wir jetzt komplett raus geschmissen.

 

Was aber meine eigentliche Frage ist, wenn du sagst das liegt alles am Template, wie kann es denn sein dass es den einen Tag noch mit 4 Sekunden lädt und keine 24 Stunden später ohne eine Veränderung mit 21 Sekunden?

 

 

 

Es geht ja hier jetzt nicht um einen Template wechsel oder ob etwas den rechtlichen Vorgaben entspricht sondern einzig allein um die Geschwindigkeit. Ich denke nicht dass die Geschwindigkeit darunter leidet wenn etwas nicht den rechtlichen Vorgaben entspricht ;)

Außerdem gibt es soweit ich weis keine genaue Regelung bei OPC Checkouts (was wir jetzt testen) was die erneute Auflistung des Warekorbs bedeutet.

Share this post


Link to post
Share on other sites

Die Fehlermeldung lautet: "Unresponsive" - es kann sich aber um einen Chrome-Bug handeln, da sie immer nur beim ersten Aufruf ohne Cache-Daten erscheint. Da dauert es aber auch sehr lange, bis die blank Page verschwindet. Das geht selbst beim Firefox deutlich schneller.

 

 

Das mit Google Fonts hat sich erledigt, die haben wir jetzt komplett raus geschmissen.

 

:D Ja "rausgeschmissen" ist wahrscheinlich der passende Ausdruck! Die Fontswahl wird also jetzt gänzlich dem Browser überlassen. Interessanter Ansatz! Aber Spaß beiseite, vielleicht wäre es da doch besser, so etwas Fachleuten zu überlassen. Gerade bei Responsive Themes kann man nicht einfach nach Gusto hier und da was rauslöschen.

</style><link href='//' rel='stylesheet' type='text/css'><style>
body {
	font-family:  !important;
	font-size: 13px;
	color: #898989;
}

Und worauf verlinkt '//'? ;)

 

 

Was aber meine eigentliche Frage ist, wenn du sagst das liegt alles am Template, wie kann es denn sein dass es den einen Tag noch mit 4 Sekunden lädt und keine 24 Stunden später ohne eine Veränderung mit 21 Sekunden?

 

Die 21 sek finden sich nur bei Pagespeed, hat wohl etwas mit der Messmethode zu tun. Die Werte bei anderen Testmaschinen sind zwar auch grottig, aber fallen aufgrund der Prüfalgorithmen längst nicht so hoch aus. Aber auch 4 sek sind nicht gerade der Brüller.

Die Geschwindigkeit scheint aber wohl tatsächlich "tagesformabhängig" zu sein.

Über welchen Hoster / welchen Leistungsumfang reden wir denn überhaupt?

 

 

Außerdem gibt es soweit ich weis keine genaue Regelung bei OPC Checkouts

 

Irrtum! Erstens gibt es da keine Sonderregelung, und zweitens  verhalten sich beim OPC eure Zahlungsmodule auch nicht rechtskonformer. Das hat doch Chris Gurk klar und deutlich erklärt.

 

 

Es geht ja hier jetzt nicht um einen Template wechsel oder ob etwas den rechtlichen Vorgaben entspricht sondern einzig allein um die Geschwindigkeit.

 

Bei Abmahnungen, für die eure Seite geradezu prädestiniert ist, spielt die Geschwindigkeit nach meiner Erfahrung keine Rolle. ;)

Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More