Jump to content

Module 1 click upgrade: impossible de l'installer


Recommended Posts

Bonjour à tous

Cela fait plusieurs mois maintenant que je rencontre un gros problème avec le module 1 click upgrade. En effet, celui ci n'est plus disponible sur le BO, et j'ai beau essayer de le réinstaller, rien n'y fait. J'ai essayé de plusieurs façons, soit directement depuis le BO, soit en le téléchargeant depuis le site de Prestashop et en l'important, ou en le transférant par FTP.

J'ai toujours le même message d'erreur qui s'affiche, à savoir:

 

""" Le ou les modules suivants n'ont pas été correctement installés :

  • autoupgrade :
        Impossible de créer le menu "AdminSelfUpgrade" """

post-905053-0-13580100-1421421815_thumb.png

 

Pourtant, lorsque je regarde dans le dossier autoupgrade, j'ai bien le fichier AdminSelfUpgrade.php présent sur le serveur, et je rencontre toujours le problème en passant les droits d'accès au maximum (777).

Aujourd'hui, je cherche une solution à ce problème plutôt handicapant.

Merci à ceux qui pourront m'aider.

Share this post


Link to post
Share on other sites

Bonjour,

Sous quelle version êtes-vous ? Pourquoi ne pas tout sauvegardée et tenter une MAJ manuelle si l'automatique ne fonctionne pas ?

Bonne continuation,
Cordialement.

Share this post


Link to post
Share on other sites

Apparemment, dans la partie Anglaise, ils ont trouvé la solution : https://www.prestashop.com/forums/topic/393533-1-click-upgrade-module-installation-problem/
Il semble que ce soit au niveau de la table ps_tab, de votre Base de données, mais j'en sais pas plus. Je leur ai laissé un message, demandant de détaillé la solution.

Sinon, pour la MAJ manuelle, il suffit de vous reporter au manuel officiel de Prestashop : http://doc.prestashop.com/pages/viewpage.action?pageId=23069397

Bonne continuation.

Share this post


Link to post
Share on other sites

Bonsoir FMR

Je suis allé sur le site anglais, et j'ai pu orienter mes recherches pour résoudre le problème en grande partie.

Le problème venait de l'absence d'une colonne dans la table ps_tab (il manquait la colonne hide_host_mode. Il a fallu que j'entre la commande suivante au niveau de la base de données: 

ALTER TABLE `ps_tab` ADD `hide_host_mode` tinyint(1) NOT NULL DEFAULT '0' AFTER `active`;

Le problème d'installation du module a ainsi été réglé.

Par contre, j'ai rencontré un autre problème par la suite, l'accès au module 1 click upgrade m'est interdit avec le profil webmaster, qui a pourtant tous les droits. Après un essai avec le profil Super administrateur, j'ai eu accès au module.

Tentative de mise à jour demain. 

En tout cas, merci de m'avoir orienté vers le post anglais, cela m'a fait gagner un temps précieux.

Bonne soirée

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More