Jump to content

Problema download prodotto virtuale (file PDF)


Clizia63
 Share

Recommended Posts

Ho installato Prestashop v. 1.6.0.9 ed ho caricato nel mio negozio alcuni e-book. Ad ogni prodotto ho associato un file PDF, caricandolo dalla pagina di amministrazione. Ho simulato un acquisto, tutto funziona perfettamente ed il cliente riceve la e-mail con il link per scaricare l'e-book, ma quando clicca sul link non appare il PDF ma una pagina con solo codice ASCII.

Faccio presente che il file dell'e-book, caricato nella cartella download di Prestashop,  è  funzionante e visualizzabile se scaricato dalla pagina di amministrazione del negozio.

Qualcuno ha qualche idea in proposito?

Share this post


Link to post
Share on other sites

Rispondo a Luigi:

Le prove sono state fatte verificando su browser differenti. A quale plugin fai riferimento?
I files sono stati prodotti con Adobe Acrobat  professional  ver 9.

 

Rispondo a tuk66:

 

esattamente.

Lo stesso problema si è posto provando a caricare immagini. Viene scaricata l'immagine in ASCII. In ogni caso non appare la richiesta di  downloadare il file ma si apre automaticamente una pagina nuova 

Nel caso specifico appare, all'inizio della pagina:

 

%PDF-1.6
%âãÏÓ
1658 0 obj
<</Linearized 1/L 5896903/O 1660/E 146666/N 380/T 5894822/H [ 495 1825]>>
endobj
      
1670 0 obj etc ....

 

Aggiungo che il sito in questione ha come server ARUBA.

Edited by Clizia63 (see edit history)

Share this post


Link to post
Share on other sites

Sembra che il vostro PDF caricato è danneggiato. Provare a scaricare un file dalla directory /download via FTP, aggiungere l'estensione .pdf e aperto nel computer.

 

It looks like your uploaded PDF is corrupted. Try to download one file from the /download directory via FTP, add .pdf extension and open in your computer.

Share this post


Link to post
Share on other sites

Operazione avvenuta, tuk66, ed il file si apre senza alcun problema.
Ieri ho provato a modificare ripetutamente il files sperimentando anche l'uso di files prodotti da altri, proprio per garantirmi da eventuali errori "personali".
Ho provato con files di diverse dimensioni (ipotizzando un problema di  limite massimo)  ed alla fine ho anche provato a far scaricare immagini.
L'esito è sempre lo stesso.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More