Jump to content

Recommended Posts

Bonjour à toutes et tous et merci de vous intéresser à mon problème.


Ma cliente a la version 1.5.4 de prestashop avec le template mylook.


Le problème est le suivant : L'affichage des produits personnalisés était erroné, j'ai récupéré un bou du code de la version par défaut pour corriger les bugs le cas "if isset($customizedDatas.$productId.$productAttributeId)" et cela remarche lors du chargement du panier.


Maintenant le problème vient du changement de quantité ou de la suppression d'une des personnalisations :

    •    Sur la ligne du produit, la quantité se recalcule bien mais le total se met à 0,00€

    •    Si on créer une deuxième personnalisation, le champ input des quantités du deuxième se vide

    •    Alors que la quantité sur la ligne de produits n'enlève pas les quantités de cette dernière personnalisation, et que le total global du panier de calcule normalement


Mes diagnostics :

    •    En passant sur le thème par défaut, tout fonctionne bien

    •    En remplaçant le code entier des pages shopping-cart.tpl et shopping-cart-product-line.tpl du thème mylook par le thème par défaut, le problème persiste

    •    Après que l'utilisateur ait effectué des modifications sur le panier et malgré l'affichage défectueux, les données sont correctement envoyées à la commande

    •    Après analyse du script Json renvoyé en Ajax lors de la modification d'une quantité, le nouveau montant par rapport à la quantité du produit personnalisé se calcule correctement


Il doit surement y avoir un conflit que je ne détecte pas pourtant aucun module n'est installé, si vous pouvez m'éclairer se serait juste génial ! :)

Lien boutique : http://www.lespetitesdecoupes-shop.fr/home/189-decoration-gateau-motif-1-dore.html
Lien produit personnalisable : http://www.lespetitesdecoupes-shop.fr/home/1[spam-filter]collier-mot.html
Template : http://themes.prestashop.com/mylook/fr/

 

Edited by g7design (see edit history)

Share this post


Link to post
Share on other sites

Problème souvent rencontré sur les thèmes externes en 1.5.

Veuillez comparez vos fichiers theme/js/cart-summary.js et theme/js/modules/blockcart/ajax-cart.js avec les originaux.

Share this post


Link to post
Share on other sites

Merci énormément ! ça marche nickel !!

 

J'ai donc récupéré les fichiers par défaut et remplacé ceux du thème et ça a marché aussitôt !


Donc encore un grand merci Eolia ! Topic résolu

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More