Jump to content

Recommended Posts

Bonjour à tous.

 

Mise à jour 1.6.0.9 faite depuis le 08/12/14. 3 commandes depuis cette mise à jour. RAS sur la première. En revanche, les deux suivantes posent problème : il n’y a pas le détail de la commande. À noter également qu’aucun email de notification de commande n’est envoyé.

 
Je me suis connecté à un compte client factice pour essayer. Je choisis le paiement par chèque et au moment de cliquer sur « Je confirme ma commande » (capture ci-dessous), le site rame jusqu’à afficher une page blanche.
 
Je suis donc allé voir le back-office et la commande est bien enregistrée… sans détail. Et pas d’email de notification de la commande au client ni à l’administrateur (le module de notification est bien activé). Je suppose (sans vouloir te mettre sur une mauvaise piste) que le problème arrive au moment de cette étape de confirmation.
 
J'ai donc mis PHP à jour en 5.5
 
J'ai refait un test et bingo ça marche… pas pour longtemps.
 
Vrai commande suivante, paiement par CB. Pas de détail de commande.
 
J'ai refait des commandes fictives pour voir (par chèque cette fois-ci) et j'ai exactement les mêmes symptômes.
 
Détail « amusant » : en allant voir les logs, je n'ai plus de log depuis le jour de la mise-à-jour de PHP.
 
Je ne sais plus quoi faire et c'est très handicapant.
 
Merci d'avance pour votre aide.
Edited by Neoziox (see edit history)

Share this post


Link to post
Share on other sites

Merci pour ta réponse loulou66.

 

Voilà l'erreur affichée :

Fatal error: Maximum execution time of 80 seconds exceeded in /home/www/classes/cache/CacheMemcache.php on line 156

Share this post


Link to post
Share on other sites

coucou

 

tu a donc sur ton hebergement un system de cache Cachemem

 

sinon dans les préférences avancés =>performances dans la section "cache" tout en bas mettre NON a "utiliser le cache"

 

si oui a la ligne 156 

protected function _writeKeys()
{
	if (!$this->is_connected)
		return false;
	$this->memcache->set(_COOKIE_IV_, $this->keys);
}

ils sagit surrement d'un probleme de droit en ecriture voir avec ton hebegeur

 

@++

Loulou66

  • Like 1

Share this post


Link to post
Share on other sites

Merci Loulou66. Non seulement ça a l'air d'avoir résolu le problème (désactivation du cache Memcached dans les préférences), mais en plus ça a rendu le site beaucoup plus réactif. J'avais cru comprendre qu'il était recommandé d'activer le cache, mais là c'est clairement pas la bonne option.

Share this post


Link to post
Share on other sites

coucou

 

oui quand on parle d'activer le cache smarty c'est l’option en haut de la page avec "ne pas forcer la recompilation" et "cache"

les option qui sont en bas dépendent de ton hébergement et ralentissent la boutique si les plugin ne sont pas installés

 

@++

 

Loulou66

Share this post


Link to post
Share on other sites

Bonjour ici :)

 

l'option Memcached  ou Blowfish (en bas de la page Performances) est à bannir en mutu et à utiliser en dedié si le serveur est bien paramétré, mais APC cache est beaucoup plus performant dans ces cas là.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More