en Jump to content
  • 0
animuz1

google sitemap problems 1969-12-31T19:00:00-05:00

Question

Hey guys,

 

I found some posts about this issue on the forums, but unfortunatly those fixes were for prestashop 1.4.x i think.

 

My problem is that google returns 900 errors out of the 1100 sitemap links. The error google shows is invalid date.

 

I followed vekia's instuctions here: http://www.prestashop.com/forums/topic/283362-new-sitemap-module-bad-data-format/?do=findComment&comment=1426194

But the problem still exists.

 

When I take a look at my generated sitemap, almost all products show this:

<priority>
0.9</priority><lastmod>1969-12-31T19:00:00-05:00</lastmod><changefreq>daily</changefreq>

 

I am running 1.6.0.9 with latest googlesitemap module.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Please check product and product_shop tables and change columns date_add and date_upd and make sure all values that equal 0000-00-00 00:00:00 and replace it with something like 2014-12-21 20:29:47 or any other random date.  It solved my issues. I hope this helps.

 

 

 

William Williamson

www.shopsavenearn.com

Share this post


Link to post
Share on other sites
  • 0

if your sitemap generation process does not work, please try this:

 

1-close cache at performance page

2-than try the sitemap generator again.

 

When I experience sitemap problem I have solved by using this method

Share this post


Link to post
Share on other sites

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More