Jump to content
steff86

Kategorie na stronie głównej

Recommended Posts

Kwestia styli dla elementu li musisz dodać float:left i jakiś margin najlepiej.

Share this post


Link to post
Share on other sites

tylko że ja nie ogarniam takich rzeczy jak możesz to opisz dokładnie co i gdzie dodać

Share this post


Link to post
Share on other sites

Tutaj akurat żadna filozofia w homecategory.tpl dopisujesz dla elemantu li kalsę np. glowna, później w css definiujesz coś w stylu:

.glowna {float:left; margin: 0 5px;}

 

albo jeszcze lepiej możesz to oprzeć na bootstrapie.

Edited by endriu107 (see edit history)

Share this post


Link to post
Share on other sites

rozumiem ze to to:

<!-- MODULE Home categories -->
<div class="home_categories">
    <h2>{l s='Categories' mod='homecategories'}</h2>
    {if isset($categories) AND $categories}
            <ul>
            {foreach from=$categories item=category name=homeCategories}
                {assign var='categoryLink' value=$link->getcategoryLink($category.id_category, $category.link_rewrite)}
                <li class="ajax_block_category {if $smarty.foreach.homeCategories.first}first_item{elseif $smarty.foreach.homeCategories.last}last_item{else}item{/if}">
                <div><a href="{$categoryLink}" title="{$category.legend}" class="category_image"><img src="{$img_cat_dir}{$category.id_category}-medium_default.jpg" alt="{$category.name}" title="{$category.name}" class="categoryImage" width="{$categorySize.width}" height="{$categorySize.height}" /></a></div>
                <a href="{$categoryLink}" title="{$category.legend}">{$category.name|truncate:35}</a>
               
                </li> 
            {/foreach}
            </ul>
    {else}
        <p>{l s='No categories' mod='homecategories'}</p>
  {/if}
    <div class="cr"></div>
</div>
<!-- /MODULE Home categories -->
 
i gdzie to ma byc bo probowalem i nic sie nie zmienia.

Share this post


Link to post
Share on other sites

A który dokładnie moduł zainstalowałeś? Plik który wkleiłeś a to co widze na twoim sklepie sie nie bardzo zgadza. Masz włączona kompilacje?

Share this post


Link to post
Share on other sites

Tak dla próby odinstaluj ten moduł i zainstaluj ten z pierwszej strony do 1.5  bo ja w pierwszej kolejności u siebie ten zainstalowałem i lepiej mi sie wyświetla niż ten do 1.6

Share this post


Link to post
Share on other sites

ok jest teraz siatka ale tam zdjecia były wieksze zaraz sobie przetestuje


Dzieki za pomoc i poświęcony czas

Share this post


Link to post
Share on other sites

To co masz w homecategories.css zastąp tym:

 

div.home_categories{margin-bottom: 5px}
div.home_categories .cr{clear: both;border: 0px none}div.home_categories ul{text-align:center;list-style:none}
div.home_categories img{width: 150px;height: 150px;}
div.home_categories li{float:left;margin:5px;width: 150px;height: 180px;}
div.home_categories h5 a:hover{text-decoration:underline;color:#444}
div.home_categories div{width: 152px;border:1px outset black}
div.home_categories div:hover{border:1px inset black}

Share this post


Link to post
Share on other sites

jak wgrałem wersje 1.5 nie wyświetla mi zdjęć co może być źle?

Share this post


Link to post
Share on other sites

Nie masz i tyle :D

 

Presta 1.6 w standardzie ma zdjęcia typu large-default a u ciebie jest odwołanie do large.

Share this post


Link to post
Share on other sites

Po pierwsze nie mówiłem żebyś cokolwiek zmieniał,a po drugie co zmieniłeś? Chłopie nikt tu nie jest po to żeby Ciebie ciągnąć za język to ty masz problem więc pisz wszystko dokładnie co zrobiłeś.

Share this post


Link to post
Share on other sites

large-default zmieniłem kategorie,dostawcy,producenci, sceny i sklep na aktywne 

Share this post


Link to post
Share on other sites

Z tym że nic nie rozumiesz co do Ciebie piszę, jeśli Ci szkoda czasu to po prostu zleć to komuś, albo przeczytaj wątek od początku i zastanów się co miałem na myśli ;)

Share this post


Link to post
Share on other sites

Zmieniłem wersje jak Pan mówił, i mówiłem że się na tym nie znam i Pan piszę że jest odwołanie i sprawdzam i jest to wyłączone więc włączyłem, więc proszę napisać tak żebym zrozumiał co trzeba zrobić a nie co jest wył lub włą

Share this post


Link to post
Share on other sites

Takie zasadnicze pytanie na temat budowy szablonów na prestashop, skąd sklep ma wiedzieć że ma wyświetlić akurat takie a nie inne zdjęcie? 

 

Sklep rozpoznaje pliki po deklaracji w szablonie jeśli w twoim pliku szablonu jest deklaracja large-default to presta szuka zdjęcia large-default jeśli deklaracja jest large to presta szuka zdjęcia large i tutaj powinno być wszystko jasne, ale gdyby nie było to pociągnę temat dalej.

 

Wchodząc w zaplecze > preferencje > zdjęcia, wyświetlają się zdjęcia z głównymi nazwami small-default, home-default, large-default itd. cały czas pamiętamy że presta szuka zdjęcia large przelatuje po nazwach i co? Nie ma, jest large-default ale large nie ma, czyli zdjęcie się nie wyświetla.

 

Ubiegając następną głupotę którą możesz popełnić od razu nadmienię że zmiana nazwy z large-default na large to nie jest najlepszy pomysł. Więc aby osiągnąć zamierzony efekt najzwyczajniej należy dodać opcje large na wzór large-default rozmiary 150 na 150 i wygenerować obrazki.

 

Czyli tak jak już wspomniałem:

Presta 1.6 w standardzie ma zdjęcia typu large-default a u ciebie jest odwołanie do large.

Share this post


Link to post
Share on other sites

Zrozumiały jest problem, ale wykonanie już nie ale skopiowałem plik z wersji 1.6 do 1.5 i działa dzięki na wyjaśnienie w czym tkwił problem.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More