Jump to content
rexlechien

Remise en ligne site internet

Recommended Posts

Bonjour,

 

J'ai connu un gros bug avec ma boutique ce jeudi 27/11/2014 vers 17h00.

 

Depuis c'est le big bazar avec les restaurations de mon hébergeur.

 

En effet, la mise à jour vers la toute dernière version de Prestashop a été effectuée en date du 18/11/2014.

 

Lorsque que je restaure un bkup du 22/11/2014 de chez mon hébergeur, je me retrouve avec l'ancienne version en 1.4.9.0, comment est-ce possible ?

 

Je dispose d'un bkup réalisé à partir de Prestashop, mais également via le phpmyadmin en sql et csv.

 

Ce que je demande c'est me remettre tout cela en état de fonctionnement et de me configurer le prestashop, pour ne pas avoir des pages blanches lorsque que l'on veut consulter la boutique et de de voir toutes les 5 minutes devoir vider le cache du Thême.

 

Etant donné que j'ai déjà du payer pour effectuer la mise à jour et voilà ou j'en suis, une contribution financière sera donnée, mais le montant sera dévoilé en MP

 

Pour un pro, en 15 minutes, cela doit être fait...

 

A bientôt

Share this post


Link to post
Share on other sites

Bonjour

 

 

 

Pour un pro, en 15 minutes, cela doit être fait...

 

Tout dépend du problème ça se résous pas toujours en 15 mn, le temps de vérifier, de peut être devoir désactivé un module pour tester vos 15mn sont loin.

 

Vous avez des pages blanches où en faisant quel action ?

Share this post


Link to post
Share on other sites

pages blanches, lorsque l'on souhaite accéder sur le site, allez dans la page modules.

 

Je suis obligé d'allez vider le cache toutes les 5 minutes, bref, une vrai corvée...

 

Bref, je n'ai jamais connu autant de problème depuis la mise à jour vers la 1.6.0.9 !

 

La 1.4.9.0 était peut être "kitch" mais au moins cette dernière fonctionnait sans le moindre problème..

Share this post


Link to post
Share on other sites

un jour vous vous connectez, les tarifs pour les transporteurs sont calculés hors tva, le lendemain, cela est revenu à la normal...

 

Chaque jour apporte son lot de surprises, mais en négatif...

Share this post


Link to post
Share on other sites

La 1.6.0.9 est à fuir (trop de bugs)

Repassez en 1.4.9 (restauration) et upgradez vers 1.6.0.8 (vous pouvez choisir la version)

Share this post


Link to post
Share on other sites

dans ce cas, je pourrais remettre ma sauvegarde sql effectuée sous la 16.0.9


y a-t-il moyen de downgrader ?

Share this post


Link to post
Share on other sites

Normalement, dans le module oneclickupgrade vous pouvez restaurer l'ancienne version

Ensuite téléchargez la 1.6.0.8 ici http://www.prestashop.com/download/old/prestashop_1.6.0.8.zip et placez l'archive dans : votre dossier admin/autoupgrade/download

 

Dans le module cliquez sur "plus d'options(mode expert)"

et choisissez : Canal : Archive locale

 

et lancez l'upgrade

Share this post


Link to post
Share on other sites

Merci à tous pour toutes vox explications, et pour sql, cela fonctionne toujours ?

C'est à dire ?

Si vous retaurez avec le module, votre base sql est restaurée à sa version précédente.

Si vous restaurez manuellement, la version contenue en base doit correspondre à celle de votre boutique.

 

Une boutique en 1.4 avec une base en 1.6 va pas bien fonctionner...

Share this post


Link to post
Share on other sites

Normalement, dans le module oneclickupgrade vous pouvez restaurer l'ancienne version

Ensuite téléchargez la 1.6.0.8 ici http://www.prestashop.com/download/old/prestashop_1.6.0.8.zip et placez l'archive dans : votre dossier admin/autoupgrade/download

 

Dans le module cliquez sur "plus d'options(mode expert)"

et choisissez : Canal : Archive locale

 

et lancez l'upgrade

 

J'ai suivi la procédure.

 

Un souci se présent après avoir enregistré le Zip de la 1.6.0.8: je n'ai pas de bouton pour lancer l'upgrade.

Normal ?

 

Dès lors comment faire ?

 

merci

Share this post


Link to post
Share on other sites

Toutes les options en haut à droite ont une coche verte ? (boutique en maintenance etc...)

Share this post


Link to post
Share on other sites

Le repertoire upgrade et le fichier zip sont accessibles en lecture/ecriture ?

 

Vous avez choisi le canal "Archive local" et rentré le n° de version ? ( 1.6.0.8)

 

La page devrait se rafraichir et le bouton apparaitre

Share this post


Link to post
Share on other sites

Ok... On va y arriver.

 

En face de "Votre version actuelle de PrestaShop" vous avez quelle version ?

Share this post


Link to post
Share on other sites

Oui, il y a de fortes chances et vu que le bouton "mettre à jour maintenant" n'apparaitra pas tant que la version en cours est supérieure à celle dispo...

 

Mais bon, s'il a restauré sa boutique en 1.4.9 ca devrait pas ^^

Share this post


Link to post
Share on other sites

Voilà, j'ai installé la 1.6.0.8 >> tout est ok.

 

Par contre, quand je veux restaurer le bkup que j'avais effectué via Prestashop en version 1.6.0.9, lorsque que je veux me rendre dans l'interface administration, il refuse mon mot de passe, je suis obligé d'en générer un nouveau, pourquoi ?

 

C'est idem pour tous les clients de ma boutique,  devront-ils faire pareil ?

 

Mon fichier settings.inc a été vérifié et pointe bien sur ma DB, le préfixe est correct et le mot de passe SQL aussi.

 

Y a-t-il une manipulation a effectuer ?

Share this post


Link to post
Share on other sites

Logique vos clés de hachage ont été régénérées
Il faut les récupérer dans le fichier /config/settings.inc.php d'origine

.....
define('_COOKIE_KEY_', 'PvXhupmUVgkHIKQBvEGFB6xHRLXX5xWEP8SIYIenFO0aAFZIr0QWPoNN');
define('_COOKIE_IV_', '69dVOSiB');
define('_PS_CREATION_DATE_', '2014-11-13');
if (!defined('_PS_VERSION_'))
	define('_PS_VERSION_', '1.6.0.8');
define('_RIJNDAEL_KEY_', 'DSst3szQLvzU23QyzswNfyYqjr43AA8b');
define('_RIJNDAEL_IV_', 'R9r3uminJrhHuKptC9M3YQ==');

C'est une exemple ci-dessus, ne les copiez pas^^

Share this post


Link to post
Share on other sites

Logique vos clés de hachage ont été régénérées

Il faut les récupérer dans le fichier /config/settings.inc.php d'origine

 

.....
define('_COOKIE_KEY_', 'PvXhupmUVgkHIKQBvEGFB6xHRLXX5xWEP8SIYIenFO0aAFZIr0QWPoNN');
define('_COOKIE_IV_', '69dVOSiB');
define('_PS_CREATION_DATE_', '2014-11-13');
if (!defined('_PS_VERSION_'))
	define('_PS_VERSION_', '1.6.0.8');
define('_RIJNDAEL_KEY_', 'DSst3szQLvzU23QyzswNfyYqjr43AA8b');
define('_RIJNDAEL_IV_', 'R9r3uminJrhHuKptC9M3YQ==');
C'est une exemple ci-dessus, ne les copiez pas^^

 

Le problème c'est que je ne dispose pas de ce fichier, vu que chez mon hébergeur, il me restaurait toujours l'ancienne?

 

Pas moyen de la trouver dans la DB via les tables?

 

Par contre le fichier settings de la 1.4.0.9, je la dispose toujours.

 

Merci d'avance

Share this post


Link to post
Share on other sites

Ben si vos mots de passe ont été générés avant le changement en 1.6.0.9 les clés de votre setting 1.4 sont les bonnes normalement

Share this post


Link to post
Share on other sites

Ok je vais tester tantôt.

 

Dernière question y a-t-il encore possibilité de récupérer les photos, car j'ai tjs les dossiers Img de la 1.4.0.9 sous la main.

Share this post


Link to post
Share on other sites

Normalement oui, il faudra ensuite les régénérer

Share this post


Link to post
Share on other sites

en régénérant cela ne fonctionne pas ; messsage=  "répertoire vide, image manquante" pour toutes les images.

 

Une chose étrange = ds la fiche du produit, j'enregistre l'image avec succès, l'aperçu apparait mais n'est pas visible sur le site.

 

Droit en écriture ...ok

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More