Jump to content

Recommended Posts

Bom dia!

 

Gostaria de saber como eu removo a mensagem "Powerd by PrestaShop" da minha loja quando vou compartilhar o link, como por exemplo, no Facebook.

 

Segue em anexo uma mensagem para melhor compreensão.

 

Grato!

 

 

post-824039-0-89622200-1416914114_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Bom dia!

 

Gostaria de saber como eu removo a mensagem "Powerd by PrestaShop" da minha loja quando vou compartilhar o link, como por exemplo, no Facebook.

 

Segue em anexo uma mensagem para melhor compreensão.

 

Grato!

 

Você terá que fazer essa alteração via código.

 

Entre no arquivo footer.tpl do tema que você está utilizando, e remova a linha que insere essa informação.

Share this post


Link to post
Share on other sites

Nao é necessário alterar nada por código.

 

Vc. vai na aba módulos -> módulo bloco cms. e retira la o gancho em "Display "Powered by PrestaShop" in the footer"

  • Like 1

Share this post


Link to post
Share on other sites

Nao é necessário alterar nada por código.

 

Vc. vai na aba módulos -> módulo bloco cms. e retira la o gancho em "Display "Powered by PrestaShop" in the footer"

Removi do gancho e sumiu a coluna do rodapé, que não era o que eu queria.. como restauro ela? já subi o backup do módulo cms tanto no theme quando na pasta modules.

Share this post


Link to post
Share on other sites

Vc. removeu do gancho o qu enao é a mesma coisa que eu escrevi. Vc. removeu em módulos -> posicoes, foi lá na lista do footer e removeu o módulo inteiro deletando o gancho.

 

Para reativar o módulo, vc. deve desinstalá-lo e instalar novamente. assim o módulo enganchará em todos os gancho nativos novamente. Ou entao vc. vai na aba módulos -> posicoes -> mover um módulo, seleciona o módulo bloco cms e engancha no footer novamente.

 

Para remover o Powered by vc. abre o módulo e edita lá o powered by, retirando o check do box.

Share this post


Link to post
Share on other sites

Vc. removeu do gancho o qu enao é a mesma coisa que eu escrevi. Vc. removeu em módulos -> posicoes, foi lá na lista do footer e removeu o módulo inteiro deletando o gancho.

 

Para reativar o módulo, vc. deve desinstalá-lo e instalar novamente. assim o módulo enganchará em todos os gancho nativos novamente. Ou entao vc. vai na aba módulos -> posicoes -> mover um módulo, seleciona o módulo bloco cms e engancha no footer novamente.

 

Para remover o Powered by vc. abre o módulo e edita lá o powered by, retirando o check do box.

Boa tarde!

 

Estou com o mesmo problema.

 

Mas quando abro o Módulo CMS o ckeck box está desmarcado e mesmo assim, toda vez que faz o compartilhamento do link a mensagem de "powered..." permanece.

 

Também procurei o texto no footer.tpl do tema e no footer.tpl da pasta mobile dentro do tema. Mas este texto não existe para ser editado.

 

Como excluir então a mensagem no rodapé ao compartilhar o link?

 

Uso PS 1.5.6.2 tema padrão.

Share this post


Link to post
Share on other sites

Remover o powered Prestashop para o FACEBOOK: Preferencias -> SEO & URL's -> edite a página "index" e remova lá a descricao meta da página, adicionando o seu próprio meta.

 

Após remover, vc. deverá deletar o cache do seu browser, o smarty cache e tmb. o cache do FACEBOOK !!!

  • Like 1

Share this post


Link to post
Share on other sites

Remover o powered Prestashop para o FACEBOOK: Preferencias -> SEO & URL's -> edite a página "index" e remova lá a descricao meta da página, adicionando o seu próprio meta.

 

Após remover, vc. deverá deletar o cache do seu browser, o smarty cache e tmb. o cache do FACEBOOK !!!

 

Boa tarde!

 

Grato pela sua resposta e atenção.

 

Eu fiz a limpesa do cache do navegador e até usei navegadores diferentes também com o cachê "zerado".

Fiz o seguinte caminho: Parâmetros Avançados>Desempenho. Em Smarty está marcado a opção Modelos de recompilar se os arquivos foram atualizados  e Cache também está marcado. Então cliquei em Limpar cache inteligente e o carregamento automático de cache.

Em Console de Depuração está marcado a opção Não abrir console.

No facebook eu acessei o link https://developers.facebook.com/tools/debug/og/object/ inseri o link da minha loja e cliquei em Fetch new scrape information.

Em seguida eu compartilhei o link na minha linha do tempo e tb na linha de outra pessoa e mesmo assim, a mensagem de "powered  by Prestashop" permanece.

 

Complementando: Fiz anteriormente o caminho Preferências>SEO & URLs e editei a página "index" mas ao Salvar dá a seguinte mensagem: Ocorreu um erro durante a atualização do objeto. meta ()

Edited by Carlos-JCP (see edit history)

Share this post


Link to post
Share on other sites

Você quer apenas retirar ou editar os direitos no footer?

 

Se for apenas tirar nosso amigo Selectat.Shop já respondeu.

 

Caso queria editar/substituir siga os passos abaixo: (Estou usando versão 1.6.1.6 com tema padrão)

 

Consegui resolver alterando a Compilação de Template além de Limpar o Cache. Segue passos abaixo.
 
Acessando Localização > Traduções > Traduções de Módulos Instalados > default-bootstrap > pt-br > Blockcms
 
De: [1] %3$s %2$s - Ecommerce software by %1$s [/1]
Por: [1] %3$s %2$s - Todos os direitos reservados - Desenvolvido por: %1$s [/1]
 
Depois em themes\default-bootstrap\modules\blockcms\blockcms.tpl e fiz as seguintes alterações 
 
De: {l s='[1] %3$s %2$s - Ecommerce software by %1$s [/1]' mod='blockcms' sprintf=['PrestaShop™', 'Y'|date, '©'] tags=['<a class=_blank" href="http://www.prestashop.com"&gt] nocache}
 
Para:  {l s='[1] %3$s %2$s - Todos os direitos reservados - Desenvolvido por %1$s [/1]' mod='blockcms' sprintf=['EXEMPLO', 'Y'|date, '©'] tags=['<a class=_blank" href="http://www.EXEMPLO.com"&gt] nocache}
 
O segredo foi fazer um passo a mais em Parametros Avançados > Desempenho
 
1 - Limpar o Cache.
 
2 - Em SMARTY > Compilação de Template, alterei para "Recompilar templates se os arquivos forem alterados".
 
Link do topico - > Tópico
 
Abraço
Edited by tcschiavi (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

@ tchsiavi - ele quer remover o powerded no FACEBOOK. O caminho aí é outro. O problema é que está tendo um erro ao salvar o novo meta que é responsável pelo powered by Prestashop no Facebook.

 

@Carlos-JCP. Isto é problema do servidor. Vc. deverá ler os logs de erro do servidor quando estava tentando salvar o meta novo. Quanto ao resto, o caminho que fez é o correto.

  • Like 2

Share this post


Link to post
Share on other sites

Bom dia a tds!

 

Primeiramente agradeço pela atenção e colaboração de tds!

 

Onde estava dando erro ao salvar o meta, entrei em contato com a hospedagem da loja e eles me disseram que era por conta de um erro de permissão na gravação do cache, mas que foi corrigido.

 

De fato, retornei e ao salvar a alteração, atualizou com sucesso.

 

Bem, eu fiz tudo o que foi relatado aqui e realmente não funcionou. A bendita frase "Powerd by Prestashop" ainda permanece ao compartilhar o link copiando a URL diretamente da loja para o Facebook.

 

Sendo assim, eu desisto!

 

A solução vai ser fazer na "unha" mesmo, CTRL+C na URL adiciono uma imagem (no caso um print da index) e CTRL+V...

 

Abraços

Share this post


Link to post
Share on other sites

Vc. está usando um tema próprio ? Se bem que este nao deveria ter influência, mas pode ter....

 

Uso PS 1.5.6.2 tema padrão.

Share this post


Link to post
Share on other sites

Uso PS 1.5.6.2 tema padrão.

Infelizmente nao posso acessar a sua loja, pois está limitando através de geotargeting. Talvez o Daniel consegue: https://www.cardservicos.com.br/lojavirtual/

 

Aliás usando o debugger do facebook, dá o mesmo erro: vc. está restringindo o acesso do FB, por isto o mesmo nao consegue atualizar os seus links e toma aqueles que postou. Vc. deverá colocar US como whitelist ou entao inserir os IP's do FB na whitelist do módulo geolocalization.

 

Veja o código source (body restricted country)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="br" lang="br">
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8">
<title>CARD - Loja Virtual - CARD - Loja Virtual</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="description" content="By CARD SERVIÇOS">
<meta name="keywords" content="cardservicos,cardserviços,cardservicoslojavirtual,cardservicos lojavirtual">
<meta name="robots" content="index,follow">
<link rel="shortcut icon" href="/lojavirtual/img/favicon.ico">
<link href="https://www.cardservicos.com.br/lojavirtual/themes/padrao/css/restricted-country.css" rel="stylesheet" type="text/css">
</head>
<body><div id="restricted-country">
<p><img src="https://www.cardservicos.com.br/lojavirtual/img/logo.jpg" alt="logo"><br><br></p>
<p id="message"> <img src="https://www.cardservicos.com.br/lojavirtual/img/admin/tab-tools.gif" style="margin-right:10px; float:left;" alt="">Você não pode acessar nossa loja deste país. Pedimos desculpas pela inconveniência.</p> <span style="clear:both;"> </span>
</div></body>
</html>

Além do mais o FB debugger está devolvendo erros:

 

Critical Errors That Must Be Fixed

Wrong return value

URL returned a bad HTTP response code. - Isto é porque o FB nao está conseguindo acessar a sua página (geotargeting mal configurado)

 

 

Errors That Must Be Fixed

Property missing The 'og:type' property is required, but not present.

  • Like 1

Share this post


Link to post
Share on other sites

O link é https:/cardservicos.com.br/lojavirtual/

 

Continuo sem conseguir acessar.

Ou dá TIMEOUT no servidor, ou dá a mensagem "Não pode acessar do seu país"...

Share this post


Link to post
Share on other sites

Infelizmente nao posso acessar a sua loja, pois está limitando através de geotargeting. Talvez o Daniel consegue: https://www.cardservicos.com.br/lojavirtual/

 

Aliás usando o debugger do facebook, dá o mesmo erro: vc. está restringindo o acesso do FB, por isto o mesmo nao consegue atualizar os seus links e toma aqueles que postou. Vc. deverá colocar US como whitelist ou entao inserir os IP's do FB na whitelist do módulo geolocalization.

 

Veja o código source (body restricted country)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="br" lang="br">
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8">
<title>CARD - Loja Virtual - CARD - Loja Virtual</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="description" content="By CARD SERVIÇOS">
<meta name="keywords" content="cardservicos,cardserviços,cardservicoslojavirtual,cardservicos lojavirtual">
<meta name="robots" content="index,follow">
<link rel="shortcut icon" href="/lojavirtual/img/favicon.ico">
<link href="https://www.cardservicos.com.br/lojavirtual/themes/padrao/css/restricted-country.css" rel="stylesheet" type="text/css">
</head>
<body><div id="restricted-country">
<p><img src="https://www.cardservicos.com.br/lojavirtual/img/logo.jpg" alt="logo"><br><br></p>
<p id="message"> <img src="https://www.cardservicos.com.br/lojavirtual/img/admin/tab-tools.gif" style="margin-right:10px; float:left;" alt="">Você não pode acessar nossa loja deste país. Pedimos desculpas pela inconveniência.</p> <span style="clear:both;"> </span>
</div></body>
</html>

Além do mais o FB debugger está devolvendo erros:

 

Critical Errors That Must Be Fixed

Wrong return value

URL returned a bad HTTP response code. - Isto é porque o FB nao está conseguindo acessar a sua página (geotargeting mal configurado)

 

 

Errors That Must Be Fixed

Property missing The 'og:type' property is required, but not present.

 

Pessoal, deu certo por aqui.

 

Vou explicar o que eu fiz:

 

Preferências>Geolocalização havia deixado Geolocalização por IP Ativado e em Selecione os países que podem ter acesso a sua loja também tinha deixado apenas o Brasil selecionado, pois não tenho o menor interesse em vender para fora do País.

 

Mas então, seguindo a sua orientação, adicionei o Estados Unidos (mas não estou confortável com esta opção ativada, pelo motivo descrito acima).

 

Então acessei Módulos e notei que Bloco Compartilhar no Facebook já estava Instalado e Habilitado.

 

Depois limpei o cache do PS, do Navegador do FB em https://developers.facebook.com/tools/debug/og/object/ 

 

Então ao realizar o compartilhamento da URL no FB a mensagem foi alterada e até apareceu algumas imagens da minha loja.

 

Depois retornei e desabilitei novamente os Estados Unidos, deixando apenas o BR novamente.

 

E no teste de compartilhamento, aparentemente está ok.

 

Vou fazer novos testes e qualquer novidade eu aviso.

 

Desde já, vlw pelas orientações e paciência  :D  :D  :D

Share this post


Link to post
Share on other sites

Como já comentado algumas vezes aqui neste fórum, não recomendo utilizar a geolocalização por IP.

Não funciona bem no Brasil e você pode ter clientes reais do Brasil que não conseguem acessar sua loja.

 

Para desativar a venda para fora do Brasil, basta restringir os países (cadastro), e/ou frete (entrega) e/ou módulos de pagamento apenas para o Brasil.

  • Like 1

Share this post


Link to post
Share on other sites
Em 22/10/2016 em 8:30 PM, tcschiavi disse:

Você quer apenas retirar ou editar os direitos no footer?

 

Se for apenas tirar nosso amigo Selectat.Shop já respondeu.

 

Caso queria editar/substituir siga os passos abaixo: (Estou usando versão 1.6.1.6 com tema padrão)

 

Consegui resolver alterando a Compilação de Template além de Limpar o Cache. Segue passos abaixo.
 
Acessando Localização > Traduções > Traduções de Módulos Instalados > default-bootstrap > pt-br > Blockcms
 
De: [1] %3$s %2$s - Ecommerce software by %1$s [/1]
Por: [1] %3$s %2$s - Todos os direitos reservados - Desenvolvido por: %1$s [/1]
 
Depois em themes\default-bootstrap\modules\blockcms\blockcms.tpl e fiz as seguintes alterações 
 
De: {l s='[1] %3$s %2$s - Ecommerce software by %1$s [/1]' mod='blockcms' sprintf=['PrestaShop™', 'Y'|date, '©'] tags=['<a class=_blank" href="http://www.prestashop.com"&gt] nocache}
 
Para:  {l s='[1] %3$s %2$s - Todos os direitos reservados - Desenvolvido por %1$s [/1]' mod='blockcms' sprintf=['EXEMPLO', 'Y'|date, '©'] tags=['<a class=_blank" href="http://www.EXEMPLO.com"&gt] nocache}
 
O segredo foi fazer um passo a mais em Parametros Avançados > Desempenho
 
1 - Limpar o Cache.
 
2 - Em SMARTY > Compilação de Template, alterei para "Recompilar templates se os arquivos forem alterados".
 
Link do topico - > Tópico
 
Abraço

Como faço isto de retirar o link no Presta V 1.7.5 qual o ficheiro e já agora o caminho?

Obrigado

Rui

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More