Jump to content
maxhome

[MODULE] Export des produits en csv (Modification du mod de lmwood)

Recommended Posts

Bonjour, lmwood a mis un module d'export en csv ici:
http://www.prestashop.com/forums/viewthread/37900/P0/modules___development/module_product_export_module_v0_dot_1_free

- Choisissez les éléments que vous voulez exporter par glisser-déposer depuis les champs disponibles.
- Choisissez comment vous voulez que l'exportation soit ordonnée (Tri facile des champs sélectionnés).
- Enregistrer le modèle de l'exportation, de sorte que vous pourrez la recharger plus tard.

J'avais plusieurs soucis sur ce mod (Problème des apostrophes dans les noms, export dans une seule colonne de tous les champs etc...)

J'ai corrigé, traduit, le tout à ma "sauce" que je vous livre ici...

Si d'autres le modifient, ce serait sympa de suivre le fil afin que tout le monde en profite.
Ajout de champs, fonctionnalité etc.

Je livre ce mod en l'état, je n'assure aucun SAV... merci

PS: si vous avez d'autres modules exportproduct, les desinstaller sinon il se peut qu'il ne veuille pas s'installer...

UPDATE du 24/01/2010:
Légères modification de la mise à jour de lmwood v2
Traduction, séparateur par défaut le point virgule, juste le choix de la langue (anglais, français) pour extraire les infos de la BDD par rapport à la langue, les prix avec des virgules sans le symbole €, pour moi plus pratique quant on se sert d'excel...etc)
Pensez bien à mettre votre dossier chez OVH en 755, surtout pas 777!!!
Testé sur 1.2.5 (pas compatible 1.1 je pense!)

UPDATE du 30/01/2010:
Correction du bug des catégories anglais/français

Attention, si vous activez l'URL simplifiée dans le BO (BO dans onglet Préférences), les url renvoyées ne seront pas bonnes

17615_dKZ6BRmncJr5RDX637No_t

exportproducts.zip

  • Like 1

Share this post


Link to post
Share on other sites

Il serait bon de reférencer les site où ce mod fonctionne.
D'autres personnes ont-elles testé chez OVH?
Merci

Share this post


Link to post
Share on other sites

merci jolvil de ta réponse.
Tu as testé le module original de lmwood ou le mien que j'ai modifié ici ?
J'ai dû toucher quelque chose sur OVH mais je ne sais pas quoi. Sur un autre de mes sites, il fonctionne nickel grrr....

Share this post


Link to post
Share on other sites

Par contre j'ai un autre probleme avec l'original, avec la version recente exportant les liens des images, j'ai un certain nombre de champs dont la description qui ne sont pas exporté dans le csv. Dans une autre precedente je n'ai pas ce probleme, ts les champs sont exportés, avez vous ce probleme?

Share this post


Link to post
Share on other sites

Perso, j'ai voulu tester ce module (l'adapté), mais la liste des champs est vide

Je suis sur 1and1

Share this post


Link to post
Share on other sites

merci d'avoir répondu...Vraiment bizarre le fonctionnement de ce module.
J'ai pas changé l'encodage, j'ai juste traduit exportproducts.php, remplacé à 2 endroits le , par un ; et ligne 228 j'ai mis:

$export_final[$field] = iconv("UTF-8", "ISO-8859-1//TRANSLIT", $export[$field]);


ceci pour ne plus avoir de problème pour les apostrophes.
J'y comprends rien, sinon chez phpnux aucun problème, extrait tout sans problème sinon chez ovh, comme aaron87, export csv vide...
Je vais me conconcentrer sur l'original je crois...
Je ferai un test sur une plus grosse boutique pour voir les url des images et voir s'il me manque des infos

Share this post


Link to post
Share on other sites

C'est bon, mon module modifié fonctionne.
J'avais mis des droits en 777 mais OVH bloquait en execution
J'ai remis en 755 : ca marche nickel;-)

Pour Jolvil, effectivement, comme toi, certains champs sont vides...
Mais j'ai vu que l'auteur dans le post anglais comptait le mettre à jour demain?!

Share this post


Link to post
Share on other sites

Bonjour,

installé et testé sur Hostpapa, avec une version de presta 1.2.5 --> installation et fonctionnement OK !

merci !

Share this post


Link to post
Share on other sites

Hola,
He instalado esta versión sobre la versión PS 1.2.5. Solo me importó el nombre de la categoría Home acompañado de la coma, pero no importó ninguna categoría más.
La url de las imágenes sale mal. ejemplo: Aparece http://www.promoinformatica.com/12-52/.jpg y lo correcto seria: http://www.promoinformatica.com/img/p/12-52-large.jpg
Todo lo demás está perfecto.
Saludos

J'ai installé cette version sur la version PS 1.2.5. J'ai juste importé le nom de la catégorie d'origine accompagnés d'un coma, mais n'a pas importé otre catégorie.
L'url de l'image se passe mal. Exemple: Apparaît sortie http://www.promoinformatica.com/12-52/.jpg et droite: http://www.promoinformatica.com/img/p/12-52-large.jpg
Tout le reste est parfait.
Salut

Share this post


Link to post
Share on other sites

Bonjour,
moi je le test sur 1&1;, il s' installe bien mais je ne peux faire glisser aucun choix. colonne de "liste de champs et "champs choisis" sont vides....
seul "sauvegarder, charger et supprimé fonctionneraient...

Mais ce serait bien que ca fonctionne , il est top ce module.

install comme suit:

CSS ----> css du site
JS ------> js/jquery du site
exportproducts ---> modules

J' espère que c'est bien comme çà.

16684_DzMYWAB2oIQmI7Q84DMr_t

Share this post


Link to post
Share on other sites
Bonjour,
moi je le test sur 1&1;, il s' installe bien mais je ne peux faire glisser aucun choix. colonne de "liste de champs et "champs choisis" sont vides....
seul "sauvegarder, charger et supprimé fonctionneraient...

Mais ce serait bien que ca fonctionne , il est top ce module.

install comme suit:

CSS ----> css du site
JS ------> js/jquery du site
exportproducts ---> modules

J' espère que c'est bien comme çà.


J' ai tous passé en 777, toujours rien...

Share this post


Link to post
Share on other sites

Bonjour,

merci pour ce module il fonctionne très bien en local pour l'instant. Je ne devrais pas tarder à le tester sur ovh.

Merci.

Share this post


Link to post
Share on other sites

Bonjour,
Comment on configure ce module ? On l'envoit ou sur le ftp ? et on y accède comment car je ne trouve rien ...
Merci

Share this post


Link to post
Share on other sites

J' ai tous passé en 777, toujours rien...


Passe en 755, surtout pas 777, jolvil l'a expliqué!

Ce module s'installe comme un autre, j'vois pas où est le soucis?
Tu l'envoyes dans le repertoire modules par ftp et tu le paramètres dans le BO

Share this post


Link to post
Share on other sites

maxhome, c est bizarre que je ne le vois pas dans le bo dans la partie module. Il a quel nom?
Merci
Tony

Share this post


Link to post
Share on other sites

Regarde la capture jointe
Attention n'as-tu pas déjà un autre module d'export installé???
Sinon désinstalle les autres versions

17029_yxcWfTj6zyKCTDwcXgHX_t

Share this post


Link to post
Share on other sites

bah c est vraiment bizarre car je n'ai rien qui apparaît....

Edit: J'ai trouvé. En fait la personne a crée un répertoire à l'intérieure d un autre répertoire, donc il faut tout remonter d un niveau quand on l upload sur le ftp. Là il apparait, je vais tester maintenant. Encore merci

Share this post


Link to post
Share on other sites

Bonjour

Désolééééééééééééééééé ne fonctionne pas c'est à dire au premier coup j'avais pas vu le produits.csv qui était dans le dossier, donc il m'as sortis ce fichier avec plein d'articles que je vends pas.

Donc il écrase pas les anciens, j'ai effacer, re-essayer mais rien vide de chez vide même avec le bloc note.
Mon hébergeur heu moi-même location multiplan.

Sous linux l'hébergement

Share this post


Link to post
Share on other sites

- Le produits.csv qui est dans le repertoire du module, tu peux le supprimer!
- Ensuite met le module en CHMOD 755.


Sinon essayez l'original qui a été depuis, mis à jour par l'auteur...
Voir mon premier post

Share this post


Link to post
Share on other sites

Re

Bien j'ai récupérer sur son site imwood et n'est même pas visible dans onglet Module et le dossier est 755 et fichier 644

Aller encore un export noter -1 :vampire:

Share this post


Link to post
Share on other sites

oron, j'ai trouvé la solution pour moi. Je n'avais pas vérifié avant. Peut etre que pour toi c est la meme chose. Mais le fichier zip du site imwood est de la forme exportproducts/exportproducts/*.*
Donc si tu l envoies tel quel, tu as modules/exportproducts/exportproducts/*.* et c'est pour cela que cela ne s'affiche pas.
Il faut avoir modules/exportproducts/*.*
Si cela peut t'aider ...

Share this post


Link to post
Share on other sites

Re

Hélas tons28 c'est pas ça ;) depuis que je manipule prestashop et que les fichiers zip ne se dézippent pas sur l'hébergement, je dézippe les fichiers en local, et j'ai souvent constater que les fichiers sont dans des farandole de dossier

mondossiermodule1/mondossiermodule1 et bien plus tard /mondossiermodule

Je sais pas pourquoi ou alors il savent pas utilisé le zippeur ou l'on mal réglé, mais c'est souvent décevant tant de fioriture.

Donc réflexe : dézipper en local puis transférer avec ftp c'est tout aussi rapide. Question d'habitude. Ce cas c'est pas seulement prestashop c'est un problème mondial :snake:

Share this post


Link to post
Share on other sites

Bravo, enfin un module exportproduct qui marche chez 1and1
Merci, cela va m'aider à avancer - Bravoooooooooooooooooo !

Share this post


Link to post
Share on other sites

Bonjour

Marche nickel, chez moi
pense tu qu'il est possible de faire la même chose pour les déclinaisons ?
et par exemple d'exporter aussi les correspondances images / déclinaisons. (très fastidieux dans le BO)

pa.

Share this post


Link to post
Share on other sites

Mise à jour voir post première page.
Juste quelques petites modifs
Peha, je regarde mais je ne suis qu'un "adaptateur" et ne fais, ici, que modifier le mod de lmwood :)

Share this post


Link to post
Share on other sites

Bonjour

j'ai installé ce module qui fonctionne plutot bien , j'ai juste un soucis je n'arrive pas à avoir les catégories et sous categories dans l'export !

merci

Share this post


Link to post
Share on other sites

re,
Toujours aucun affichage chez moi des catégories a choisir pour l' export.... sur Firefox et IE rien

Share this post


Link to post
Share on other sites

marche nickel sur une svn 1.3.1 en local sous wamp seul petit truc si on choisit fr reste en anglais sur l'export ( les categories )??

pas moyne de prolonger cet excellent export en vrai catalogue avec photo ????

merci a toi pour ce boulot
cdlt
pat

Share this post


Link to post
Share on other sites
seul petit truc si on choisit fr reste en anglais sur l'export ( les categories )??


Allez pour patgame, mis à jour(les catégories), à tester :)
monvidedressing c'est quoi ton problème d'url sur les images? tu obtiens quoi?

Edit: ok je viens de voir sur ta boutique, le chemin est incomplet, il te manque le rep /img/ c'est cela?
par exemple tu as dans l'export
http://www.mon-vide-dressing.fr/1816-1816/ikea-hamac.jpg
à la place de
http://www.mon-vide-dressing.fr/1816-1816-home/ikea-hamac.jpg

A tous les coups tu as activé URL simplifiée dans le BO non??? (BO dans onglet Préférences)
Essaye de le désactiver pour voir et retente un export
sinon je sais pas un problème d'.htaccess peut-être??

17981_KBDTTcZysNWzqbWijF62_t

Share this post


Link to post
Share on other sites

on demande on est servi royale quoi

que dire de plus !

un vrai catalogue en sortie pdf avec photo pour prolonger cet excellent export ???? et la prise en compte des déclinaisons ??

une question: je décortique ps mais bon je découvre tous les jours,

les produits en accueil sur le FO sortent en catégorie accueil qsur l'export mais ce n'est pas leur vraie catégorie ( pour des stats par exple ) mais je suppose que la on ne peut rien faire à ce niveau ?

comme disait un célèbre humouriste se serait le chit sur le mac do euh je voulais dire la cerise sur le gâteau

jamais content la bleusaille et exigeant avec ça lol je sais je le ferais plus madame

mais bon ce module doit faire partie de notre config, absolument indispensable ( je me suis bien racheté hein lol )

ok pour le fr en export sort nikel

merci a toi
cdlt
pat

Share this post


Link to post
Share on other sites

Bonjour,
allez je m'incruste.

Ne le prenez surtout pas mal je voudrais juste donner une idée.
en fait j'ai tester ce module nikel, apres j'ai voulu importer : ca marche pas.(ou je comprend rien)
Puis j'ai cherché comment importer rapidement, je me suis pas attarder la dessus car j'en ai pas vraiment besoin bref
Mais par contre j'ai pu voir que plein de personne galere a importer les produits.

Alors mon idée serait de repartir de ce module pour en faire son contraire. Mais sans ecraser ce qui existe deja dans la base de données.
Moi c'est sur je suis pas capable de le faire.

Share this post


Link to post
Share on other sites

Luggy, surveille parfois le post (voir mon 1er message) en anglais original de ce module fait par lmwood. (Il a cela en projet je crois import/export)
Je n'ai fait que quelques modifs dessus par confort personnel mais le créateur...c'est lui :)

Share this post


Link to post
Share on other sites

Bonjour,
Je viens de tester le module et il fonctionne bien.
Je suis hébergé chez Webalpa. Le répertoire est en 777 en 775 cela ne fonctionnait pas.
Merci!!

Share this post


Link to post
Share on other sites

Oui bien vu, j'ai rectifié mon post de la première page... 755 pour OVH qui n'accepte pas 777

Share this post


Link to post
Share on other sites

Oui en effet j'ai vu Maxhome. Ya pas de mal, c'etait juste une idée comme ca.
Ca aurait pu etre juste un simple modif a faire et profiter a la communauté (c'etait dans ce but).

Mais j'avais pas regarder comment cela fonctionnait, Maintenant que j'ai regardé, je comprend le fonctionnement
du coup j'ai vu par rapport a la structure de la base que ce ne serait pas evident.

Allez on oublie mon 1er post.....

Share this post


Link to post
Share on other sites

Sorry for writing this in english but I do not speak french.

Maxhome, nice work on the translation into french and probably a few tweeks here and there. I'm going to be releasing another version soon and will include your translations.

Thank you.

Share this post


Link to post
Share on other sites

Bonjour, le module fonctionne bien merci, il est possible d'exporter les attributs pour
Produit ? Pour moi de changer le prix du produit.
Désolé pour le français je utiliser la traduction google, je suis italien.
Merci

Share this post


Link to post
Share on other sites

will u guys do this conversation in english?

nous, le ingorante people de la monde, ne understende voutre languagé! oh la la!

Share this post


Link to post
Share on other sites

Fabuleux ! C'est le premier module d'export qui marche chez moi, même le module original ne marche pas. Merci Maxhome !

Share this post


Link to post
Share on other sites

Hi Guys.

I have to use english.
I am asking for one tip only:
- what I have to do to get EAN13 exported?

I was trying to make some changes to exportproducts.php but no success.

Thanks for a tip!
Tomaz.

Share this post


Link to post
Share on other sites

Bonjour Maxhome,

Je réitère mes félicitations pour ce module d'export.
Je viens de m'apercevoir d'un soucis : la quantité.
La quantité pour chaque produit est à 1 même lorsque le produit est vendu (sachant que je n'ai qu'un exemplaire de chaque produit donc une quantité à 1 est normal !).
Comment puis-je rectifier cela ?

Share this post


Link to post
Share on other sites

Bonsoir monvidedressing,

Attends je comprends pas là.
Tu me dis que la quantité exportée est toujours de 1 (Sachant que tu n'as qu'1 article de chaque c'est cela?)
Bizarre, si le produit est vendu la quantité doit revenir à 0, ce qui est le cas pour moi.
Sinon je pense plus à un problème autre mais ne sais pas

Edit: et la quantité est bien de 0 dans le BO de Presta???

Share this post


Link to post
Share on other sites

Bonsoir Maxhome,

La quantité est à 0 dans le BO quand le produit est vendu.
Petite info qui pourra peut-être te servir : pour chaque article, j'ai crée une déclinaison qui indique la taille ou la pointure et l'état (neuf ou occasion).
Je te confirme, à l'export, j'ai 1 comme quantité sur tous les articles.

Share this post


Link to post
Share on other sites

Oui monvidedressing confirmation... Ce mod exporte la quantité présente dans la table product et non la ou les quantités de la table des déclinaisons product_attribute.
D'ailleurs pour les prix aussi tu dois avoir des surprises...Si tu as une robe en taille 38 et 40 avec 2 prix différents, les infos de prix repris par ce mod ne seront pas bonnes.

Il faudrait modifier ce mod afin qu'il gère les déclinaisons

Avis aux amateurs qui veulent se pencher dessus

Share this post


Link to post
Share on other sites

Salut Maxhome

content de ce module coopératif qui à l'air vraiment cool !

Petit souci (je suis en 1.3.0.6

si je n'ai pas de produit il me mouline un CSV nickel avec tous les champs.

Mais quand il y a des produit là j'ai un

Warning: implode() [function.implode]: Invalid arguments passed in /myshop/boutique/modules/exportproducts/exportproducts.php  on line 166
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM psv13_product as p LEFT JOIN `psv13_product_lang` pl ON (pl.`id_product' at line 2

SELECT p.`id_product`, 
           FROM psv13_product as p
           LEFT JOIN `psv13_product_lang` pl ON (pl.`id_product` = p.`id_product`)
           WHERE pl.`id_lang`=2 GROUP BY p.`id_product`




T'as une idée du problème ?

Mille merci

Share this post


Link to post
Share on other sites

Bonjour Jean-Bruno,

Je viens de le tester sur une 1.3.0.7 et pas de problème.
Là j'vois pas
Quand tu me dis "si je n'ai pas de produit", c'est à dire que tu ne selectionnes pas le nom du produit pour l'export c'est ça?

Question, mais vraiment au hazard, tu as plusieurs langues sur ta boutique?
Si c'est le cas et si tu peux, laisse que le français et retente une exportation...

Mais attention, c'est juste une idée comme ça, sans fondement...
Si des pros peuvent aider!!!

Maintenant si tu ne peux pas et que tu as par exemple une 2ème langue, vérifie que tes noms de produits existent bien dans la seconde langue

Share this post


Link to post
Share on other sites

non non cher Maxhome, j'ai eut l'occasion de tester alors que ma base était vide de produit (suite à import bousillé)
Pour le reste je vais voir et je rapporte ici les résultats

Share this post


Link to post
Share on other sites

Bonjour Maxhome,

Après plusieurs essais et des recherches, je me demandais s'il n'était pas judicieux d'aller chercher la quantité de la table product_attribute qui fait la somme des déclinaisons ?
J'ai fait des essais, je n'y arrive pas !

Share this post


Link to post
Share on other sites

Bonjour

J'utilise ce module sur mes 4 sites en Prod et il fonctionne parfaitement.
Il est très facile à installer et à mettre en oeuvre. version PS 1.2.5, 13.7, 1.3.9
Bravo pour le concepteur et à Maxhome pour les modifications

Question 1: Comment rajouter une option de sélection fournisseur ?
Question 2: Comment rajouter des options de sélection pour customizer les sélections ?
( ex je ne veux que les fournisseurs A et B avec la marque C ou les produits non actif du fournisseur A etc.. )
Question 3: Dans le même esprit, à quand un module d'export des commandes / clients

Share this post


Link to post
Share on other sites

Bonsoir,

Si dans le catalogue du BO, la quantité affiché est celle de la table ps_product mais est mise à jour par la table ps_product_attribut.
Du coup, le module d'export est fabuleux pour la liste des produits mais pas pour un état de stock ! grrrrr
Il y a un génie qui a une idée ?

Share this post


Link to post
Share on other sites

Bonjour à tous et à Maxome ,
Pas de problème pour la mise en place du module mais lorsque je l’ouvre les champs sont vides. Je suis chez OVH et j’ai bien mis ‘755’ pour l’attribut du fichier et des sous-fichiers. Impossible de trouver la solution.
Merci d’avance – Bonne journée -
Vanessa

Share this post


Link to post
Share on other sites

Bonsoir,
Oups Vanessa, j'avais pas vu ce post avant de t'envoyer mon PM...
Attention, tu parles de fichiers mais c'est avant tout le dossier exportproducts qu'il faut mettre en 755 chez OVH (Es-tu certaine de ne pas avoir mis des fichiers en 777 car OVH n'aime pas du tout)
Tiens-nous au courant
Max

Share this post


Link to post
Share on other sites

Salut Maxhome,
Merci pour ta réponse raponse rapide. Je me suis mal exprimée; j'ai bien mis le dossier exportproducts en 755 via Filezilla; avant le changement il était en 705. Mais même en 755, les champs n'apparaissent pas dans le module ?? J'y ai passé plusieurs heures mais impossible de trouver la solution. Reste plus que Maxhome et la communauté prestashop !! Merci c'avance

Share this post


Link to post
Share on other sites

c'est toujours difficile de faire un diag sans avoir accès à la boutique!
Pas de config particulière, URL simplifiée activée ou autre?
Si c'est la cas, désactive et retente histoire de voir ;)

Share this post


Link to post
Share on other sites

allo
je recupere tout le code avec et c'est un peu le foutoir a moins que ça soit moi qui n'est pas compris quelquechose...
prestshop 1.3.1 en local si quelqu'un avait une idée

produits.csv

Share this post


Link to post
Share on other sites

macabann, là j'comprends pas ???
Ton csv est correct, où est le problème?

Share this post


Link to post
Share on other sites

et bien quand je le recharge sur prestashop j'ai le code html du texte, et si il manque des champs il mélange tout au chargement et les lettres avec des accents sont remplacer par des "?" et j'ai des erreurs resultants

mais je l'ai ouvert avec le classeur de openoffice....
mais peut etre que j'ai pas compris le principe....

24816_zT0UWZzgsSbjfp3izhOj_t

Share this post


Link to post
Share on other sites

bon ça vient de moi
un milliard d'excuses, j'étais resté en categorie et pas en produit
mais j'ai quand meme des erreurs si dessus voir image

Share this post


Link to post
Share on other sites

Bonjour et merci pour ce module qui facilite bien la vie.
Je voulais savoir s'il était envisageable de pouvoir exporter également les attributs des produits (dans une version future) avec ce module ?

merci encore.

Share this post


Link to post
Share on other sites

Bonsoir,

J'utilise ce module pour l'exportation… pas de soucis
et reprend le csv créé pour l'importation du catalogue dans une autre boutique… avec la fonction import du BO : là j'ai un joli "tentative de piratage"

Quelqu'un aurait-il la raison et la solution ?

Merci par avance !

Share this post


Link to post
Share on other sites

Bonjour à tous, et merci pour tout le travail réalisé sur ce module, que j'utilise et qui me rends de grands services ^^

Néanmoins, je m'interroge sur la possibilité de le compléter :

Par exemple (et surtout) en ajoutant la fonction "export des catégories" ?

J'en appel aux développeurs (et à maxhome aussi), y'aurait-il beaucoup de travail pour ajouter une fonction d'export des catégories à ce module ?

En gros il faudrait combien de temps de dev ?

Parce que je n'sais pas pour les autres, mais c'est quand même galère de tout ce retaper la création des catégories à la main avant d'y coller les produits :)

Il va de soit que je suis prêt à financer en partie ce développement sur la base d'une mutualisation à plusieurs ou d'un don (en fonction de mes moyens bien entendu :P).

Après, on peut imaginer rajouter d'autres fonctions, en gros permettre d'exporter tout ce qu'on peut importer dans Presta ^^.

Merci.

Share this post


Link to post
Share on other sites

Merci, super module :)

Possibilité d'ajout URL vers fiche produit ?
Possibilité d'ajouter lien vers pdf ?

J'espère ne pas trop en demander ...

Merci

Share this post


Link to post
Share on other sites

Bonjour,

J'ai installé votre module, mais j'ai du louper quelques chose, car je n'ai aucun champ dans la liste.

Merci de votre aide.

Je suis en PS 1.3.2.3

Edit: J'ai trouvé. il fallait creer à la main les tables car il ne l'avait pas fait eu automatique.
Une fois crée on peut désinstaller sans souci et réinstaller proprement.

Il subsiste toujours un problème, je n'arrive pas à importer des chiffres avec des décimales : 7.4 ou 7,4 ne focntionnent pas.

Share this post


Link to post
Share on other sites
Bonjour,

J'ai installé votre module, mais j'ai du louper quelques chose, car je n'ai aucun champ dans la liste.

Merci de votre aide.

Je suis en PS 1.3.2.3

Edit: J'ai trouvé. il fallait creer à la main les tables car il ne l'avait pas fait eu automatique.
Une fois crée on peut désinstaller sans souci et réinstaller proprement.

Il subsiste toujours un problème, je n'arrive pas à importer des chiffres avec des décimales : 7.4 ou 7,4 ne focntionnent pas.


bonjour marli06,
J'ai le meme probleme que toi pour l'instal, les bases ne sont pas créées. Tu peu me dire de qu'elle maniere tu as créé les tables plus précisément, la mise en forme ? Merci

Share this post


Link to post
Share on other sites

Ecoute merci, c'est magnifique tout ça.
Testé avec la toute dernière version de PrestaShop (1.3.2.3) et hébergé chez OVH : tout fonctionne niquel.
J'ai 1 seul problème : les Tags ne sont pas exportés, c'est dommage. (les Meta-Tags sont exportés donc ça va je fais un simple copié-collé d'une colonne à l'autre).
Donc si il y a une solution à ce problème je suis preneur.

Share this post


Link to post
Share on other sites

bonjour

je suis sur ovh et j'ai une belle erreur 'tentative de piratage" qd je veux exporter les produits

le chmod est bien à 755

quelqu'un aurait il une idee ?

Merci pour votre aide

Share this post


Link to post
Share on other sites

il ne fonctionne pas sur la 1.3.6 ? donc encore moins sur la prochaine 1.4? :( On peut s'attendre à quand à une mise à jour de ce plugin? Merci infiniment!!

Share this post


Link to post
Share on other sites

Bonjour je viens de l'installer mais je rencontre un problème d'affiche donc je ne peux pas l'utiliser.
Je suis chez ovh et j'ai la version : 1.3.2.3

37963_HGAzzbg8c3h5gmPGT1Wt_t

Share this post


Link to post
Share on other sites

Hello, je fais remonter car j'ai un petit soucis : Installation tout ça nickel par contre quand je lance l'export, page totalement vierge >< Sauriez-vous d'où cela peut-il venir ?

D'avance merci.

Share this post


Link to post
Share on other sites

Bonjour a tous, ce module est super .
Je cherche à ajouter la possibilité d'exporter la valeur de l'écotax, celle-ci n'est pas présente dans la liste, quelqu'un la déja fait ?
J'ai modifié la ligne 78 comme ceci

(29, 'URL Images', 'images', 'products', 0),
(30, 'ecotax ttc', 'ecotax', 'products', 0);

C'est résolu :lol: , j'ai juste eu besoin d'ajouter cette valeur 30, 'ecotax ttc', 'ecotax', 'products', 0 directement dans la base export_fields
en fait, ce que j'avais modifié concernait les données insérés lors de l'installation du module

Share this post


Link to post
Share on other sites

Bonjour je viens de l'installer mais je rencontre un problème d'affiche donc je ne peux pas l'utiliser.<br/>Je suis chez ovh et j'ai la version : 1.3.2.3

 

Colonnes vides également...t'as réussi à trouver une solution? merci (suis chez ovh aussi)

Share this post


Link to post
Share on other sites

Prestashop 1.2.5

J'ai bien le module installé dans le BO.

Lorsque je clique sur configurer j'ai les 2 colonnes Listes des champs, et Champs choisi qui sont vides et grisées.

 

D'ou viens le problème?

Share this post


Link to post
Share on other sites

Bonjour,

 

Je viens d'installer le module sur une version 1.4 chez OVH.

 

Il marche impeccable (à part un petit défaut d'affichage qui n'est pas gênant.

 

Une question: il y a t il moyen de gérer les stocks des produits avec attribut? En modifiant quelque chose?

 

Merci

 

A bientôt

  • Like 1

Share this post


Link to post
Share on other sites