Jump to content

Recommended Posts

A tout hasard j'ai effacé toute trace de google shopping sur le ftp, et réinstallé cette dernière version mais toujours aucune donnée dans "catégories".

 

 

 

edit : C bon plus d'erreurs

Edited by Hobbes

Share this post


Link to post
Share on other sites

Hi dimooz and thanks for your work.

 

However we cannot remove the old module because it's too risky to publich on Gshopping with unstable module. isn't possible to use it alongside the old one ? If the name is different ?

 

No, I suggest you not to try this module without uninstalling the previous one, they use same database parameters and this could be a problem to get this one working correctly..

 

[EDIT] Reported errors in this thread have been corrected. I suggest you to backup your database and try this last version.

Edited by dimooz

Share this post


Link to post
Share on other sites

Hi,

 

thanks for the module.

 

There is one problem in my xml feed - atrribute "condition" is missing. Any ideas?

Prestashop version 1.5.3.1.

 

Further information needed for diagnosis, have you configure/linked the products' condition attribute or did you set the condition for the category/categories ? Thank you for the feedback anyway.

Share this post


Link to post
Share on other sites

Hi,

 

thanks for the module.

 

There is one problem in my xml feed - atrribute "condition" is missing. Any ideas?

Prestashop version 1.5.3.1.

 

it's fantastic modul, Instal on PS 1.6.0.9 and it's ok, but have the same probleme, "condition" is missing

 

in the back office product was selected as the condition "new"

 

any idea ???

Edited by jonysi_d

Share this post


Link to post
Share on other sites

GREAT, this is worked

 

But have problem with currencies, and very good making not language export , COUNTRY-LANGUAGE-CURRENCIES export xml!!!

Share this post


Link to post
Share on other sites

it's fantastic modul, Instal on PS 1.6.0.9 and it's ok, but have the same probleme, "condition" is missing

 

in the back office product was selected as the condition "new"

 

any idea ???

 

Same issue in my shop. the xml files don't have condition parameter to export, and then google merchant center doesn't accept these products.

Share this post


Link to post
Share on other sites

I have detected that If you edit a category manually inside this module, you can select condition parameter different as by default, then all products related with this category automatically is set as condition as you selected.

 

But It doesn't work with the option Condition: By default.

 

Any fix for this?

Share this post


Link to post
Share on other sites

I have detected that If you edit a category manually inside this module, you can select condition parameter different as by default, then all products related with this category automatically is set as condition as you selected.

 

But It doesn't work with the option Condition: By default.

 

Any fix for this?

 

Pretty weird that it doesn't work only with the condition attribute, I'll try to fix it asap. Keep an eye on this thread, as I'll certainly update the module on the GitHub hosting.

 

[EDIT]

This is how the module works :

 

 - if your products already have a "condition" attribute set in prestashop, then you can indicate it in the module main page, by the way products are exported with your native product's condition value.

 

- if your products have not any "condition" attribute, and Google asks for it, then you can set the value for this attribute in the module category's configuration form, then each product in this category is exported with this value.

 

- if your product have no condition attribute, and its module category has no 'condition' value set, then product is exported with the condition value set for its parent category, and so on till the root category.

 

If all of your shop products belong to the same Google Shopping category, you can just set it for your root/home category, no need to set it for all of your categories. Children categories automatically get the same parameter. The module works the same way for the condition attribute, availability, gender and age_group attributes.

 

The "Default" value means: "if product have no condition attribute set, then use the category attribute value, and if it's not set, then use the first parent category's filled setting." ... Not really clear but should be helpful ?

In other words, If Google Merchant Center doesn't accept your products because the "condition" attribute is missing, then just set the value "new" to the condition attribute while editing your root category in the module configuration page. By the way all of your shop products are exported with the condition attribute set to "new". No need to change the "Default" value for each products category.

Edited by dimooz

Share this post


Link to post
Share on other sites

Hi,

 

thanks for the module.

 

There is one problem in my xml feed - atrribute "condition" is missing. Any ideas?

Prestashop version 1.5.3.1.

 

I suggest you to set "new" for the condition attribute attached to your home category (edit the category in the module configuration page to do this). By the way all of your products should be exported with the value you set ("new" or whatever you chose to set).

Edited by dimooz

Share this post


Link to post
Share on other sites

Pretty weird that it doesn't work only with the condition attribute, I'll try to fix it asap. Keep an eye on this thread, as I'll certainly update the module on the GitHub hosting.

 

[EDIT]

This is how the module works :

 

 - if your products already have a "condition" attribute set in prestashop, then you can indicate it in the module main page, by the way products are exported with your native product's condition value.

 

- if your products have not any "condition" attribute, and Google asks for it, then you can set the value for this attribute in the module category's configuration form, then each product in this category is exported with this value.

 

- if your product have no condition attribute, and its module category has no 'condition' value set, then product is exported with the condition value set for its parent category, and so on till the root category.

 

If all of your shop products belong to the same Google Shopping category, you can just set it for your root/home category, no need to set it for all of your categories. Children categories automatically get the same parameter. The module works the same way for the condition attribute, availability, gender and age_group attributes.

 

The "Default" value means: "if product have no condition attribute set, then use the category attribute value, and if it's not set, then use the first parent category's filled setting." ... Not really clear but should be helpful ?

In other words, If Google Merchant Center doesn't accept your products because the "condition" attribute is missing, then just set the value "new" to the condition attribute while editing your root category in the module configuration page. By the way all of your shop products are exported with the condition attribute set to "new". No need to change the "Default" value for each products category.

 

 

Very very nice explanation to understand better this module. Thank you very much and I like this module, no doubt! fully designed for PS 1.6.

 

I hope updates for improvements!

Share this post


Link to post
Share on other sites

Very very nice explanation to understand better this module. Thank you very much and I like this module, no doubt! fully designed for PS 1.6.

 

I hope updates for improvements!

 

Thank you :)

Next improvement should be the currency management for different xml/flux languages. Unfortunately, to get it working correctly, there will be some modification to do in the native prestashop classes files, so an override of some of these files should be required.

I'm working on it.. :ph34r:

 

EDIT: at last no need to override any native class, last ver. of the module correctly do the job.

Edited by dimooz

Share this post


Link to post
Share on other sites

in the back office product was selected as the condition "new"

 

In the back office, you mean in the product admin page (condition attribute that you set for each product)?

or in the module admin page (condition attribute that you set in the Google Category edit form, in the GShoppingFlux module configuration page)?

Share this post


Link to post
Share on other sites

This module worked perfectly when only exporting a few categories, but then re adding all categories (67) then then the script dies when regenerating the XML file.

 

Is there any way that i get all categories to be exported. The shop is on a shared setup, so i don't have superuser access to the server setup.

Share this post


Link to post
Share on other sites

This module worked perfectly when only exporting a few categories, but then re adding all categories (67) then then the script dies when regenerating the XML file.

 

Is there any way that i get all categories to be exported. The shop is on a shared setup, so i don't have superuser access to the server setup.

 

I can try to modify the script in order to let you get all categories to be exported, but i need further information, i.e. what is the module version that you used ? Do you have several root categories attached to your shop ? Thank you for the feedback ;)

Edited by dimooz

Share this post


Link to post
Share on other sites

Dimooz: Seems like the upgrade from 1.5.2 to 1.5.4 fixed the issue. I'll get back if i still have problems after the import of ~400 products in MCC.

 

Thanks for a great product.

Share this post


Link to post
Share on other sites

Dimooz: Seems like the upgrade from 1.5.2 to 1.5.4 fixed the issue. I'll get back if i still have problems after the import of ~400 products in MCC.

 

Thanks for a great product.

 

Thank you so much for this info, I modified the script especially trying to get rid of this "Gateway Timeout" error. You're the first one to confirm that this modification is really efficient. ^_^

Edited by dimooz

Share this post


Link to post
Share on other sites
Hi,

 

When I install the module has given me the following error message:

 

[PrestaShop] Fatal error in module gshoppingflux:

Call to undefined method GCategories :: getRoot ()

 

Although I get installed and try to run get the same error. What problem can I be ?, have version 1.5.6.2

 

Thanks for the help

Share this post


Link to post
Share on other sites

 

Hi,
 
When I install the module has given me the following error message:
 
[PrestaShop] Fatal error in module gshoppingflux:
Call to undefined method GCategories :: getRoot ()
 
Although I get installed and try to run get the same error. What problem can I be ?, have version 1.5.6.2
 
Thanks for the help

 

 

There's no more getRoot function in module v 1.5.4, please try the last zip archive available in topic...

Share this post


Link to post
Share on other sites

What are the posibiliities to make make more than one feed? Managing ~400 products in one feed in Adwords are time consuming and i would like to have different ads for different product groups.

 

The products all come from the same supplier, so i have no filtering possibilities on that one.

Share this post


Link to post
Share on other sites

What are the posibiliities to make make more than one feed? Managing ~400 products in one feed in Adwords are time consuming and i would like to have different ads for different product groups.

 

The products all come from the same supplier, so i have no filtering possibilities on that one.

 

Maybe it's time consuming, but this module is not made to let you manage several different products feed. However, I think you're still able to manage different ads for different products group in Google Shopping, even with only one feed (?)

 

If it's really a pain for you to manage all the shop products in only one feed, you can manually export some of your categories in one feed first, then rename it, and generate a second feed with other categories afterwards. By the way you'll have 2 feeds available on your server, and you can ask Google to load each one separately. Problem is that the cron task is made to load only one configuration to export products, so you'll have to choose which feed you want to be automatically generated by the system... Obviously, the second feed will have to be generated manually.

Edited by dimooz

Share this post


Link to post
Share on other sites

Hi All,

 

any attempt to exporting ends this error.

[PrestaShop] Fatal error in module ImageManager:
Maximum execution time of 30 seconds exceeded

Can I somehow solve myself or I need to contact the administrator of hosting?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi All,

 

any attempt to exporting ends this error.

[PrestaShop] Fatal error in module ImageManager:
Maximum execution time of 30 seconds exceeded

Can I somehow solve myself or I need to contact the administrator of hosting?

 

Thanks.

Shared Host or dedicated server ?

Share this post


Link to post
Share on other sites

Hi All,

 

any attempt to exporting ends this error.

[PrestaShop] Fatal error in module ImageManager:
Maximum execution time of 30 seconds exceeded

Can I somehow solve myself or I need to contact the administrator of hosting?

 

Thanks.

 

It seems that your ImageManager module is not correctly installed.. pretty weird ? I guess you should try to update your Prestashop before using this module. What version of prestashop do you use? and what is the module version?

Share this post


Link to post
Share on other sites

This module was exactly what I was looking for, but I get this error message every time I try to compile the feed:

 

[PrestaShop] Fatal error in module DbPDO:
Allowed memory size of 33554432 bytes exhausted (tried to allocate 43 bytes)

 

Is there a correction for this?

Share this post


Link to post
Share on other sites

This module was exactly what I was looking for, but I get this error message every time I try to compile the feed:

 

[PrestaShop] Fatal error in module DbPDO:

Allowed memory size of 33554432 bytes exhausted (tried to allocate 43 bytes)

 

Is there a correction for this?

 

You're not the only one to encounter this issue. But as I'm not able to reproduce the problem on my servers, I don't know how to debug it correctly. That could comes form many parts... Have you thought to modify your php.ini (i.e.) to extend the default memory size for your scripts ? Are there lot of products in your shop ? Is your root category outside of the default root directory ? The simpliest way is that you send me a copy of your extracted database (remove passwords if any) by the way I should be able to create a copy of your site and its configuration on my test server. It's up to you.

Share this post


Link to post
Share on other sites

You're not the only one to encounter this issue. But as I'm not able to reproduce the problem on my servers, I don't know how to debug it correctly. That could comes form many parts... Have you thought to modify your php.ini (i.e.) to extend the default memory size for your scripts ? Are there lot of products in your shop ? Is your root category outside of the default root directory ? The simpliest way is that you send me a copy of your extracted database (remove passwords if any) by the way I should be able to create a copy of your site and its configuration on my test server. It's up to you.

I haven't thought to increase the default memory, frankly......I wasn't sure how to do that. I have about 1400 +\- products iincluding combinations and have been using Prestacenter XML Export for a few weeks without any problems whatsoever. But, that module doesn't allow for matching to the google categories.

Share this post


Link to post
Share on other sites

Prestacenter XML... is it free ?

Yes, there is a free and a paid version. I use the free version, and like I said..it does everything flawlessly except for the google category matching...which is very important, and what I liked about yours so much! :-)

Share this post


Link to post
Share on other sites

Yes, there is a free and a paid version. I use the free version, and like I said..it does everything flawlessly except for the google category matching...which is very important, and what I liked about yours so much! :-)

Ok, I'll try to have a look at this module in order to find where comes from the problem with mine. I'll tell you asap. thx for the info anyway ;)

Share this post


Link to post
Share on other sites

Ok, I'll try to have a look at this module in order to find where comes from the problem with mine. I'll tell you asap. thx for the info anyway ;)

Good deal, I appreciate it!

Share this post


Link to post
Share on other sites

It seems that your ImageManager module is not correctly installed.. pretty weird ? I guess you should try to update your Prestashop before using this module. What version of prestashop do you use? and what is the module version?

I have PrestaShop 1.6.0.9 

What is ImageManager module?

 

Thanks

Share this post


Link to post
Share on other sites

I haven't thought to increase the default memory, frankly......I wasn't sure how to do that. I have about 1400 +\- products iincluding combinations and have been using Prestacenter XML Export for a few weeks without any problems whatsoever. But, that module doesn't allow for matching to the google categories.

Where might I find the php.ini file?

Share this post


Link to post
Share on other sites

There's no more getRoot function in module v 1.5.4, please try the last zip archive available in topic...

 

Thank you very much, this version could install and works, but as in a previous case in my store I drive about 160 categories and about 2200 products combinations and only a very small part of them is generated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×