Jump to content
seb6868

( RESOLU ) probleme site prestashop redirige vers localhost

Recommended Posts

Bonjour,

je suis novice et je bloque sur un probleme.

j'ai fait une boutique avec prestashop 1.6 en local, et aprés l'avoir mise en ligne, l'adresse www.monsite.com redirige vers localhost/prestashop.

j'ai modifier l'url avant la mise en ligne, vérifié les tables PS_Domain et modifié le fichier setting mais rien n'y fait. Si quelqu'un a une idée.

Edited by seb6868 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

j'ai déjà eu ce souci et il a été réglé en vidant cache et cookies du navigateur. Essaye ;)

Share this post


Link to post
Share on other sites

merci de votre réponse, mais ca ne change rien et j'ai le probleme avec d'autres pc, ca doit venir de la config mais je ne vois pas ce que j'ai oublié.

Share this post


Link to post
Share on other sites

la table PS_SHOP_URL est correctement configurée ?

Le fichier settings.inc.php également ?

Share this post


Link to post
Share on other sites

PS_SHOP_DOMAIN et PS_SHOP_DOMAIN_SSL ok et le settings.inc est ok également, ca ma met également ce message au chargement Link to database cannot be established: SQLSTATE[HY000] [2002] No such file or directory

Share this post


Link to post
Share on other sites

PS_SHOP_DOMAIN et PS_SHOP_DOMAIN_SSL ok et le settings.inc est ok également, ca ma met également ce message au chargement Link to database cannot be established: SQLSTATE[HY000] [2002] No such file or directory

Bonjour

 

J'ai vu ce genre de message d'erreur quand c'était le serveur de la base de donnée qui ne fonctionnait pas, donc l'erreur n'a rien à voir ni avec les éléments de connexion, ni avec prestashop.

Vous êtes chez OVH ?

Share this post


Link to post
Share on other sites

Bonjour,

je suis novice et je bloque sur un probleme.

j'ai fait une boutique avec prestashop 1.6 en local, et aprés l'avoir mise en ligne, l'adresse www.monsite.com redirige vers localhost/prestashop.

j'ai modifier l'url avant la mise en ligne, vérifié les tables PS_Domain et modifié le fichier setting mais rien n'y fait. Si quelqu'un a une idée.

Videz le cache smarty :

 

1.6.x  /cache/smarty/cache & /cache/smarty/compile

Supprimer tous les fichiers et dossiers sauf le index.php s'il y est.

 

Si vous avez transférer de local vers serveur distant et que vous avez accès au dossier d'administration désactivé l'url rewrinting et activé de nouveau pour régénérer le .htaccess

Share this post


Link to post
Share on other sites

je suis chez one and one et je n'ai pas accès au dossier, pour les caches c ok

Share this post


Link to post
Share on other sites

je suis chez one and one et je n'ai pas accès au dossier, pour les caches c ok

Bonjour

 

Vous n'avez pas accès au dossier ? c'est à dire vous n'avez pas de connexion ftp et dans la gestion de votre hébergement vous n'avez pas accès au fichiers ?

Share this post


Link to post
Share on other sites

je suis sous prestashop 1.6 et je ne trouve pas de table PS_SHOP_URL

Dans phpmyadmin c'est dans la colonne de gauche sous ps_shop

Share this post


Link to post
Share on other sites

merci, problème résolu, en fait il manquait cette table dans ma base, je l'ai importée, configurer et ça fonctionne.merci

Share this post


Link to post
Share on other sites

Bonjour

 

Ok donc c"est bon ?

 

Votre problème est résolu merci de bien vouloir mettre [Résolu] devant le sujet de votre 1er post en cliquant sur Modifier, puis Utiliser l'éditeur complet.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More