Jump to content
Pascal - Netenvie

Problème entre les modules Mail Alerts et Chronopost

Recommended Posts

Bonjour,

 

Nous sommes face à un problème un peu compliqué qui semble intervenir entre les modules Mail alerts et Chronopost & ChronoRelais (par Oxileo) sur un PRestashop 1.5.6.2.

 

Le problème est que le module Mail alerts utilise l'adresse de livraison spécifiée à l'étape 3 (Adresse) et pas celle choisie avec le module Chronopost & ChronoRelais à l'étape 4 (Frais de port).

 

Pourtant après la confirmation de commande si on regarde dans la base le champ id_address_delivery de la table orders correspond bien à l'adresse choisie avec le module Chronopost.

 

En toute logique il semble que le module Chronopost vienne mettre à jour le champ id_address_delivery après que le module Mail Alerts effectue l'envoi des emails ...

 

Pour info :

  • la même configuration fonctionnait parfaitement sur la version 1.4.8.
    Donc apparement l'ordre d'éxécution des modules a changé entre les deux versions.
  • Nous avons changé l'ordre des positions des modules dans le header mais ça ne fonctionne pas.

 

 

Comment régler ce problème ?

 

Merci.

Edited by Pascal - Netenvie (see edit history)

Share this post


Link to post
Share on other sites

Bon en fait c'est tout bête, il suffit de bien ordonner les modules, sauf que par défaut ils sont dans une position cachée.

Donc bien afficher les poitns d'ancrage cachés ...

Edited by Pascal - Netenvie (see edit history)

Share this post


Link to post
Share on other sites

Bonjour Pascal,

Je me trouve face au même problème, pouvez-vous m'expliquer un peu plus votre démarche ?
Qu'entendez-vous par "bien ordonner les modules " ?
J'ai bien activé les points d'ancrage cachés mais je ne sais pas où je dois déplacer le module "alerte par e-mail".

Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

Donc voici la solution pour ce problème:

Dans votre BO de PS, dans l'onglet "module", allez dans position.
Là, il faut simplement inverser le module "Alertes par e-mail" et le module "Chronopost" dans la section :"ActionValidateOrder"
Pour exemple, je me retrouve avec :

-1 Chronopost
-2 Videodesk
-3 Avis vérifié
-4 Alertes pas e-mail.

Solution testé, ça fonctionne ! =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More