[FREE MODULE] Product Export Module v2.4.1 (UPDATED 04/08/15) - Free Modules & Themes - PrestaShop

Jump to content

Photo

[FREE MODULE] Product Export Module v2.4.1 (UPDATED 04/08/15)

export products free module csv export multistore export csv

#1

Posted 18 December 2009 - 10:51 AM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts

*
POPULAR

Export Products

 

Export products generates you a CSV file which will match the Prestashop import functionality. This allows you to quickly make bulk changes to your store with minimal effort.

 

Features

  • Export all products
  • Export by products by category.
  • CSV delimiter - lets you set the delimiter of the CSV export. 
  • Choose to export only active items.
  • Language select. Only export products in your desired language.
  • Multistore Support.
  • Advanced Stock Management Support.
  • Adds a link to your admin menu for ease of use. (You no longer have to dig through the modules page to use this). 

To use the module after install just navigate to the following:

"Advanced Parameters > Export Products"

 

Attached File  exportproducts_v2.4.2.zip   13.67KB   52 downloads

Attached File  exportproducts_v2.4.1.zip   9.61KB   243 downloads

 

I've also released a Pro version of this module which will export product combinations, categories, addresses & customers. You can read more about it here

 

CHANGE LOG

 

UPDATE v2.4.2 (27/08/2015)

- Fix empty cell spacing.

 

UPDATE v2.4.1 (04/08/2015)

- Fix syntax error is category function.

- Fix notice error in warehouses if using advanced stock.

 

UPDATE v2.4 (30/07/2015)

- Multistore bug fix for category display.

 

UPDATE v2.3 (23/07/2015)

- Multistore support

- Advanced Stock Management Support

- Fixed created date format.

 

UPDATE v2.2 (08/04/2015)

- Fix for warehouse name export.

- Fix for UTF8 support in Excel on windows.

 

UPDATE v2.1 (10/03/2015)

- Fix for notice errors

- Fix for categories

 

UPDATE v2.0

Complete Rewrite for Prestashop 1.6+


Edited by leemarkwood, 27 August 2015 - 10:35 AM.

http://oavea.com - Custom Modules & Themes


#2

Posted 18 December 2009 - 11:28 AM

JAKCRABBIT

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 2684 Active Posts
Wow, it look amazing, hurry i try it :)

logosamolepkyprestashop.jpg


#3

Posted 18 December 2009 - 12:19 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Thanks, Let me know how you get on.

http://oavea.com - Custom Modules & Themes


#4
gra

Posted 18 December 2009 - 12:35 PM

gra

    PrestaShop Newbie

  • Members
  • Pip
  • 11 Active Posts
Using ver 1.25. Installs OK, but getting the following error when clicking configure.

Table 'prestashop.ps_export_set' doesn't exist

SELECT * FROM `ps_export_set`


-- Graham
-- Graham (www.bestbooksforkids.com.au)

#5

Posted 18 December 2009 - 12:36 PM

mohsart

    PrestaShop Addict

  • Members
  • PipPipPip
  • 749 Active Posts
Great! :-)
However, some characters get garbled, eg the Swedish å, ä, and ö; I believe this can be sorted with utf8_decode() but don't see right away where to insert it...

/Mats
My blog about using PrestaShop
My shops: Spel (1.4.3) HandKraft (1.5.2)
I help for free, but you may donate a small sum via PayPal to shop@mohsart.se if you feel that I've been helpful

#6

Posted 18 December 2009 - 12:39 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Ok, I'll have a look into your problem Graham.

Also, I hadn't thought about different character sets. I shall update asap.

http://oavea.com - Custom Modules & Themes


#7

Posted 18 December 2009 - 12:48 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Graham,

I'd left out the set table's sql from the install sql file.

CREATE TABLE IF NOT EXISTS `ps_export_set` (  `id` int(10) unsigned NOT NULL auto_increment,  `set_name` varchar(200) NOT NULL,  `set_values` text NOT NULL,  PRIMARY KEY  (`id`)) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=1;


Running the above sql in phpMyAdmin should do the trick. If you dont have access to phpMyAdmin pm me and i'll help you out.

http://oavea.com - Custom Modules & Themes


#8

Posted 18 December 2009 - 12:54 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
I've added utf8_decode() to the exportproducts.php file. Just download a new copy and upload the exportproducts.php file.

Could you let me know if thats fixed the character encoding issues :)

http://oavea.com - Custom Modules & Themes


#9

Posted 18 December 2009 - 01:04 PM

mohsart

    PrestaShop Addict

  • Members
  • PipPipPip
  • 749 Active Posts
Yes, works perfect now.
Great job :-)

/Mats
My blog about using PrestaShop
My shops: Spel (1.4.3) HandKraft (1.5.2)
I help for free, but you may donate a small sum via PayPal to shop@mohsart.se if you feel that I've been helpful

#10

Posted 18 December 2009 - 01:07 PM

junnecito

    PrestaShop Fanatic

  • Moderators
  • 1633 Active Posts
Hi Imwood:
Thanks for this nice module, will be posible to upload pics also?
Thanks again

#11
gra

Posted 18 December 2009 - 01:13 PM

gra

    PrestaShop Newbie

  • Members
  • Pip
  • 11 Active Posts
Still having some issues. Getting to the configure page now but seeing:

Notice: Undefined index: export_data in D:\localhost\www\bestbooksforkids\modules\exportproducts\exportproducts.php on line 83

Should clarify that I am running a test site (locally using Wampserver), and I have had issues (resolved I hoped) with my database due to hung Prestashop upgrade in the past.

- Graham
-- Graham (www.bestbooksforkids.com.au)

#12

Posted 18 December 2009 - 01:21 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Graham,

Thats just a notice to tell you that my coding isnt the best practice at that part in the script. I'll quickly ammend my sloppy code.

Cheers,
Lee.

http://oavea.com - Custom Modules & Themes


#13

Posted 18 December 2009 - 01:26 PM

Jaap Visser

    PrestaShop Apprentice

  • Members
  • PipPip
  • 28 Active Posts
Still have this issue:

SELECT * FROM `ps_export_fields`

Please help me out :)

#14

Posted 18 December 2009 - 01:26 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Updated once again, download a new copy and overwrite the files and you shouldn't see that error notice.

http://oavea.com - Custom Modules & Themes


#15

Posted 18 December 2009 - 01:28 PM

Jaap Visser

    PrestaShop Apprentice

  • Members
  • PipPip
  • 28 Active Posts
Still the same problem: SELECT * FROM `ps_export_fields` :S

#16

Posted 18 December 2009 - 01:28 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
Jaap Visser,

Could you be more specific please. It's hard for me to know the exact cause. Its more than likely that the install has failed.

http://oavea.com - Custom Modules & Themes


#17

Posted 18 December 2009 - 01:30 PM

Jaap Visser

    PrestaShop Apprentice

  • Members
  • PipPip
  • 28 Active Posts
I've download the new version...
Install it in the back office...
Try to run the module and get this screen notice:
-----------------------------------------------------------
Table 'prestashop.ps_export_fields' doesn't exist

SELECT * FROM `ps_export_fields`
-----------------------------------------------------------

#18

Posted 18 December 2009 - 01:33 PM

leemarkwood

    PrestaShop Apprentice

  • Members
  • PipPip
  • 146 Active Posts
If you have phpMyAdmin or another tool you can run an sql command in then please run the following code on your database.

CREATE TABLE IF NOT EXISTS `ps_export_fields` (    `id` int(10) NOT NULL auto_increment,    `field_name` varchar(50) NOT NULL,    `database_name` varchar(50) NOT NULL,    `category` varchar(50) NOT NULL,    `position` int(2) NOT NULL default '0',    PRIMARY KEY  (`id`)) ENGINE=MyISAM  DEFAULT CHARSET=latin1 AUTO_INCREMENT=1;        CREATE TABLE IF NOT EXISTS `ps_export_set` (  `id` int(10) unsigned NOT NULL auto_increment,  `set_name` varchar(200) NOT NULL,  `set_values` text NOT NULL,  PRIMARY KEY  (`id`)) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=1;INSERT INTO `ps_export_fields` (`id`, `field_name`, `database_name`, `category`, `position`) VALUES(1, 'Product Id', 'id_product', 'products', 0),(2, 'Product Reference', 'reference', 'products', 0),(3, 'Name', 'name', 'products_lang', 0),(4, 'Short Description', 'description_short', 'products_lang', 0),(5, 'Long Description', 'description', 'products_lang', 0),(6, 'Quantity', 'quantity', 'products', 0),(7, 'Price', 'price', 'products', 0),(8, 'Wholesale Price', 'wholesale_price', 'products', 0),(9, 'Supplier Name', 'id_supplier', 'products', 0),(10, 'Manufacturer', 'id_manufacturer', 'products', 0),(11, 'Tax %', 'id_tax', 'products', 0),(12, 'Categories', 'id_category_default', 'products', 0),(13, 'On Sale', 'on_sale', 'products', 0),(14, 'Reduction Price', 'reduction_price', 'products', 0),(15, 'Reduction %', 'reduction_percent', 'products', 0),(16, 'Reduction From', 'reduction_from', 'products', 0),(17, 'Reduction To', 'reduction_to', 'products', 0),(18, 'Supplier Reference', 'supplier_reference', 'products', 0),(19, 'Weight', 'weight', 'products', 0),(20, 'Date Added', 'date_add', 'products', 0),(21, 'Active', 'active', 'products', 0),(22, 'Meta Title', 'meta_title', 'products_lang', 0),(23, 'Meta Description', 'meta_description', 'products_lang', 0),(24, 'Meta Keywords', 'meta_keywords', 'products_lang', 0),(25, 'Available Now', 'available_now', 'products_lang', 0),(26, 'Available Later', 'available_later', 'products_lang', 0),(27, 'Tags', 'tags', 'products', 0),(28, 'Accessories', 'accessories', 'products', 0);

http://oavea.com - Custom Modules & Themes


#19
gra

Posted 18 December 2009 - 01:35 PM

gra

    PrestaShop Newbie

  • Members
  • Pip
  • 11 Active Posts
Getting further for me. No errors anymore. Can install / uninstall ok. Attached picture shows what I see. (Nothing to click?)

- Graham

Attached Files


-- Graham (www.bestbooksforkids.com.au)

#20

Posted 18 December 2009 - 01:41 PM

Jaap Visser

    PrestaShop Apprentice

  • Members
  • PipPip
  • 28 Active Posts
Oke done the SQL thing, but now the same screen as GRA...



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Cookies help us deliver our services. By using our services, you agree to use our cookies.     Learn more