Jump to content
thepan

EU-Legal Lieferzeit doppelt in Kategorieansicht

Recommended Posts

Guten Tag

 

Vorwort: Alle Cache Optionen sind deaktiviert.

Ich versuche grade EU-Legal mit einem Drittanbieter Template zum laufen zu bringen.

Frische 1.6.0.9 Installation mit frisch installiertem EU-Legal 1.0.5.

Dann die neuste Version des Templates welches mit 1.6.0.9 kompatibel ist installiert.

So weit so gut.

Habe dann festgestellt, dass es einen Javascript Error gibt. Das Template hatte nicht das Jquery-plugin "Totalstorage". Hab dieses Plugin zum "Autoload" Ordner des Templates hinzugefügt und damit läuft alles auch wie es soll. Außer das es jetzt in der Kategorieansicht  unter den Produkten zweimal das "Gewicht" und die "Lieferzeit" anzeigt.

AVbG32n.jpg

 

 

Hab dann erstmal einen Tag lang den Programmcode von EU-Legal durchforstet und keine andere Lösung gefunden als in der Datei 

/public_html/modules/eu_legal/views/js/legal.js

in der Zeile 19 "brindGridLegal()" zulöschen und damit die Funktionen "bindGridLegal" und "displayLegal" nicht mehr aufzurufen.

15 $(document).ready(function(){
16	
17	/* category pages => list and grid view */
18	if (typeof page_name != 'undefined' && !in_array(page_name, ['product']))
19		bindGridLegal(); 
20	
21	/* product pages combinations/attributes */
22	else

Damit hat es dann auch funktioniert und er zeigt mir nur einmal das "Gewicht" und die "Lieferzeit" an.

Nur kann es doch nicht die Lösung sein. Irgendwas in den beiden Funktionen "bindGridLegal" und "displayLegal" muss doch dafür verantwortlich sein, dass "Gewicht" und "Lieferzeit" zweimal angezeigt werden.  Außerdem könnten ja noch andere Fehler durch das löschen entstanden sein, die Ich bis jetzt nicht gefunden habe.

 

Hat irgendjemand eine Idee wie man es richtig lösen kann?

Bin für jeden Tipp dankbar

Edited by thepan (see edit history)

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

Aktuell habe ich dies Problem bei mir auch. In der Kategorieansicht wird die Lieferzeit zwei Mal angezeigt...

Cache habe ich geleert und ausgeschaltet, der Hook ist auch nur einmal in der product-list.tpl meines Templates.

 

PrestaShop version: 1.6.0.11

EU Legal 1.1.2

 

Kann mir jemand vielleicht behilflich sein?

Vielen Dank vorweg,

 

Michael

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

ich habe das gleiche Problem. 1.6.0.14 und E.L. v1.4.0.

Lieferzeit wird sogar dreimal angezeigt, zweimal über und einmal unter "kaufen". "inkl. MwSt." fehlt in Modulen wie "new product slider" die auf der Startseite angezeigt werden.

 

Mensch, hat denn keiner ´ne Lösung für uns  :rolleyes:

 

Gruß, Andre

Share this post


Link to post
Share on other sites

Willkommen Ihr Beiden,

 

Euer problem hat mit dem von thepan nix zu tun (fremdtemplate)

 

Standart-Template:

Lösung: suche benutzen (wie schon hundertmal beschrieben:)

template kompilieren

cache löschen

browser-cache löschen

anderen browser nehmen

Share this post


Link to post
Share on other sites

Willkommen kulli,

 

der Fehler der oben beschrieben wird exisitiert tatsächlich so!

Ich habe mir damit geholfen, dass ich per CSS die Felder ausgeblendet habe.

 

Weiterhin bindet das EU Legal Modul (v1.4) den Verfügbarkeitshinweis VOR dem DIV-tag mit Lieferzeit ein. Sodass da steht "Sofort" und drunter dann "Lieferzeit: ".

Das gleiche geschieht auf der Produktdetail-Seite.

Share this post


Link to post
Share on other sites

es ging um die doppelten/dreifachen Lieferzeiten-zeile  -  das war im märz  -  sollte seit dem patch nicht mehr auftreten ?

Share this post


Link to post
Share on other sites

Guten Morgen. Bei mir taucht dieses Problem auch auf - Lieferzeit wird 3 fach angezeigt. 

 

Gibt es schon eine Lösung dafür ?

Share this post


Link to post
Share on other sites

Hallo,

 

erstmal ein riesen Lob an Prestashop, ich habe schon mit einigen Shopsystemen gearbeitet.

Aber Presta finde ich richtig geil.

 

Ich habe auch so ein schönes Problem.

Doppelte und bei Sonderangebot dreifache Lieferzeit.

Die mwst. wird nicht angezeigt.

Siehe abbildung.

 

 

Prestashop Version: 1.6.1.1

Europäische Rechtssicherheit v1.5.0

 

 

fehler.jpg

 

Wenn ich jetzt bei

Voreinstellungen / Produkte / Bestandsverwaltung aktivieren

auf "Ja" klicke, ist es für eine Kurze Zeit alles richtig.

 

Kurze Zeit später, taucht die doppelte und bei Sonderangebot die dreifache Lieferzeit wieder auf.

 

Dann mache ich wieder bei

Voreinstellungen / Produkte / Bestandsverwaltung aktivieren

auf "Nein" und es ist für eine paar Klicks wieder alles in Ordnung.

 

Habe das Module "Europäische Rechtssicherheit" schon deinstalliert und wieder installiert.

 

Ich habe noch einen 2 Shop,

gleiche Versionen, da habe ich den Fehler nicht.

 

Weiss leider nicht woran es liegt!

Hat jemand einen Idee?

Edited by matce84 (see edit history)

Share this post


Link to post
Share on other sites

willkommen

 

Du bist im Thema eu_legal und nicht bei Europäische Rechtsicherheit

 

das sind zwei paar schuhe, auch wenn sie ähnlich sind; mach lieber einen neuen Thread auf mit möglichst vielen infos

 

cache leeren,

template kompilieren

und anderen Browser (der die Seite noch nciht gesehen hat) zum testen nehmen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More