Jump to content

Recommended Posts

Boa noite, pessoal.

 

Sou novo na comunidade e tenho pouquíssimo conhecimento sobre o Prestashop, antes de vir aqui procurei alguns tópicos no fórum para ver se alguém havia respondido a minha dúvida, como não achei nada resolvi criar meu próprio tópico. Tentarei ser o mais detalhista possível.

 

Minha hospedagem fica no GoDaddy, então realizei a instalação do Prestashop 1.6.0.9 conforme tutorial do site, criando uma pasta no meu "Gerenciador de Arquivos" para ser a raíz, chamada "Loja", onde aloquei todos os arquivos baixados.

 

Como uso Windows (e vi que existem alguns problemas por causa disso), uso o Parallels Plesk e configurei o documento raíz como /loja. Também criei um banco de dados e um usuário para ele.

 

Acontece que, ao digitar a minha url, não sou redirecionado ao instalador. Simplesmente aparece uma tela branca-azulada e o título "Maintenance". Além disso, se digito minhaurl.com/loja aparece a mensagem "403 Forbidden. You do not have permission to access this document".

 

Tentando resolver o problema acessei o "Diretório virtual" e, em "Permissões de Acesso do Diretório", selecionei todas as permissões para o "Grupo do Pool de Aplicativos", replicando para todas as pastas filho esta diretriz - mas nada mudou.

 

Enfim, segui passo-a-passo a instalação do Prestashop, mas não consigo avançar para a instalação de fato.

 

Detalhe: havia instalado o prestashop na minha máquina sob a pasta raíz "/Prestashop". Como tinha ficado ridículo e estava com muitos problemas para subir um tema de minha preferência, desinstalei o programa e reiniciei todo o processo. (Também tive muuuuuito trabalho para instalá-lo da primeira vez, quando os arquivos ficavam direto no diretório raiz eu não conseguia instalar nada, apenas quando criei a pasta Prestashop e transferi todos os arquivos para dentro dela é que funcionou, motivo pelo qual, desta vez, criei uma pasta chamada Loja).

 

Desde já, obrigado por toda a ajuda.

Share this post


Link to post
Share on other sites

Mude o servidor para Linux (Apache).

Caso contrário sua loja não vai funcionar corretamente nunca.

Recomendo o Painel de controle cPanel/WHM, pelas inúmeras facilidades que oferece.

Mas existem outras opções.

 

Boa sorte.

Share this post


Link to post
Share on other sites

Mude o servidor para Linux (Apache).

Caso contrário sua loja não vai funcionar corretamente nunca.

Recomendo o Painel de controle cPanel/WHM, pelas inúmeras facilidades que oferece.

Mas existem outras opções.

 

Boa sorte.

 

Daniel, bom dia. Muito obrigado pela rápida resposta!

 

Se for para ter a loja funcionando corretamente, estou disposto a mudar para Linux, mas não tenho conhecimentos suficientes para fazê-lo. Você poderia me orientar? Assim economizo algumas dezenas de horas de pesquisa.

 

Mais uma vez, obrigado!

Share this post


Link to post
Share on other sites

Se não for um servidor dedicado, solicite ao suporte de sua hospedagem.

Normalmente eles têm opções Linux / Windows para o mesmo plano. basta solicitar.

 

Tem mais detalhes sobre um bom servidor neste post: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

 

Daniel, mais uma vez, obrigado pelo suporte.

 

Realizei a alteração para Linux, mas continuo com o problema... Ao realizar o upload do prestashop via FTP, digito minha URL/install e aparece "File Not Found (404 Error)". Coloquei os arquivos direto no "/", talvez eu deva transferi-lo para o "public_html"?

Edited by felipewitt (see edit history)

Share this post


Link to post
Share on other sites

Vc. nao precisa digitar /install. Vc. somente abre a URL e o processo de instalacao deve comecar automaticamente.

Controle se existe um ficheiro .htaccess na raíz de aonde quer instalar a loja. Se tiver, entao renomeia para .htaccess-outracoisa

 

Eu tenho o mesmo problema no meu servidor quando instalo manualmente e nao através do cPanel outra software. So redirecionado para 404, pois no meu public_html existe um wordPress. Para que este aceite outros projetos em outro domínio ou sub-pastas eu primeiramente tenho que renomear o .htaccess principal, ou entao adicionar a sub-pasta como "allowed" ao .htaccess da raíz.

 

Provavelmente vc. está tendo o mesmo problema. Se nao conseguir resolver, converse com o seu provedor. Algum ficheiro .htaccess anterior ou seja uma instancia anterior a qu está querendo usar, está impedindo a instalacao.

Share this post


Link to post
Share on other sites

Pessoal, bom dia.

 

Transferi os arquivos para a pasta "public_html" e tudo funcionou, a instalação foi concluída, o site apareceu funcionando e o backoffice está lá pronto para ser usado.

 

Obrigado a todos pela atenção!

Share this post


Link to post
Share on other sites

Sim a pasta public_html é a raiz de todos os seu projetos que saem para fora. Provavelmente vc. tinha instalado na raíz do seu espaco web. Que neste caso nao é a mesma coisa...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More