Jump to content

Recommended Posts

Tento realizar a atualização através da atualização automática atualização 1 clique e aparece uma mensagem de erro apontando para File /admin1203/ajax-tab.php not removed.

 

O que devo fazer.

Share this post


Link to post
Share on other sites

Estou utilizando a versão 1.6.0.8 estou tentando mudar para 1.6.0.9

Share this post


Link to post
Share on other sites

Segue o log de atualização:

 

All files saved. Now backing up database
Database backup: 238 table(s) left...
Database backup: 142 table(s) left...
Database backup done in filename V1.6.0.8_20141022-205739-1eafdc8d. Now upgrading files...
5506 ficheiros serão atualizados.
5486 ficheiros por actualizar.
Reposição de ficheiros ...
Error when removing /admin1203/ajax-tab.php.
 
 
Erros:
 
File tools/geoip/GeoLiteCity.dat (size: 17[spam-filter]02) has been skipped during backup.
Error while copying file /admin1203/export/.htaccess
Error when trying to upgrade file /admin1203/export/.htaccess.
File /admin1203/ajax-tab.php not removed.

Share this post


Link to post
Share on other sites

Mas a loja está atualizada ? Veja lá bem em baixo no seu back.office a versao.

 

Pode ser que o seu servidor nao tinha poderes de escrita suficientes para escrever os arquivos correspondentes. Suba os mesmos através do FTP. Para isto faca o download dos arquivos que anexei, descompacta os ficheiros na sua máquina local e suba os dois arquivos para o seu FTP /admin1203 e /admin1203/export como o erro acima descreve.

.htaccess.zip

ajax-tab.zip

Share this post


Link to post
Share on other sites

Verifiquei no back office, ainda está 1.6.0.8. Eu preciso dar permissão de escrita nas pastas e subpastas?

Share this post


Link to post
Share on other sites

Direitos de escrita ao menos chmod 0750 na pasta /admin1203 e sub-pastas. Mas acredito que os ficheiros estavam é faltando mesmo. Verifique. Se faltavam entao também é razao do upgrade interromper e voltar com erro, pois nao pode atualizar o que lá nao existe...

Share this post


Link to post
Share on other sites

Tentei as informações descritas aqui, fiz o upload dos arquivos mais acontece a mesma coisa.

Share this post


Link to post
Share on other sites

Provavelmente é um erro de permissão.

Sem permissões automáticas (suPHP/suExec), vc terá diversos erros, em diversos módulos e funções do PrestaShop que criam / alteram arquivos.

 

Minha dica de sempre: Se puder, utilize um VPS, para poder controlar todos os parâmetros do servidor. Preferenciamente com cPanel.

 

Se não puder, troque para um servidor que atenda aos requisitos mínimos:

http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

Share this post


Link to post
Share on other sites

Acordo com o Daniel o problema está no seu servidor mesmo. Se nao puder trocar de servidor, entao desca a sua loja para um XAMPP, faca o upgrade na sua máquina local e suba tudo novamente ao seu servidor.

 

Como clonar a sua loja:

 

http://www.prestashop.com/forums/topic/313999-tutorial-how-to-clone-your-shop-for-upgrades/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More