Jump to content
daisypoo

add to cart not showing

Recommended Posts

Again, I've spent ages trawling through posts for this, nothing seems to apply

 

I've only just got Prestashop, only got the one test product in there.  

I deleted all of the products that came with the PS, prices were showing before then.  The product that's on is just bog standard,  nothing special about it at all, although I did have text and file fields, and file upload.  Thought they might be the problem, but deleted them and no change.  Did have Catalogue Mode on, switched that off (had no prices either prior to that!).  Still no cart.  

One reply I read mentioned some lines of code in theme/defaulttheme/modules/product.tpl - can't find the post now but sure this was the code:

   
<div class="unvisible">	<p id="add_to_cart" class="buttons_bottom_block no-print">
								<button type="submit" name="Submit" class="exclusive">
									<span>Add to cart</span>
								</button>

I In my product tpl.file, I can't find that code, but when I "view source" on my site I can see it

 

site is dijac.co.uk and if anyone looks at it, even if you can't help with this, can you tell me how to move that damn shopping cart!

 

thanks in advance :)

 

Share this post


Link to post
Share on other sites

as ps works out of the box, and as you have only 'one' product, maybe you should start over again with latest release.  If you do this do not 'delete' any demo data, simply disable them, for test orders simply cancel them.  don't delete 'anything', this causes more issues and in fact has caused failure of start up shops to numerous to count.

 

once we starting deleting things, we can make impact on core cart behaviors.

Share this post


Link to post
Share on other sites

Ehm did you enter a quantity for this product in the backoffice?

I guess not :)

Share this post


Link to post
Share on other sites

Ehm did you enter a quantity for this product in the backoffice?

I guess not :)

 Ehm, yes I did  :P

 

 

as ps works out of the box, and as you have only 'one' product, maybe you should start over again with latest release.  If you do this do not 'delete' any demo data, simply disable them, for test orders simply cancel them.  don't delete 'anything', this causes more issues and in fact has caused failure of start up shops to numerous to count.

 

once we starting deleting things, we can make impact on core cart behaviors.

 

I do have the latest release, but was thinking the same thing.  not really changed much so probably the best option.

 

 

Thanks for your input guys  :rolleyes:

  • Like 1

Share this post


Link to post
Share on other sites

 Ehm, yes I did  :P

 

 

 

I do have the latest release, but was thinking the same thing.  not really changed much so probably the best option.

 

 

Thanks for your input guys  :rolleyes:

 

yes, I think starting clean is good idea, you learned much already and will continue to learn.  While  we hope to open shop and start making loads of profit, in reality it is like any business much effort over time (years)...again don't delete anything and don't use cleaner module.

and back up back up back up

Share this post


Link to post
Share on other sites

OK. Downloaded PS again, and have put our header on the site 

 

Of course it's messed up the search box and the shopping cart.

 

I've saved the original files so should be able to back to the start if needed, but can you tell me how to move them?

(preferably to the top bar, where the contact us and sign in are, or along from the category tabs

 

I don't want to touch anything without some advice, cos I know what'll happen!

 

I have searched btw, but none of the replies I've found seem to fit my problem

 

Thanks in advance :)

Share this post


Link to post
Share on other sites

OK. Downloaded PS again, and have put our header on the site 

 

Of course it's messed up the search box and the shopping cart.

 

I've saved the original files so should be able to back to the start if needed, but can you tell me how to move them?

(preferably to the top bar, where the contact us and sign in are, or along from the category tabs

 

I don't want to touch anything without some advice, cos I know what'll happen!

 

I have searched btw, but none of the replies I've found seem to fit my problem

 

Thanks in advance :)

 

 

HI, now good posting advice for you.  Open new topic for each issue where search did not help.  Make sure to include a link to your Front Office (when fo question).  

 

Also as you move forward, first have good back up strategy as we may when learning need to restore.

 

Visit and learn and share here with community.  Happy PrestaShopping.

Share this post


Link to post
Share on other sites

thank you, will repost :)

 

with a link  :D

 

since this post is effectively completed, look what I released today.  

 

http://etiendas.co/

 

This is upgrade from 1.4.6.2 to 1.6.0.9 with 'paid' leo theme.  as you move forward, dont' worry about design, build category and products, shipping payment all that labor stuff.  Put a lot of hard work into it, then live at the beach. :)

  • Like 1

Share this post


Link to post
Share on other sites

What fixed it for me was:

go to Prefrences/products turn "Catalog mode" OFF then save

Share this post


Link to post
Share on other sites

This post really made my day. Turn off catalog and prestashop allows add to cart?

How funny :wacko: :wacko: :wacko: !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More