Jump to content
Vinum

[MODULE] Advanced Themes Configurator

Recommended Posts

Hi,

Our new Module Advanced Themes Configurator is validated by addons.
This is a complete overhaul of ThemeConfigurator module from prestashop to make it a real theme maker.

You can change all colors and fonts as well as the size and margin blocks, change background images etc ...
The changes are immediately visible in the front office for an administrator. They will not be visible to customers until publication of the work.

Site demo:
https://addons.prestashop.com/en/page-customization/17952-advanced-theme-configurator-theme-maker.html

Username: demo@demo.com

Password: demodemo

To see the module in front office you have to go from the back office by clicking on My Shop (top right).


The save buttons are disabled in the demo.

The module is sold for 50 euros and is available either on our site or on addons:

http://addons.prestashop.com/fr/fonctionnalites-front-office-modules-prestashop/17952-configurateur-de-themes-avance.html

thank you

Edited by Vinum (see edit history)

Share this post


Link to post
Share on other sites

Hi,

V.1.0.6 : New update for that module. Its is now possible to choose the background-repeat style for the background image.
Best regards,

Share this post


Link to post
Share on other sites

Hola, acabo de comprar el modulo en la tienda de prestashop addons y esta muy completo, y es justo lo que buscaba, pero hay un problema, no siempre guarda los cambios, tengo que cambiar varias veces el mismo cambio para que finalmente se guarde. ¿Sabes porque ocurre esto? ¿Hay alguna corrección para este problema?

 

Gracias

 

Hi, I just bought the module in the shop addons prestashop and very complete this , and it's just what I wanted , but there is a problem , not always save the changes , I have to change several times the same change to finally be saved. You know that this happens ? Is there a fix for this problem?

 

Thank You

  • Like 1

Share this post


Link to post
Share on other sites

Hi Vinum,

 

sehr sehr feines Modul. Fehlen nur noch Regler fürs Spacing;)

Und eine Hauptstandardschrift.

 

Direkt eine Frage:

 

Ändere ich im Header die Backgroundcolor, geht diese Farbe auf der Haupt/Homeseite bis zum unteren Rand des StandardSliders (über die gesamte Breite). Das hängt wohl damit zusammen das der Slider im displayHeader Hook hängt und somit den gesamten Header nach unten "ausdehnt". Wenn ich den displayHeader Hook allerdings entferne, zerschießt es mir alles. Auf der Kategorieseite gibt es den Slider nicht, dort passt alles.

 

Kennst du vllt. das Problem oder hast eine Lösung parat?

 

MfG Porter Ricks

Share this post


Link to post
Share on other sites

Hi,

Sorry but I don't speak deutch. Only french or english.

So, I don't understand what you want.

Share this post


Link to post
Share on other sites

Hi Vinum,

 

;) ok, its obvious you speek englisch. My fault, sorry.

 

At first, big thanks for your work. Its a very nice modul. Maybe you can add some slider for spacing/padding ;)

And a mainfont for all ;)

 

My question is, i change the backgroundcolor in header and on homesite is the color to the buttom from slider (100% width). The slider is hooked in displayheader and stretched the header. But when i delete the slider from displayheader, its crashed the grid.

 

On categoriepages are still not sliders, here its perfect. See attached images.

 

Maybe you know the prob or have a solution?

 

Best regards Porter Ricks

 

post-483832-0-85017400-1421795202_thumb.png

post-483832-0-17707500-1421795410_thumb.png

 

Share this post


Link to post
Share on other sites

Hi,

Can you send screen capture when you said the grid is crashed.

I think it is not due to the module .

Share this post


Link to post
Share on other sites

Hi Vinum,

 

thanks for your reply. I think the problem is not your modul, but the slider strechted the header.

At the first image, the slider (sorry, images has not the right resolution) only hooked in displaytop and crashed the side.

At second image you can see the streched header because the slider is also hooked in displayheader.

The third image its what i like ;)

 

Thanks for your help

 

post-483832-0-51846100-1421843277_thumb.png

post-483832-0-47066200-1421843163_thumb.png

post-483832-0-58548900-1421844113_thumb.png

 

Share this post


Link to post
Share on other sites

Hi,

Like that I can't to see where is the problem.

Contact us by PM and send me your email and your website url .

Share this post


Link to post
Share on other sites

Hi Vinum

 

I have just bought your Advanced Themes Configurator module and installed it. Thank you very much for creating this very useful tool. Most of it is self-explaining but maybe you do have a tutorial? For example it would be great help to know what exactly is beeing deleted when I press delete in the main menu or what breadcrums are. :mellow:   

 

Best regards,

Peter

 

 

Share this post


Link to post
Share on other sites

Hi,

Actually help is succinct because normally the module is very intuitive.
When you click on delete, all your work is deleted and you go back to zero.

The module breadcrumb (in french fil d'ariane) replace the default breadcrumb from prestashop to add the feature to update it.

Share this post


Link to post
Share on other sites

There is two differents buttons :

RESET : To reset your last update (not already saved)

DELETE : To delete all your work.The new css files are deleted and you come back to the default boostrap theme settings.

Edited by Vinum (see edit history)

Share this post


Link to post
Share on other sites

Hi,

In order to improve this module can you tell us the improvements or features that you would find in it.

 

- The next improvements will be the possibilites to save several themes and choose the theme you want to use with 2 clicks.

 

Remember, that module is only available for the default boostrap theme in prestashop >= 1.6.

 

Best regards,

Vinum Master

Share this post


Link to post
Share on other sites

HI,

Our module Advanced theme configurator has been updated.
It is now compatible with prestashop 1.7 classic theme.
https://addons.prestashop.com/en/administrative-tools/17952-advanced-theme-configurator-theme-maker.html
Be carreful:
For prestashop 1.6, that module only run with default bootstrap theme.
For prestashop 1.7, it only run with default classic theme.


If you want a configurator for all the themes, it is necessary to use that module:

https://addons.prestashop.com/en/page-customization/22092-css-magician-ultimate-themes-configurator-theme-maker.html

 

Best regards,

 

Share this post


Link to post
Share on other sites

Hi,

With this module,  which fonts are available : anyone I have in my computer or just the fonts integrated in the module ?

Thanks !

Share this post


Link to post
Share on other sites

Hi Vinum

I want to 1-click upgrade from 1.6.1.11 to 1.6.1.20 and not loose the modifications to the default bootstrap I made with your excellent Advanced Theme Configurator. So I need to know if I should, in "Upgrade Options"/"Upgrade the Default Theme" select "Yes" or "No". If possible I would like to upgrade the default bootstrap as well as keep my modifications. Thanks very much!

Best,

Peter

Share this post


Link to post
Share on other sites

Hi,
Normally you can upgrade the default theme.
The module is completely independant.
But if some html tags and so css operators have been modified with the upgrade perhaps some changes will not be safe.
Best regards,

Share this post


Link to post
Share on other sites

Hi Vinum

  I want to use paypal v3.11.1 with Prestashop 1.6.1.20. Right at the beginning of the paypal standard module configuration it says "Your Country:" (in my case) "Deutschland". When I try to change this to "Switzerland" in the drop down menu, the program doesn't accept it. Consequently all Swiss data entered (e.g. postal code) are refused and the module gets stuck. I've spent days trying to find a solution to this problem and hope that you can help. Is it possiblet hat PayPal module only works properly with the Prestashop default bootstrap and not with Advanced Themes Configurator? I'm attaching some hardcopies to illustrate the problem. You should still have my data to log into my future shop www.alfredneuman.ch/Prestashop/administrator. If not, I'll send them again.

Thank you very much,

Peter

Modules.JPG

Country.JPG

CountrySelect.JPG

HTML.JPG

Share this post


Link to post
Share on other sites

Hi,
NO the module advanced theme configurator do not interact with paypal module.

Share this post


Link to post
Share on other sites

HI,
The module advanced theme configurator have been updated to prestashop 1.7.6.0

Best regards,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More