Jump to content
  • 0
magali ferber

Official Video Tutorial - Installing PrestaShop On Your Server

Question

28 answers to this question

Recommended Posts

  • 0

Hi, I've downloaded the Prestashop but I can't follow the next step to instillation as I can't find MySQL in my squarespace website.  My admin panel looks nothing like the C panel in the tutorial.  Do you or anyone else know how to install Prestashop to squarespace please?  


 


Regards


Angela


Share this post


Link to post
Share on other sites
  • 0

downloaded 16.0.14

installed as shown in docs,

after install compleated ,  it should change the /admin folder to "newadmin name".  did not change the name. ?

no errors .

then clicked to go to backoffice , and a blank page shows. 

clicked on store front , and everything is fine. 

 

cant see anything on admin page, blank. 

when do we change the permissions,   before the install or after the install finished. ???

 

please clearify.

 

Share this post


Link to post
Share on other sites
  • 0

Hi Prestashop Experts

 

I have this problem installing Prestashop 1.6.1

 

APACHE/PHP error log:

 

 

[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error:  Call to a member function fetch() on boolean in /var/www/html/test.webstore/classes/db/DbPDO.php on line 369, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP Stack trace:, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP   1. {main}() /var/www/html/test.webstore/install/index.php:0, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP   2. InstallControllerHttp::execute() /var/www/html/test.webstore/install/index.php:31, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP   3. InstallControllerHttpDatabase->validate() /var/www/html/test.webstore/install/classes/controllerHttp.php:157, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP   4. InstallModelDatabase->getBestEngine() /var/www/html/test.webstore/install/controllers/http/database.php:85, referer: http://www.test.webstore/install/index.php
[Thu Aug 13 21:51:20 2015] [error] [client xxx.xxx.xxx.xxx] PHP   5. DbPDOCore->getBestEngine() /var/www/html/test.webstore/install/models/database.php:114, referer: http://www.test.webstore/install/index.php
 

 

Happen the same with Prestashop 1.6.0   I already try that version too.

 

I have experience on Linux apache and php, but with that error I not have idea About.

 
My configuration:
Linux Centos 6.7
MySql 5.7.7
PHP 5.6
 
Thank you for the help.
Joao Nunes
Edited by oxionstore

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

I am trying to install free module from Prestashop addons market place in my store's back office.

I checked the user guide and it says like this,

 

  • 1. In your store's back office, click on the tab to connect to PrestaShop Addons, in the upper right of the page.
  • 2. Enter your login information in the box.
    Now all of your purchases will appear directly in your list of back office modules!
  • 3. After connecting to Addons from your store's back office, click on the "Modules" tab in the menu.
  • 4. Look for the name of the module you want, click "Install", then configure it.

 

But the problem is I don't even see the tab to connect to Prestashop Addons.

I am using Prestashop version 1.6 and am newbie for this.

 

Please help!!!

Share this post


Link to post
Share on other sites
  • 0
I am a web developer and have been looking for a good alternative to Shopify and Woocommerce for my clients.
 
I like PrestaShop from what I see, however I had my IT guy try to install it and it won't install. We get to 25% and it hangs. We have looked though all the forums and blogs and we see tons of people having the same issue.
 
We have tried all of the posted solutions with no luck. I need to know if you are going to fix this issue anytime soon as there is no reason that it should not be able to install on a Linux server using the latest version of Centos and Apache under mySQL.
 

 

I look forward to your speedy response and solution to this issue.

Share this post


Link to post
Share on other sites
  • 0

 please help  am having the same problem as shown below installing prestashop through mojo market place from ipage help help

 

 

i try ad installa the prestashop on altervista but not work 

 

see image

 

nyyagz.png

 

 

installation stops but
I do not know why
there is no log file to view

 

hi help am having the same problem installing prestashop through mojo market place from ipage help help

Edited by Bogh bazaar

Share this post


Link to post
Share on other sites
  • 0

I bought out a company who used prestashop and gave me super admin access to their backoffice.  How do I change everything over from their server to a local server.  They were a small company and are not very familiar with the web stuff.

Share this post


Link to post
Share on other sites
  • 0

I dont know whats happen, but 1.6.1.7 install when try create database tables, 

give me this error:

  1. Create database tables
An error occurred during installation..

 

If i see in phpmyadmin, i have some tables, but in 12% crash.

My host is dreamhost, i run in other domain in same server 1.6.1.5 smooth,
all permision are checked to Select , Insert, Update, Delete,Create,Drop,Index,Alter.

I try many times and same. Some idea ?

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

Many thanks for installation video for 1.7 version.

I was doing unzip manually when installation version 1.7 and facing problems.

 

This video help me to know feature which unzip prestashop 1.7 zip file automatically.

I am looking for documentation link for enabling php accelerator on my ubuntu and xampp local server.

Share this post


Link to post
Share on other sites
  • 0

I"ve been trying to upgrade from 1.6.1.5 to 1.6.1.18 all week with errors.. finally decided to wipe everything and install 1.7.3 to avoid any upgrades needed in the near future... still can't get it to work.. it does not automatically unzip..   So I'm trying to install it on a local server using devserver17.. 

It DID unzip but I get these errors and have NO idea how to fix them..  any ideas or guidance, documentation, anything?

 

psPOS1.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More