Jump to content

[SOLVED] an error occurred while processing this directive

Recommended Posts

NOTE: Problem solved by replacing the php.ini with the server-wide php.ini.



I just moved my site from the old hosting to the new VPS running on CentOS 6.5 with Cpanel/WHM.

I have few other sites which already moved and running well.

But this one won't open with an error message [an error occurred while processing this directive].


When I checked the error log, I see a bunch of the following messages:

exec used but not allowed in /home/bursasp/public_html/500.shtml


I've browsed around for solutions, but found nothing that really answered my problem. I noticed there's this post but I've checked my folders and file permissions and everything looks fine.


Any help would be really appreciated.


Edited by blackkaviar

Share this post

Link to post
Share on other sites

Hi El Patron, thanks for responding  :)


I downloaded and reuploded the files and database manually.

The reason I did that manually is because on the old hosting it was an addon domain. Then I want to make it separate account on the new VPS.

But, I've tried to transfer the site using SCP as the whole account (with it's parent domain), and still having the same error message.

Share this post

Link to post
Share on other sites

Problem Solved!!


It's actually the problem with php.ini file.

After I replaced the php.ini with the server-wide php.ini (/usr/local/lib/php.ini), it worked.

Using diffchecker I can see there are quite a few difference between the original php.ini with the server-wide php.ini. 

Some settings are quite the opposite of each others, AFAIK.

Currently I got no time (actually no courage and no knowledge :) to test and find which corresponding line cause the problem.

But yeah the problem solved, so I'm happy with this.

Thanks El Patron for willing to help and giving some advise!

Share this post

Link to post
Share on other sites

This was making me crazy for a couple of days.


[an error occurred while processing the directive]


This error suddenly appeared twice in the header-container. I checked permissions on the files - all fine. And looked into the .htaccess, but couldn't find anything that showed it was looking for SSI directives.


What finally solved the problem was removing the hashtag character "#" from comments in smartblocktopmenu.tpl. The problem seems to be that the server was interpreting the comments as calls to SSI directives. Anything that looks like <!--#comment --> is interpreted as an SSI directive. Since it couldn't process the directive it returned the error. So I simply removed the hashtag "#" to make it look like <!--comment -->.


I don't know why I suddenly started getting the error message since I hadn't made any changes. But changing the comments  fixed the problem.

Share this post

Link to post
Share on other sites


Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More