Jump to content

(RESOLU) decalage produit phare entre explorer et mozilla


Recommended Posts

bonsoir,

je travaille actuellement sur la présentation de mes produits phare

j'ai modifié le nombre de colonne dans le module, modifié la taille des images etc...

l'ensemble me convient sous mozilla c'est parfait sauf que sur explorer j'ai un décalage que je n'arrive pas à résoudre et qui empêche le bon affichage du prix qui est caché sous la photo.

quelle est la subtilité pour résoudre ce soucis?

www.nuagedeperles.fr/bijoux-mariage

merci

Share this post


Link to post
Share on other sites

bonsoir,

global.css, ligne 1119, la taille ne correspond pas aux tailles des images :


#center_column div.products_block a.product_image {
background-color:transparent;
display:block;
height:129px;
margin-left:2px;
width:129px;
}



utilise 170px pour la hauteur et 212 pour la largeur, et ça devrait corriger le problème ^^

profite en pour centrer l'image dans son bloc. ça donnerai, toujours au même endroit :

#center_column div.products_block a.product_image {
background-color:transparent;
display:block;
height:129px;
margin-left:auto;
margin-right:auto;
width:212px;
}



et une largeur de bloc paire pour un effet visuel plus élégant :

global.css, ligne 1071, une valeur paire. 220, 222, mais pas 221px pour la largeur.

bonne continuation !



EDIT : si j'avais à pousser le vice suffisamment loin.... Tu es à deux doigts d'avoir une boutique totalement compatible W3C (le respect des normes donne l'impression d'une boutique réalisée avec soin, et aide pour le référencement)

Il te manque juste un attribut "alt" dans les images de ton header. ajouter un simple " alt="" " dans tes balises te ferra passer le test de validation.

Share this post


Link to post
Share on other sites

merci beaucoup pour ta réponse complète qui a résolu le problème.

il me reste un dernier détail apparu en ajoutant 3 produits supplémentaire, une large marge au bas du bloc à faire disparaître.

je me pose aussi une question car moi lorsque je selectionne le ou les blocs avec firebug je ne vois jamais la ligne 1119?
est-ce que c'est moi qui l'utilise mal? peut-être que je passe à côté de certaines choses à cause de ça?


(merci pour le alt j'attendais d'avoir tout terminé pour faire la validation mais puisque tu m'y fait penser je vais aller le faire)

Share this post


Link to post
Share on other sites

Salut,

Dans le module homefeatured, il y a un fichier nommé "homefeatured.tpl".

Ligne 11, tu as

></pre>
<ul>



Supprime l'attribut height pour supprimer le bloc en dessous (ça donnera

  • , tout simplement.)

    Sinon, l'utilisation de firebug demande un peu de pratique, c'est tout.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More